LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-16-2004, 01:32 PM   #1
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,291

Rep: Reputation: 52
mounting ntfs for users on laptop


Work this out!

I have had an ongoing issue with my ntfs partition on my laptop: users cannot read it.
my line in fstab is (or was):

/dev/hda2 /mnt/xp ntfs noauto,user,nosuid,ro,umask=777 1 0

I could never get it to mount and be readable by the user. I've just been fiddling around and found that if I look at the permissions of /mnt/xp when it is mounted it's 144

I then changed the "umask=#" part to "umask=555". The mounted permissions then changed to 504!

So, using bad logic I tried "umask=144". The permissions of /mnt/xp when mounted is now 555.

Put that in yer pipe and smoke it!
 
Old 05-16-2004, 01:45 PM   #2
Stuartb21
Member
 
Registered: Jun 2003
Location: U.K
Distribution: Slack - Current
Posts: 55

Rep: Reputation: 15
Try umask=000 that allways works for me on fat 32, not tried ntfs tho
 
Old 05-16-2004, 02:54 PM   #3
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,291

Original Poster
Rep: Reputation: 52
ah, im thinking the wrong way round! A umask is like a netmask no? 255.255.255.0 allows any connection to the last 256 addresses, so umask=144 changes the unset bits in the permissions! I think I understand now.
 
Old 05-16-2004, 04:00 PM   #4
Stuartb21
Member
 
Registered: Jun 2003
Location: U.K
Distribution: Slack - Current
Posts: 55

Rep: Reputation: 15
I think with anything but a linux partition you need 000 as the other f/s do not support permission bits
 
Old 05-16-2004, 10:07 PM   #5
JWhitaker1321
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Rep: Reputation: 0
Smile Here is what I use in /etc/fstab

/dev/hdc1 /mnt/windows ntfs noauto,ro,user,umask=0222 0 0

hdc1 is the ntfs partition where Windows XP resides on my Dell 5150 laptop. Don't ask me why Dell uses hdc for the hard drive instead of hda.

/mnt/windows is the folder that the windows partition is mounted to.

ntfs is the filesystem.

noauto,ro,user,umask=0222 are the mount options. I don't automount the partition, but have in the past, and it will work without problem. ro is read only, I don't want to write to the partition. user allows users to mount, so that you don't have to be root to mount. umask=0222 makes files copied from the ntfs partition have permissions rw-r--r--. 0 0 means the filesystem will not be dumped, nor checked at boot.
 
Old 05-18-2004, 04:00 PM   #6
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,291

Original Poster
Rep: Reputation: 52
Thanks for the feedback, all working now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting NTFS for all users of fedora 3 lnthai2002 Linux - Hardware 1 01-09-2005 07:21 PM
Mounting NTFS for users eggoz Linux - Newbie 1 09-26-2004 10:18 PM
Mounting NTFS for users other than root Tarwedge Slackware 19 05-20-2004 02:59 PM
Mounting NTFS drive for all users laurentbon Slackware 7 10-27-2003 06:13 AM
Mounting NTFS Partition for all users? Seph64 Slackware 3 02-27-2003 08:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration