-   Slackware (
-   -   Mounting Digital Camera (

jeff1500 12-10-2004 07:34 PM

Mounting Digital Camera
I have Slackware 9.1 and am trying to get a digital camera working
by reading the HOWTO. The sequence is below. The short story is:

/etc/rc.d/init.d/usb: No such file or directory

Can anyone offer any advice?


1. I got the following command block from the USB Digital Camera HOWTO:

echo "Please enter a directory name for the pictures."
mkdir picture/$DIRPATH

/sbin/modprobe usb-storage
mount -t vfat /dev/sda1 /mnt/camera
/etc/rc.d/init.d/usb start

mv /mnt/camera/dcim/100msdcf/*.jpg picture/$DIRPATH;
umount /mnt/camera
chown -R your_login_name picture/$DIRPATH

2. When I got to the mount command it said:
mount: /dev/sda1 is not a valid block device

3. So I looked around on the internet and then did this:
(not to say that I know what it means!)

/sbin/modprobe usbcore
/sbin/modprobe usb-storage
/sbin/modprobe usb-uhci

mount -t usbdevfs /dev/sda1 /mnt/camera

This mount command worked.
I saw a couple of small files in the /mnt/camera directory, but no pictures.

4. I continued with the commands from the USB-Camera-HOWTO and entered
/etc/rc.d/init.d/usb start

It says -bash: /etc/rc.d/init.d/usb: No such file or directory

So I looked for /etc/rc.d/init.d/usb and sure enough I couldn't find it.

5. dmesg says this:
usbvideo.c: ibmcam on /dev/video0: canvas=352x240 videosize=352x240

I tried mounting /dev/video0 to /mnt/camera and got the same error
mount: /dev/video0 is not a valid block device

6. Am I mounting successfully? I think I am.

7. Why is there no /etc/rc.d/init.d/usb ?

8. What should I do next?

wallison 12-10-2004 08:03 PM

Try /dev/sr0
That's what I use to mount mine.

Genesee 12-11-2004 02:19 PM

you didn't mention what camera you have. I believe some are mountable as plain usb storage devices, while with others you may have to use something like gPhoto2 ? -

the sections on USB in the gphoto2 docs may be helpful

also search the device list here:

if its a usb-storage device and the usb modules are loaded you should be able to mount it, probably as a vfat filesystem using the command you wrote above. make sure the camera is turned on when you try to mount, and you may have to do it as root

there is no /etc/rc.d/init.d in a default slack setup. that tutorial may have been written from a sysv-style distro's perspective

shilo 12-11-2004 02:32 PM

I don't know if this helps, but I use gtkam under Gnome to access my digital camera. I don't think I even have USB Mass-storage compiled.

Linux.tar.gz 12-11-2004 03:48 PM

mount -t vfat /dev/sda1 /mnt/thefolderyouchoosetomountin
should works with at least 50% chances.

jeff1500 12-15-2004 07:53 PM

The camera is an old freebe that someone gave me. He got it free when he signed up for earthlink ISP. It goes by the name xirlink. It works okay in broad daylight.

I'm learning how cameras work with Linux. I guess there are two kinds, 1) USB mass storage devices that can be accessed just by mounting, and 2) cameras that need drivers like the ones that come with gphoto2.

It's not a #1, I'm pretty sure it needs a driver, so I installed gtkam/gphoto2/libgphoto2 to see if that would work. I got it installed but it didn't have a driver for this camera.

I started up xsane and it recognizes the camera but I wasn't able to get to any of the images inside the camera. Can xsane look inside for images?

I appreciate the responses.

shilo 12-15-2004 09:45 PM

I don't think you can access the stored images via xsane.

There is lot's of info on xirlink online. This site has some stuff. You can use the info there to help better identify your camera. Might be easier to find help then.

jeff1500 12-17-2004 06:25 PM

That's an interesting web site about xirlink/ibmcam

I have a point an shoot camera, not a web cam.

Look below. It seems to like the ibmcam driver that comes with Slackware 9.1

I couldn't find any images on the camera but it did mount something.

I tried gtkam after "modprobe ibmcam". Nothing to see.


jeff@darkstar:~$ cat /proc/bus/usb/devices

P: Vendor=0545 ProdID=8080 Rev= 3.0a
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=ff Prot=ff Driver=ibmcam

root@darkstar:/home/jeff# mount -t usbdevfs /dev/video0 /mnt/camera
root@darkstar:/home/jeff# cd /mnt/camera
root@darkstar:/mnt/camera# ls
001 devices drivers

There are five images in the camera but nothing to see in the above directory

shilo 12-17-2004 06:52 PM

THe best I can come up with is this:

You'll note that this page is talking about the same camera, since the Vendor and Product ID #s match. Have you tried using it as a webcam to see if that works?

All times are GMT -5. The time now is 12:24 PM.