-   Slackware (
-   -   mount: Mounting /dev/sda2 on /mnt failed: Invalid argument (

dohpaz 05-24-2007 10:56 AM

mount: Mounting /dev/sda2 on /mnt failed: Invalid argument
I installed Slack 11 on an external USB hd using huge26.s. I used the reiserfs and partitioned the drive with a swap part on sda1 and root on sda2. I have been piecing together info from several threads to get this thing to boot.
Mostly this one:

I have installed the kernel modules and kernel

I created an initrd.gz

mkinitrd -c -k 2.6.13 -m reiserfs:ehci-hcd:uhci-hcd:ohci-hcd:usb-storage
and edited it by extracting it and mounting as a loop device. I edited and updated my lilo.conf with initrd = /boot/initrd.gz. reran lilo
which seemed ok expcept for the following warning:


/proc/partitions does not exist
When I boot the device it gets past the point of loading the usb modules and recognizes my usb h/d which contains an older 4gb hd.

The system then fails to complete the boot process with the following error:


mount: Mounting /dev/sda2 on /mnt failed: No such file or directory
ERROR: mount returned error code 1. Trouble ahead
mount: Mounting /dev/sda2 on /mnt failed: Invalid argument
mount: Mounting /dev/sda2 on /mnt failed: Invalid argument

I then get dropped to a sort of limited shell which I recognized as
having the same structure as the initrd file when i mounted it.

Just for kicks I tried to mount /dev/sda2 on /mnt manually and got this:


mount: /proc/filesystems: No such file or directory # not sure if this useful info or not
I'm not sure how to continue and any suggestions would be greatly appreciated.

dohpaz 05-24-2007 12:09 PM

Ok this may be due to a bad drive as I booted from the SLAX cd
and ran fsck.reiserfs which reported bad blocks. I am going to try
some stuff and will post my success/failure. :)

pixellany 05-24-2007 12:47 PM


Just for kicks I tried to mount /dev/sda2 on /mnt manually and got this:
Not sure is you meant this literally. Normally, you would mount to a mount point INSIDE of /mnt.
What was the full mount command and how is /dev/sda2 formatted?

Vincent_Vega 05-24-2007 12:54 PM


Originally Posted by pixellany
Normally, you would mount to a mount point INSIDE of /mnt.

True but a lot of times when doing things in such situations where only a single drive will be mounted temporarily - as in this case - it is perfectly acceptable and understandable to mount it at /mnt. I'm sure this person realizes they have lost all of the subdirectories for the time being.

Isn't the error most likely due to the fact that the filesystem (which contains proc and everything else) has yet to be mounted...since it failed in doing so? In which case you couldn't even expect it to mount anything or do much at all?

dohpaz 05-24-2007 01:09 PM


I see your point and the only reason I mounted to /mnt was because
thats what the linuxrc script was doing so I thought I would try the command manually.

Anyhoo I ran powermax on the quantum drive in question and it is indeed failing.

I am gonna start the whole process over with a TESTED 20bg IBM drive. :) Thanx for your help.

dohpaz 05-24-2007 01:30 PM

Well I completed the above process on the new drive and I get the same error. I guess the failing drive was just a coincidence.

Btw pixellany the drives sda2 root part is reiserfs.

I noticed some odd behaviour when booting from the Slack 11 dvd and I'm not sure if its related to my problem.

When I boot from the dvd and then mount my root part at /dev/sda2
I get:


mkdir /mount
mount /dev/sda2 /mount
Mount: special device /dev/sda does not exist

But if i then do :


fdisk -l /dev/sda 
mount /dev/sda2 /mount

The partition then mounts fine. I'm thinking maybe the two problems are related?

dohpaz 05-24-2007 02:34 PM

Well i got this working but not with reiserfs i reinstalled this time i chose to format ext2 and then i changed my mkinitrd command accordingly. Now it boots fine!

Wheeeeeeeeeeeeeeeeeeeeeeee :D

So for whatever reason reiserfs would not work for me. I only used it 'cause the guide I was following used it. I would like to try ext3 next. I chose ext2 cause I read somewhere it doesn't require initrd.gz.

gnashley 05-25-2007 02:03 AM

You need to mount your root partition on /, not on /mnt. Check your fstab, or post it here.

All times are GMT -5. The time now is 02:30 PM.