-   Slackware (
-   -   motion the correct path (

g4ry 12-28-2012 08:57 AM

motion the correct path
I've installed motion on my pc and edited the config file but one error I don't know how to solve. When I run motion without daemon on I get this error "create path:problem creating directory /usr/local/apache2: Permission denied". I think the correct path should be /var/www/ but I can't find where to point it towards in the config file.


onebuck 12-28-2012 10:22 AM

Member Response

Hopefully you used the Slackbuilds motion package;


Motion is a program that monitors the video signal from one or more cameras and is able to detect if a significant part of the picture has changed. Or in other words, it can detect motion. Motion is a command line based tool. It has no graphical user interface. Everything is setup via the command line or via a set of configuration files. Optional dependencies are ffmpeg and postgresql. Once installed, please be sure to read /usr/doc/motion-3.2.11/README for any configuration help. You will need to rename /etc/motion-dist.conf to /etc/motion.conf once you have made the changes you deem necessary. This build has not been tested with the optional postgresql included, but you're welcome to give it a go!
Please note the underlined sentence(s) above.

g4ry 12-28-2012 10:52 AM

Hi onebuck, yes I have renamed the file, but in the file I can't find no where to point motion to the correct path for Apache.

ponce 12-28-2012 02:05 PM

have you tried

grep -n apache2 /etc/motion.conf
(the -n option of grep adds the line number to the results)

g4ry 12-29-2012 10:04 AM

Thanks ponce, would the correct path be /var/www/htdocs?

ponce 12-29-2012 12:54 PM


Originally Posted by g4ry (Post 4859031)
Thanks ponce, would the correct path be /var/www/htdocs?

that is the target dir where it saves the snapshot images/movies, so any directory owned by the user that started motion will do.

it's not essential for it to be under /var/www/htdocs, as it is useful only to use the browser to check the saved images/movies, but needs an active webserver.
if you have access to that folder, you can also use an image viewer or a video player locally to see them.

All times are GMT -5. The time now is 02:00 AM.