-   Slackware (
-   -   mondorescue on Slackware 10.2 (

Swift&Smart 10-27-2006 11:29 PM

mondorescue on Slackware 10.2

I posted a message several weeks ago regarding how to control my server without a monitor.Ultimately,I fixed it with ssh to the server from my notebook.Okay,I want to upgrade to Slackware 11.0 from 10.2 now.

Before doing any upgrade,backup is inevitable.However,as long as partimage can be used only when you reboot your system with the bootdisc to do the backup with graphical mode,it's impossible to me right now because I don't have a monitor connected to the server.As a result,I want to use mondorescue to do the backup because it can backup my system without logging out or reboot.The problem is,mondorescue needs a lot of software which don't have a package in slackware.How can I solve this?

Your reply is appreciated.:)

tobyl 10-28-2006 07:28 AM

why can't you build it from source?
I see there is a source package available. If it will not build because of unsatisfied dependencies, go to

it is a great site for this purpose.

You may also want to investigate checkinstall if you are building from source.


Swift&Smart 10-30-2006 10:45 PM

tobyl,thanks for your reply.

I knew and tried two of your suggestions.First suggestion didn't help because most of the packages in mondorescue have no slackware package.I have also tried checkinstall for most of the compilation work.However,like "busybox" & "buffer",they didn't compile successfully.When I turned to rpm2tgz for those software,they did not install as usual.I found out they didn't install successfully by reading the information from pkgtool.

Do you guys have any suggestions to install mondorescue easily on Slackware 10.2/11?Please drop me a line if you do.

P.S. It's a nightmare to install mondorescue on Slackware,but not in RPM based Linux distro.

tobyl 10-31-2006 04:29 PM

It is not the most straightforward installation around, but if you really want mondorescue, I am sure you can do it. You may have to forego checkinstall for busybox.

busybox does not use the normal method to compile, try make defconfig, make , make install

buffer, from the README:
To install edit the Makefile and tailor the variables to
your local systems. Then type make.

Let us see what errors you are getting, then someone will give you more specific help.


Swift&Smart 10-31-2006 06:05 PM

tobyl,thanks for your reply.:)

You did help me a lot on the installation of busybox and buffer.I think these 2 software are the culprits of the problem.And I will try to do it tonight or next on this one.

Thanks a million.

All times are GMT -5. The time now is 11:26 AM.