-   Slackware (
-   -   Modules not found fatal error with alsa (

jimdaworm 02-17-2004 02:29 PM

Modules not found fatal error with alsa
Hey when I install slack I have no problems with my sound... (Nforce2) when installed the 2.6.2 kernel and compiled it.... and now everytime I start my computer up it complains that it is missing modules and this is a fatal error for alsa. When I startup X and load xmms it works find but as soon as I try to load more than one program that uses the sound it gives me an error that its not available.

I donīt know much about alsa but was kind of under the impression that is job was īsound serverī so more than one program could make sound at the same time.

I guess its not working!

Sorry I donīt have the exact modules its complaining about but I am at work... if it helps I can put add to the post tomorrow.


quatsch 02-17-2004 02:43 PM

when you compiled your kernel, did you compile alsa as modules? If you didn't compile alsa as modules for your soundcard, you would get those kinds of error messages.

jimdaworm 02-17-2004 03:39 PM

Good point I compiled them in... because when I compiled them as modules... the last time for some reason it tried to load them twice???

It said somthing about the modules it was trying to load were already in the kernel.

I will give it another compile... and get back to you. Do I compile EVERYTHING related to Alsa as modules??


quatsch 02-17-2004 04:08 PM

yeah. Everything related to sound is the best I think. The alsa drivers get updated all the time so you want them to be modules anyway (so you can just replace the modules w/o recompiling the whole kernel).

jimdaworm 02-17-2004 04:44 PM

Hey thanks again quatsch I will give it a go... all modulised.


jimdaworm 02-18-2004 02:17 PM

Hey I tried all modulised and now I done have any sound :( When I try to play mp3 with xmms it gives any error that /dev/dsp (I think its that one) doesnīt exist

Any Ideas??


quatsch 02-18-2004 03:09 PM

you've got the start the sound device. I'm not sure if slackware has an alsa service. If it has, start it.

The page gives you instructions on how to start alsa.

jimdaworm 02-18-2004 04:31 PM

Ok thanks I am off to read the alsa page!


All times are GMT -5. The time now is 09:38 AM.