LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   modules dont load after kernel patched (https://www.linuxquestions.org/questions/slackware-14/modules-dont-load-after-kernel-patched-30988/)

malix 09-22-2002 10:35 PM

modules dont load after kernel patched
 
I patched my kernel 2.4.19 to 2.4.20-pre7 and did make menuconfig, make bzImage, and a make dep somewhere in there. I copied the kernel image to /boot so I could boot with it, edited lilo, then did a make modules and make modules install. I think the make modules or make modules install did most everything except gave a couple errors in the end about cping drivers and such. When I rebooted the machine during the kernel loading I thought I saw some lines complaining about depmod: but it didnt show up in dmesg. I ran a make modules dep but that didnt seem to fix the problem. So the problem is I can't load any modules anymore on startup or manually running modprobe module. This is the first kernel patch i've ever attempted and I don't know if I did it exactly correct b/c the howto i read was pretty vague. I don't know how patches work either so I need some additional help in trying to get my modules working again. thanks.

-Malix

gway 09-23-2002 12:26 AM

Hi, try depmod -a
(or man depmod)

-- Gway

gway 09-23-2002 12:26 AM

BTW, did you compile it with modules support, did you?

malix 09-23-2002 08:13 PM

I did a 'depmod -a' and also tried regular 'depmod' and got 30 or so errors like:

depmod: *** Unresolved symbols in /lib/modules/2.4.20-pre7/kernel/drivers/block/paride/paride.o

My /etc/modules.conf file is also empty. I dont think that's supposed to be like that. After patching the kernel and in menuconfig, I'm fairly certain I had modules support enabled.

-Malix

tarballedtux 09-23-2002 10:03 PM

Nooooooooo! Burn whatever howto you read.

Here's the correct sequence of commands.

make menuconfig,config, or xconfig (<--whatever you usually use)
make dep
make clean (Only because you compiled previously)
make bzImage
make modules
make module_install





/etc/modules.conf is empty in Slackware. It all occurs in /etc/rc.d/rc.modules now.

--tarballedtux


All times are GMT -5. The time now is 05:47 AM.