LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-29-2003, 01:59 PM   #1
Tynoan
LQ Newbie
 
Registered: May 2003
Posts: 20

Rep: Reputation: 0
Modem issues


I am new to Lunix and have fortunately been able to figure out most of what I need to know on my own, except the modem. I am using a laptop, and /dev/modem points to /dev/ttyS4, which I am pretty sure is the modem. But when I try to dial-out, using kppp and pppsetup, it says the modem is busy. When Slack boots, it looks like it shares IRQ 11, which is what the modem is on, with something else. Any and all help is aprecciated. Remember, all help needs to be spelled out very simply- n00by here.

Last edited by Tynoan; 05-29-2003 at 02:02 PM.
 
Old 05-29-2003, 05:02 PM   #2
dcm
LQ Newbie
 
Registered: May 2003
Posts: 17

Rep: Reputation: 0
I never managed to do anything with kppp when I had a dial-up.
I suggest you try wvdial.
So far as I know there are no slack packages, so either build from source code or convert an rpm (I did this and it worked fine "rpm2tgz")
If you like, I will mail you my wvdial.tgz

Once its installed you run (as root) "wvdialconf" which auto detects the modem and the settings it needs, writing /etc/wvdial.conf. You need to edit this file, (still as root) giving the isp telephone number, your login and password.

Finally (as a non-root user) run "wvdial" and you should be on line. Don't forget to enter the isp's DNS in /etc/resolv.conf
 
Old 05-29-2003, 11:05 PM   #3
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
It is more likely that your laptop uses a Software based modem and needs a driver installed. Run "lspci -vv" to see what kind of driver you need and post back. We can direct you to the right site for your modem. Common software modems are lucent, conexant and PCTEL. The first two have good linux support. and the PCTEL can work. I have set up 4 laptop modems and once set up properly kppp, ppp-on and minicom all worked.

One issue is that the drivers are compiled and therefore need kernel sources. This is not included in the downloaded Slackware 9 but is in 8.1. You need to get a buddy to download the kernel (ftp.slackware.com /k) and save it to a cdrom or a USB flash drive so you can transfer into your machine


I am working to get precompiled modem drivers out for the common modems in Slack9 but my own laptop with a lucent modem is being repaired. Once out they should make this problem easier to deal with.

Last edited by shepper; 06-06-2003 at 02:39 PM.
 
Old 05-31-2003, 09:59 PM   #4
Tynoan
LQ Newbie
 
Registered: May 2003
Posts: 20

Original Poster
Rep: Reputation: 0
"lspci -vv" doesn't work or I did/didn't do something right, but I somehow know that it is a conexant modem.
 
Old 05-31-2003, 10:43 PM   #5
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
You need to be root to run lspci.

There are 2 types of conexant modems HSF and HCF.

This link has most of the information you need.

Conexant drivers

Again you need to have kernel sources installed before you can think about getting this to work

 
Old 06-01-2003, 08:00 PM   #6
Tynoan
LQ Newbie
 
Registered: May 2003
Posts: 20

Original Poster
Rep: Reputation: 0
I always log on as root, and it still doesn't work. Is there something I have to do first?
The first character is a capitol i, right?

The modem is HSF.
I have the 4 CD set from Slackware, but what do I need to do with the source code and modem driver?

Last edited by Tynoan; 06-01-2003 at 08:04 PM.
 
Old 06-01-2003, 08:19 PM   #7
Astro
Member
 
Registered: Jan 2003
Location: Ballston Lake, NY
Distribution: Slackware, Debian
Posts: 665

Rep: Reputation: 30
The modem in my laptop (running slack 9 rc-2) is picked up on boot by the pcmcia card manager stuff. All I did to get it working was from a console running pppsetup then when that is done running ppp-go or ppp-on to start it.
 
Old 06-01-2003, 08:26 PM   #8
Tynoan
LQ Newbie
 
Registered: May 2003
Posts: 20

Original Poster
Rep: Reputation: 0
LOL its a lower-case L.
 
Old 06-01-2003, 08:34 PM   #9
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
It is a lower case L. It will list your pci devices.

If you have the 4 disk set you are set. If you have problems compiling it means you don't have the /d and /k packages installed

Download this driver. It will fit on a 1.44 floppy.
http://www.linuxant.com/drivers/hsf/...s-license.htmlConexant HSF driver

To mount the floppy on a linux system type as root
"mount -t vfat /dev/fd0 /mnt/floppy"
Then change directory to /mnt/floppy " cd /mnt/floppy"

ls (LS lower case) to show the contents of the floppy
Then copy to a directory in your system. I chose the /root directory
"cp hsflinmodem*.tar.gz /root/conexant/

The cd to /root/conexant
unmount the floppy "umount /mnt/floppy

then follow these pasted instructions from the conexant site.



METHOD C: TAR PACKAGE (*.tar.gz)

If you have obtained the driver package in tar format:

1. extract the package with "tar -xzf hsflinmodem-{version}.tar.gz"

2. change to the package directory with "cd hsflinmodem-{version}"

3. run "make install" from the top of the package directory.
(Debian users might need to change the KERNELSRC definition in
modules/common.mak first)

4. run "hsfconfig" to complete the installation and configure your modem.

(Alternatively to this whole procedure you may generate RPMS from the tar
package using rpm -ta hsflinmodem-{version}.tar.gz")




It should set up a link /dev/modem -> /dev/ttySHSF0

in kppp setup you should select /dev/modem


Last edited by shepper; 06-01-2003 at 09:09 PM.
 
Old 06-01-2003, 08:48 PM   #10
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Quote:
I always log on as root
You should never log in as root, especially if you are going to go online.

Always log in as a user, open an x terminal and
Code:
[phil@uilleann phil]$ su -
Password: 
[root@uilleann root]#
Administer through that x terminal.
 
Old 06-01-2003, 08:57 PM   #11
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
I agree w/ fancypiper about never (well almost never) log in as root.

The exception is when you are configuring your system (like adding a modem driver) Once the driver is installed then you should exit root and setup kppp as a user.

I sense you could use a more general guide.

This book should help. There is a chapter on system administration and setting up users.

Slackware Book
 
Old 06-03-2003, 11:29 AM   #12
Tynoan
LQ Newbie
 
Registered: May 2003
Posts: 20

Original Poster
Rep: Reputation: 0
Make install returns Error 2. It says KERNELSRC does not point to proper directory.
How do I fix that?

Also set up a non-root user, thanks for tip.

Last edited by Tynoan; 06-03-2003 at 11:37 AM.
 
Old 06-03-2003, 11:46 AM   #13
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Usually the kernel source is in

/usr/src/linux-<version number>

There should be a symbolic link

/usr/src/linux

that points to your kernel source code directory

/usr/src/linux-<version number>

Is that true in your case?

# Modem and connection troubleshooting
Is it a PCI card? Find info about PCI cards with /cat/proc/pci
Modem NHFs
Modem HOWTO
Linmodems.org
Conexant/Rockwell modem HOWTO
The Unofficial PCTel Linux Driver page
I finaly got my PcTel hsp56 mr modem to work
The kppp Handbook
Dial-up Networking Configuration Using KDE's Kppp
Troubleshooting ISP Connection Problems
Connecting to AOL with Linux
 
Old 06-03-2003, 12:23 PM   #14
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
I suspect you do not have kernel sources installed. Which version of Slackware are you using?

Slackware 8.1 has the kernel source on CD #1

Slackware 9.0 has the kernel source on CD #2

You will need to mount the cdrom the manner of which depends on how your system is setup. If we are lucky this will work. If not post back. As root try mount /mnt/cdrom Then cd to /mnt/cdrom and ls the files. Navigate down the directory using the cd commands. You will want slackware > /k. To go up a directory "cd .." (cd <space> ..) See the book link on handling files and directories.

Once you see "linux-source-2.4.20-noarch-5.tgz"

run "installpkg linux-source-2.4.20-noarch.tgz" If you are using Slackware 8.1 the kernel source will be linux-source-2.4.18-noarch*.tgz

My error edited should be "installpkg kernel-source-2.4.20-noarch-5.tgz"

Remember to change out of the /mnt/cdrom directory (can't umount if you are in the directory) and umount /mnt/cdrom when you are done
Once this is installed try to make install the conexant driver again.

Last edited by shepper; 07-01-2003 at 11:42 PM.
 
Old 06-04-2003, 05:16 PM   #15
Tynoan
LQ Newbie
 
Registered: May 2003
Posts: 20

Original Poster
Rep: Reputation: 0
I found the '/k' directorory, which has the file 'kernel-source-2.4.20-noarch-5.tgz', but when I run 'installpkg linux-source-2.4.20-noarch.tgz' or 'installpkg kernel-source-2.4.20-noarch.tgz', it says that it can't install becouse the package does not end in .tgz.

But when I entered 'installpkg kernel-source-2.4.20-noarch-5.tgz', it installed.

Oh, and I have Slack 9.0 .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis Modem Issues ErieDeMolay MEPIS 2 06-29-2005 06:31 PM
hsf modem issues Mr_C Linux - Hardware 10 04-30-2005 04:33 PM
Modem issues wardialer Linux - Newbie 6 01-01-2005 05:21 PM
Modem issues bengele Linux - Networking 4 04-29-2003 09:56 AM
Modem Issues :/ Stacheldraht Linux - General 6 04-20-2002 07:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration