-   Slackware (
-   -   Modem issues (

Tynoan 05-29-2003 01:59 PM

Modem issues
I am new to Lunix and have fortunately been able to figure out most of what I need to know on my own, except the modem. I am using a laptop, and /dev/modem points to /dev/ttyS4, which I am pretty sure is the modem. But when I try to dial-out, using kppp and pppsetup, it says the modem is busy. When Slack boots, it looks like it shares IRQ 11, which is what the modem is on, with something else. Any and all help is aprecciated. Remember, all help needs to be spelled out very simply- n00by here.

dcm 05-29-2003 05:02 PM

I never managed to do anything with kppp when I had a dial-up.
I suggest you try wvdial.
So far as I know there are no slack packages, so either build from source code or convert an rpm (I did this and it worked fine "rpm2tgz")
If you like, I will mail you my wvdial.tgz

Once its installed you run (as root) "wvdialconf" which auto detects the modem and the settings it needs, writing /etc/wvdial.conf. You need to edit this file, (still as root) giving the isp telephone number, your login and password.

Finally (as a non-root user) run "wvdial" and you should be on line. Don't forget to enter the isp's DNS in /etc/resolv.conf

shepper 05-29-2003 11:05 PM

It is more likely that your laptop uses a Software based modem and needs a driver installed. Run "lspci -vv" to see what kind of driver you need and post back. We can direct you to the right site for your modem. Common software modems are lucent, conexant and PCTEL. The first two have good linux support. and the PCTEL can work. I have set up 4 laptop modems and once set up properly kppp, ppp-on and minicom all worked.

One issue is that the drivers are compiled and therefore need kernel sources. This is not included in the downloaded Slackware 9 but is in 8.1. You need to get a buddy to download the kernel ( /k) and save it to a cdrom or a USB flash drive so you can transfer into your machine

I am working to get precompiled modem drivers out for the common modems in Slack9 but my own laptop with a lucent modem is being repaired. Once out they should make this problem easier to deal with.

Tynoan 05-31-2003 09:59 PM

"lspci -vv" doesn't work or I did/didn't do something right, but I somehow know that it is a conexant modem.

shepper 05-31-2003 10:43 PM

You need to be root to run lspci.

There are 2 types of conexant modems HSF and HCF.

This link has most of the information you need.

Conexant drivers

Again you need to have kernel sources installed before you can think about getting this to work


Tynoan 06-01-2003 08:00 PM

I always log on as root, and it still doesn't work. Is there something I have to do first?
The first character is a capitol i, right?

The modem is HSF.
I have the 4 CD set from Slackware, but what do I need to do with the source code and modem driver?

Astro 06-01-2003 08:19 PM

The modem in my laptop (running slack 9 rc-2) is picked up on boot by the pcmcia card manager stuff. All I did to get it working was from a console running pppsetup then when that is done running ppp-go or ppp-on to start it.

Tynoan 06-01-2003 08:26 PM

LOL its a lower-case L.

shepper 06-01-2003 08:34 PM

It is a lower case L. It will list your pci devices.

If you have the 4 disk set you are set. If you have problems compiling it means you don't have the /d and /k packages installed

Download this driver. It will fit on a 1.44 floppy. HSF driver

To mount the floppy on a linux system type as root
"mount -t vfat /dev/fd0 /mnt/floppy"
Then change directory to /mnt/floppy " cd /mnt/floppy"

ls (LS lower case) to show the contents of the floppy
Then copy to a directory in your system. I chose the /root directory
"cp hsflinmodem*.tar.gz /root/conexant/

The cd to /root/conexant
unmount the floppy "umount /mnt/floppy

then follow these pasted instructions from the conexant site.


If you have obtained the driver package in tar format:

1. extract the package with "tar -xzf hsflinmodem-{version}.tar.gz"

2. change to the package directory with "cd hsflinmodem-{version}"

3. run "make install" from the top of the package directory.
(Debian users might need to change the KERNELSRC definition in
modules/common.mak first)

4. run "hsfconfig" to complete the installation and configure your modem.

(Alternatively to this whole procedure you may generate RPMS from the tar
package using rpm -ta hsflinmodem-{version}.tar.gz")

It should set up a link /dev/modem -> /dev/ttySHSF0

in kppp setup you should select /dev/modem

fancypiper 06-01-2003 08:48 PM


I always log on as root
:tisk: You should never log in as root, especially if you are going to go online.

Always log in as a user, open an x terminal and

[phil@uilleann phil]$ su -
[root@uilleann root]#

Administer through that x terminal.

shepper 06-01-2003 08:57 PM

I agree w/ fancypiper about never (well almost never) log in as root.

The exception is when you are configuring your system (like adding a modem driver) Once the driver is installed then you should exit root and setup kppp as a user.

I sense you could use a more general guide.

This book should help. There is a chapter on system administration and setting up users.

Slackware Book

Tynoan 06-03-2003 11:29 AM

Make install returns Error 2. It says KERNELSRC does not point to proper directory.
How do I fix that?

Also set up a non-root user, thanks for tip.

fancypiper 06-03-2003 11:46 AM

Usually the kernel source is in

/usr/src/linux-<version number>

There should be a symbolic link


that points to your kernel source code directory

/usr/src/linux-<version number>

Is that true in your case?

# Modem and connection troubleshooting
Is it a PCI card? Find info about PCI cards with /cat/proc/pci
Modem NHFs
Conexant/Rockwell modem HOWTO
The Unofficial PCTel Linux Driver page
I finaly got my PcTel hsp56 mr modem to work
The kppp Handbook
Dial-up Networking Configuration Using KDE's Kppp
Troubleshooting ISP Connection Problems
Connecting to AOL with Linux

shepper 06-03-2003 12:23 PM

I suspect you do not have kernel sources installed. Which version of Slackware are you using?

Slackware 8.1 has the kernel source on CD #1

Slackware 9.0 has the kernel source on CD #2

You will need to mount the cdrom the manner of which depends on how your system is setup. If we are lucky this will work. If not post back. As root try mount /mnt/cdrom Then cd to /mnt/cdrom and ls the files. Navigate down the directory using the cd commands. You will want slackware > /k. To go up a directory "cd .." (cd <space> ..) See the book link on handling files and directories.

Once you see "linux-source-2.4.20-noarch-5.tgz"

run "installpkg linux-source-2.4.20-noarch.tgz" If you are using Slackware 8.1 the kernel source will be linux-source-2.4.18-noarch*.tgz

My error edited should be "installpkg kernel-source-2.4.20-noarch-5.tgz"

Remember to change out of the /mnt/cdrom directory (can't umount if you are in the directory) and umount /mnt/cdrom when you are done
Once this is installed try to make install the conexant driver again.

Tynoan 06-04-2003 05:16 PM

I found the '/k' directorory, which has the file 'kernel-source-2.4.20-noarch-5.tgz', but when I run 'installpkg linux-source-2.4.20-noarch.tgz' or 'installpkg kernel-source-2.4.20-noarch.tgz', it says that it can't install becouse the package does not end in .tgz.

But when I entered 'installpkg kernel-source-2.4.20-noarch-5.tgz', it installed.

Oh, and I have Slack 9.0 .

Tynoan 06-04-2003 05:24 PM

Then I went back and did the driver steps from the comexant site, and they all worked, so now I am logging on as a non-root user and going to try to connect to the internet.

/me crosses fingers.

shepper 06-04-2003 05:34 PM

Good. It would have told you the package was already installed if there was something else going on. That should have set up /usr/src/linux as a link to /usr/src/linux-2.4.20. If you have the /d series of programs from the 1st disk of Slackware 9.0 installed you should be ready to compile and install the driver as root.

My replies are too slow. He has already installed the driver.

Tynoan 06-05-2003 09:42 AM

It worked. This post is from my laptop. THanks Shepper

All times are GMT -5. The time now is 01:09 PM.