-   Slackware (
-   -   mod_perl error Invalid command 'PerlOptions' (

agentc0re 05-23-2007 07:30 PM

mod_perl error Invalid command 'PerlOptions'
when i do apachectl configtest i receive

Invalid command 'PerlOptions', perhaps mis-spelled or defined by a module not included in the server configuration
i do have mod_perl loaded in the httpd.conf file. what i am doing is doing a #include /etc/apache/otrs.conf (the file that has the PerlOptions +ParseHeaders)

in my httpd.conf file just before i do the include i have <IFModule mod_perl.c> and then i end it after the include. not sure if i was supposed to do that or not but i with or without i still get the same error.

i found a post but i acidently closed it out and can't find it now. it said to copy 2 files from the mod_perl src dir after the make install to somewhere else and im wondering if that maybe what is holding me back.

any help is always appreciated! :) thanks slackers

msantinho 05-24-2007 08:45 AM

Is this the post you were looking for?

Would help if you tell us what Apache and mod_perl versions you're using.

agentc0re 05-24-2007 10:12 AM

sorry, didn't even think to mention that because i just used what comes preinstalled on 11.
so it's apache 1.3.37 (i think) and mod perl 1.30

agentc0re 05-24-2007 10:22 AM

Well i got that file copied over, and set the permissions like you had mentioned in your thread.
when i installed mod_perl it updated my httpd.conf for me by loading the module in it correctly with both the lines you also mention in your post.

do you think i could be getting this error because im calling another .conf file? should i just add this code to my httpd.conf file? if i do would i need to add it under <IFModule mod_perl.c> </IFModule> section or would anywhere matter?

i tried adding the code just to the httpd.conf file under the IFModule mod_perl.c section and still same error.

agentc0re 05-24-2007 10:51 AM

Ah, i just found out i don't have a directory called /usr/bin/apxs. could this be a problem?

--edit-- i found it else where. i found it in /usr/sbin/apxs

agentc0re 05-24-2007 12:34 PM

here is part of my apache log. maybe this might help solve the issue as well.

[Thu May 24 11:20:08 2007] [error] Can't locate ModPerl/ in @INC (@INC contains: ../../ /opt/otrs/Kernel/cpan-lib /opt/otrs/ /usr/lib/perl5/5.8.8/i486-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i486-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl . /usr/ /usr/lib/perl) at (eval 93) line 3.\n
[Thu May 24 11:20:08 2007] [error] Undefined subroutine &ModPerl::Registry::handler called.\n

agentc0re 05-24-2007 01:22 PM

I solved it! well turns out what the program was telling me to do was for mod_perl. after digging in the documents for a while i saw the difference it was telling me to add to the httpd.conf file. obviously that line wasn't part of it.

so i got it up and operational! yey!

All times are GMT -5. The time now is 03:47 AM.