-   Slackware (
-   -   mkv videos unwatchable... (

irgunII 11-23-2013 01:36 AM

mkv videos unwatchable...
I did an


ffmpeg -i <mkv file>
and I get this:


ffmpeg: error while loading shared libraries: cannot open shared object file: No such file or directory
I've searched on the forums and on search engines and can't find any information.

What library has this? Where do I get it for my 32 bit Slackware 14.1?

Every other kind of video file seems to play just fine, but mkv's (made with windows, so far...haven't been able to test on one ripped on linux) have a second or two hesitation/pause every few seconds making trying to watch a mkv movie a PITA.

ponce 11-23-2013 01:40 AM

that library it's in the libcdio package, included with Slackware.

dunno if it's what you want to do, but if you want to try ffmpeg's own player it's named ffplay.

I would have a shot also with vlc.

irgunII 11-23-2013 07:49 AM

Hi ponce,

It took me a while to just get vlc to work on my system. Vlc is working but it nor xine nore mplayer will play mkv's correctly.

I did a search on my system also for and it wasn't found. I don't think since ffmpeg needs/wants that lib, that ffplay will work either, but I'll give it a try. Thanks.

chemfire 11-23-2013 08:34 AM


Did you install the libcdio package from /l?

You can check in /var/log/packages.


cat /var/log/packages/libcdio-*
You should get a list of files in that package, if you don't you will need to install it. ffmpeg does not ship with Slackware did you compile it yourself?


ldd $(which ffmpeg) | grep -i miss
will help you figure out what else might be missing.

irgunII 11-23-2013 05:01 PM

Hi chemfire,

Yes, cdio was installed from the time I installed 14.1. I've also installed libcdio-paranoia (I cobbled it together as a txz) but it made no difference in the playability of an mkv...because it still had the hesitation and when I did ffmpeg -i it now told me an libass file was missing, yet all of these are installed *and* they're 'statically' installed too, as per alienBOB's vlc installation script and all.

When I did the ldd thing, nothing happened, it simply came back to the bash prompt with no information at all.

I'm going to uninstall alienBOB's vlc and see if a 'stock' vlc does the same trouble (it did before, but I've done more things since, so maybe something different will happen).

chemfire 11-23-2013 05:05 PM

try ldd without the | grep..., part. I thought it said missing but it might say something like not found.

Is it possible you have installed a 64bit package on a 32-bit system?

irgunII 11-24-2013 01:14 AM

Okay, that worked better, heh...


ldd $(which ffmpeg)
showed me all the libraries I had with/for ffmpeg and libcdio and libcdio-paranoia were there.

I re-downloaded just to make sure I had the 32 bit and I do.

It just doesn't make sense, to me, that mp4's, avi's work okay but not the other (I'm trying to rip an mkv on my system to see if one made on a linux box will work...if I could get HandBrake to work, but it keeps segfaulting on me).

irgunII 11-24-2013 02:17 AM

I just made an mkv file on my 14.1 system and can watch it just fine in vlc with no problems.

It seems it's mkv's made in winblows systems that are giving me trouble, though why it's doing so in 14.1 and it didn't in 14.0 is strange.

chemfire 11-24-2013 07:17 AM

So does ffplay -i /path/to/mkvfile work?

irgunII 11-24-2013 07:49 AM


Originally Posted by chemfire (Post 5069762)
So does ffplay -i /path/to/mkvfile work?

Oops...forgot to mention about that. When it was first suggested to try it, it didn't even start because of the libcdio-paranoia thing. *Now* though, it is working and plays mkv's (at least the one so far) just fine but vlc won't play it because it still has the original problem with mkv's.

frankbell 11-24-2013 10:05 PM

For what it's worth, *.mkv files have played find on my Slackware system in VLC and other players since I first encountered them without my having to take any special steps.

I offer this only to verify that it's not a Slackware-wide problem.

commandlinegamer 11-25-2013 08:12 AM

I had problems with MKV playback in 14.0 or possibly 13.37 using Xine. MPlayer worked fine, though.

All times are GMT -5. The time now is 05:17 AM.