LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-25-2019, 09:59 AM   #1
talo
LQ Newbie
 
Registered: May 2015
Location: near Amsterdam
Distribution: slackware-14.2 + currrent
Posts: 24

Rep: Reputation: Disabled
Angry mkinitrd command generator.sh


Hi all,
I just did try to install the latest slackware64current version (burned today) and got problems with ramdisk generation.
Repeatedly got the message:
mkinitrd_command_generator.sh Line 345: shift: 2 : shift count out of range.
This was not the case in 18 december 2018 version I burned.

Has there been a change in procedures?

Best regards,

talo
 
Old 01-25-2019, 10:34 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,533

Rep: Reputation: 5896Reputation: 5896Reputation: 5896Reputation: 5896Reputation: 5896Reputation: 5896Reputation: 5896Reputation: 5896Reputation: 5896Reputation: 5896Reputation: 5896
Nothing changed in that script since July 2018, and before that, nothing relevant changed either.

It may be wise that you actually show us the commandline you used, otherwise it's just crystal ball business and that will not make you happy.
The issue with your commandline is probably that you passed a weird value for the "-k" parameter. That parameter expects a kernel version, like 4.19.17.
 
Old 01-25-2019, 10:42 AM   #3
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,007
Blog Entries: 16

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
Quote:
Originally Posted by Alien Bob View Post
Nothing changed in that script since July 2018, and before that, nothing relevant changed either.
bash got bumped to 5.0 recently though.
 
Old 01-25-2019, 11:59 AM   #4
giomat
Member
 
Registered: Jul 2017
Posts: 50

Rep: Reputation: Disabled
Latest update on current introduced an automatic call to mkinitrd script during the installation.
I just tried a clean install and got the same issue as OP. I'll try to investigate a bit more this evening.
 
Old 01-25-2019, 02:58 PM   #5
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 889

Rep: Reputation: Disabled
Seeing the same thing here. From the -current ISO (Wed Jan 23 22:02:34 UTC 2019).

This is repeating in a infinite loop:
Code:
/usr/share/mkinitrd/mkinitrd_command_generator.sh: line 345: shift: 2: shift count out of range
Quote:
Originally Posted by Alien Bob View Post
Nothing changed in that script since July 2018, and before that, nothing relevant changed either.
Except this changed:
Code:
Wed Jan 23 22:02:34 UTC 2019
>..<
a/mkinitrd-1.4.11-x86_64-9.txz:  Rebuilt.
  Automatically generate an initial ramdisk from the installer.
  Added 'geninitrd' script to generate an initial ramdisk for the kernel that
  /boot/vmlinuz-generic (and/or /boot/vmlinuz-generic-smp) points to.

Last edited by Skaendo; 01-25-2019 at 03:37 PM.
 
1 members found this post helpful.
Old 01-25-2019, 04:32 PM   #6
Mobile1
Member
 
Registered: Jun 2006
Location: Abbotsford, B.C.
Distribution: Slackware64 14.2
Posts: 176

Rep: Reputation: 34
I too had the same thing happen, I had just downloaded Eric's -current .iso and burned it - then tried to install, only to get the:

/usr/share/mkinitrd/mkinitrd_command_generator.sh: line 345: shift: 2: shift count out of range

Message.
 
1 members found this post helpful.
Old 01-25-2019, 05:06 PM   #7
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,725
Blog Entries: 1

Rep: Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087
On a different, but yet similar note, over the last two days I've tried to do a uefi install from a -current .iso dated 19 January. Each time it skipped the uefi configuration option and went straight to the next step. When the system rebooted the result was a screen full of 9s.
On the third attempt I didn't reboot, but restarted pkgtool and tried to configure uefi. The screen blinked when I selected it and went back to the pkgtool menu.
Finally I went back to a "good old fashion" lilo installation. Works as it always has... and, yes, this is a relatively new motherboard with a uefi bios and a EF00 100 meg partition had been created.
 
Old 01-25-2019, 05:39 PM   #8
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,698

Rep: Reputation: 5260Reputation: 5260Reputation: 5260Reputation: 5260Reputation: 5260Reputation: 5260Reputation: 5260Reputation: 5260Reputation: 5260Reputation: 5260Reputation: 5260
Quote:
Originally Posted by cwizardone View Post
On a different, but yet similar note, over the last two days I've tried to do a uefi install from a -current .iso dated 19 January. Each time it skipped the uefi configuration option and went straight to the next step. When the system rebooted the result was a screen full of 9s.
On the third attempt I didn't reboot, but restarted pkgtool and tried to configure uefi. The screen blinked when I selected it and went back to the pkgtool menu.
Finally I went back to a "good old fashion" lilo installation. Works as it always has... and, yes, this is a relatively new motherboard with a uefi bios and a EF00 100 meg partition had been created.
Are you booting the installer in legacy BIOS mode? SeTEFI has been changed to skip mounting /boot/efi if the kernel doesn't report that it's running under UEFI.
 
2 members found this post helpful.
Old 01-25-2019, 07:02 PM   #9
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,725
Blog Entries: 1

Rep: Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087Reputation: 2087
Quote:
Originally Posted by volkerdi View Post
Are you booting the installer in legacy BIOS mode? SeTEFI has been changed to skip mounting /boot/efi if the kernel doesn't report that it's running under UEFI.
Here is how I've been doing it for a while and how I finally installed it yesterday and, again, today, after experiencing the problem described a couple of messages back.

Quote:
cwizardone
12-07-18, 09:59
............With the last few -current .iso-s I've burned to DVDs, I've had to use the efi option to get it to install.
Let me explain.
I would hit F8 to get the BIOS boot menu. If I picked the DVD drive containing the iso, the installation would start, but eventually fail. It would just stop somewhere along the line.
After a few tries, as I've always done in the past, I noticed the last entry on the BIOS boot menu was for a..... forgotten exactly, but it was labelled something like uefi/name-of-the-DVD-drive-containing-the-iso.
I went with that and the installation was successful.
When it present the elilo menu option I told it to create a standard lilo boot configuration and install it to the MBR.
The installation booted correctly and that is the procedure I've been using ever since.....
It is a ASUS UEFI BIOS (made by American Megatrends) dated 12-07-2018, and installed (burned) on 12-20-2018.

Last edited by cwizardone; 01-26-2019 at 09:11 AM.
 
1 members found this post helpful.
Old 01-25-2019, 07:56 PM   #10
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 889

Rep: Reputation: Disabled
After today's update (Fri Jan 25 23:32:30 UTC 2019), the installer gets to the "GENERATING INITIAL RAMDISK" screen where it hangs and I am getting:
Code:
./var/log/setup/setup.01.mkinitrd: line 28: /usr/share/mkinitrd/mkinitrd_command_generator.sh: No such file or directory
 
1 members found this post helpful.
Old 01-25-2019, 09:18 PM   #11
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 889

Rep: Reputation: Disabled
Would it be viable to create a initrd optional through the installer?

I'm only asking because on 3 of 5 computers that I run I make a initrd and load the Intel microcode with them, and 2 of those I have the wonderful Intel GM965 chipset so I need to drop back to a 4.4.* kernel. While my needs may differ from the majority, I think that it would be helpful to at least most(?) making the initrd and at the same time being able to skip it for those who don't really need it (or make their own).
 
Old 01-26-2019, 01:11 AM   #12
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 889

Rep: Reputation: Disabled
Code:
(Sat Jan 26 04:15:08 UTC 2019)
a/mkinitrd-1.4.11-x86_64-11.txz:  Rebuilt.
  setup.01.mkinitrd: revert to the previous command line for
  mkinitrd_command_generator.sh (the new one fails when called from the
  installer).
Working now. Thanks Pat.
 
Old 01-26-2019, 09:31 AM   #13
talo
LQ Newbie
 
Registered: May 2015
Location: near Amsterdam
Distribution: slackware-14.2 + currrent
Posts: 24

Original Poster
Rep: Reputation: Disabled
Indeed, it works correctly and I installed today's current version,
Thanks Pat,
So I will marked this thread as SOLVED

talo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Direct output of mkinitrd command generator to shell Phorize Slackware 11 11-08-2013 07:19 AM
NS2: Problem with Traffic model generator VANET (static traffic model generator for ns2) Anil Kumar Giri Linux - Software 0 04-28-2013 08:48 PM
[SOLVED] initrd and generic kernel fails to boot with errors after using mkinitrd generator adamschock Slackware 8 06-26-2010 02:30 PM
sudo mkinitrd -o /boot/initrd.img-2.6.32.9 2.6.32.9 sudo: mkinitrd: command not foun vishwas181 Linux - Newbie 1 02-27-2010 01:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration