LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-05-2019, 04:14 AM   #1
Kowalczyk
Member
 
Registered: Jan 2008
Location: Norway
Distribution: Slackware
Posts: 37

Rep: Reputation: 19
Missing shutdown button KDE


Hi.

I have installed a new slackware machine and im experiencing issues with KDE.

Im missing shutdown button in KDE. IT works on my desktop at home.

And same with KDE wallet. I cant turn it off. It says I cant save the configuration.

Have I forgot anything?

Slackware64 14.2

Standard KDE
Attached Thumbnails
Click image for larger version

Name:	2019-04-05 11_10_28-Window.png
Views:	66
Size:	90.8 KB
ID:	30243   Click image for larger version

Name:	2019-04-05 11_10_47-Window.png
Views:	23
Size:	23.0 KB
ID:	30244  
 
Old 04-05-2019, 07:23 AM   #2
bosth
Member
 
Registered: Apr 2011
Location: British Columbia, Canada
Posts: 282

Rep: Reputation: 109Reputation: 109
If you started KDE with "startx", you don't get shutdown options. However, if you switch to run level 4 ("init 4" as root) and log in through KDM, you should see them.
 
Old 04-05-2019, 07:56 AM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,153

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
yes, shutting down and rebooting the system is an admin thing. If you are not admin (root privs) no option to do so should/will be available.

if it is a works with level 4 but not 3, then there is a break in the system somewhere (obviously). You'd have to seek it out then fix it.

knowing what has the ultimate control should help you. Being part of admin (sudo/wheel). polkit and how the desktop and startx ties in. etc..

or you could switch to run level 4 and be done with it. If you are not on run level 4.

Last edited by BW-userx; 04-05-2019 at 08:01 AM.
 
Old 04-05-2019, 08:57 AM   #4
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,908
Blog Entries: 1

Rep: Reputation: 2315Reputation: 2315Reputation: 2315Reputation: 2315Reputation: 2315Reputation: 2315Reputation: 2315Reputation: 2315Reputation: 2315Reputation: 2315Reputation: 2315
Quote:
Originally Posted by bosth View Post
If you started KDE with "startx", you don't get shutdown options. However, if you switch to run level 4 ("init 4" as root) and log in through KDM, you should see them.
Au contraire!
If your installation is correct, starting with startx, level 3, has nothing to do with it. Shutdown should be an option from the application launcher, i.e., click on it, then on "Leave" and then "Shutdown." You should also be able to get to the "Leave" options by right clicking on an empty space on the desktop and/or you can add a widget to your panel.

Last edited by cwizardone; 04-05-2019 at 09:25 AM.
 
1 members found this post helpful.
Old 04-05-2019, 11:17 AM   #5
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,199

Rep: Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940
Quote:
Originally Posted by BW-userx View Post
yes, shutting down and rebooting the system is an admin thing. If you are not admin (root privs) no option to do so should/will be available.

if it is a works with level 4 but not 3, then there is a break in the system somewhere (obviously). You'd have to seek it out then fix it.

knowing what has the ultimate control should help you. Being part of admin (sudo/wheel). polkit and how the desktop and startx ties in. etc..

or you could switch to run level 4 and be done with it. If you are not on run level 4.
This is not true. You don't need to have "sudo/wheel" permissions to shut down the system. You just need to be added to the right group (pretty sure it is the power group), and that required group is part of the suggested groups when using adduser.

Code:
audio cdrom floppy lp netdev plugdev power scanner video
And I was able to verify cwizardone's statement that init 4 is not required for shutdown options (I did not realize this either, so thanks!). I just opened my VM (which defaults to runlevel 3), logged into my normal user, ran startx, and was then able to shut down the system using the Application Launcher -> Leave -> Shutdown. I have no sudo set up for that user and it is just a member of the groups above.

@OP, make sure your user is added to the recommended groups. You can do that with the command below (replacing $user with your username on the computer).

Code:
usermod -a -G audio cdrom floppy lp netdev plugdev power scanner video $user
If you're running -current (pre-15.0), add "input" to that command.

Last edited by bassmadrigal; 04-05-2019 at 11:26 AM.
 
1 members found this post helpful.
Old 04-05-2019, 12:44 PM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,153

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
Quote:
Originally Posted by bassmadrigal View Post
This is not true. You don't need to have "sudo/wheel" permissions to shut down the system. You just need to be added to the right group (pretty sure it is the power group), and that required group is part of the suggested groups when using adduser.

Code:
audio cdrom floppy lp netdev plugdev power scanner video
And I was able to verify cwizardone's statement that init 4 is not required for shutdown options (I did not realize this either, so thanks!). I just opened my VM (which defaults to runlevel 3), logged into my normal user, ran startx, and was then able to shut down the system using the Application Launcher -> Leave -> Shutdown. I have no sudo set up for that user and it is just a member of the groups above.

@OP, make sure your user is added to the recommended groups. You can do that with the command below (replacing $user with your username on the computer).

Code:
usermod -a -G audio cdrom floppy lp netdev plugdev power scanner video $user
If you're running -current (pre-15.0), add "input" to that command.
sweet, I didn't really want to shut down what I am doing to put that to the test, thanks for intervening.
 
Old 04-05-2019, 12:59 PM   #7
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,199

Rep: Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940Reputation: 3940
Quote:
Originally Posted by BW-userx View Post
sweet, I didn't really want to shut down what I am doing to put that to the test, thanks for intervening.
I didn't either Occasionally used VM to the rescue!
 
Old 04-05-2019, 01:32 PM   #8
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,153

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
Quote:
Originally Posted by bassmadrigal View Post
I didn't either Occasionally used VM to the rescue!
Now I can edit my inittab again, and put it back on 4, that is as far as I got. I don't keep vm installed anymore.
 
Old 10-01-2019, 08:55 AM   #9
sfzombie13
Member
 
Registered: Dec 2003
Location: wv
Distribution: slackware, lfs, kali, pentoo, centos
Posts: 164

Rep: Reputation: 18
so, what was the result of this thread? or, how do you bring the shutdown option back? i had the same problem, but it is a little more interesting. i had the shutdown option until an update, but it was there for a couple of weeks. then it disappeared. i logged in as root and it is gone there also. i always start in runlevel 3 then use startx to get the gui if i need it. i am holding the power button down now as it is inconvenient to open a terminal and su to root just to type in halt.

Last edited by sfzombie13; 10-01-2019 at 09:09 AM. Reason: typo
 
1 members found this post helpful.
Old 10-01-2019, 04:26 PM   #10
rherbert
LQ Newbie
 
Registered: Nov 2003
Location: Montreal, Quebec, Canada
Distribution: Slackware64-current
Posts: 9

Rep: Reputation: 6
Go to System Settings, Startup and Shutdown, Desktop Session, and make sure "Offer shutdown options" is checked.

Last edited by rherbert; 10-01-2019 at 08:12 PM.
 
1 members found this post helpful.
Old 10-07-2019, 09:54 AM   #11
sfzombie13
Member
 
Registered: Dec 2003
Location: wv
Distribution: slackware, lfs, kali, pentoo, centos
Posts: 164

Rep: Reputation: 18
strange how i don't have a system settings. i have a settings manager and session and startup, but no startup and shutdown either. no option that i see is "offer shutdown options" either. and then i re-read the title about it being a kde thread. i just had the same issue with xfce. not related i guess.
 
Old 10-07-2019, 10:01 AM   #12
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,438
Blog Entries: 31

Rep: Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607
Member Response

Hi,

Quote:
Originally Posted by sfzombie13 View Post
strange how i don't have a system settings. i have a settings manager and session and startup, but no startup and shutdown either. no option that i see is "offer shutdown options" either. and then i re-read the title about it being a kde thread. i just had the same issue with xfce. not related i guess.
Goto the menu> Favorites>System Settings >Sessions Management >General and check offer shutdown options

Hope this helps.
Have fun & enjoy Slackware!
 
Old 10-07-2019, 04:45 PM   #13
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,344
Blog Entries: 1

Rep: Reputation: Disabled
I think OP should verify to which groups belong user
Code:
$ id
it was mentioned to power off computer (I believe) user needs to belong to proper group.
 
Old 10-07-2019, 07:49 PM   #14
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,438
Blog Entries: 31

Rep: Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607Reputation: 2607
Member Response

Hi,

@igadoter

You are quite right about the group assignments.
As mentioned in post #5. But the proper access for system settings was my intent.

Last edited by onebuck; 10-07-2019 at 09:45 PM. Reason: add comment
 
Old 10-08-2019, 10:55 AM   #15
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,153

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
isn't polkit attached to this, therefore user needs to be in the wheel group to get permissions to reboot and shutdown because them operations fall under root/admin rights and responsibilities, and not just every day users.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
what is the default powerstate (e.g. S3,S4,S5) for the command 'shutdown -hP' or 'shutdown -hH' or 'shutdown -h' badbetty Slackware 6 11-12-2017 12:18 AM
logout before shutdown with shutdown button in XFCE ta0kira Ubuntu 2 06-25-2011 04:57 AM
KDE Shutdown Button MTK358 Linux - Desktop 6 07-29-2010 08:02 AM
Shutdown button on kde logoff gone arubin Slackware 9 11-20-2006 01:58 AM
shutdown button missing in gnome bhar0761 Fedora 5 08-02-2005 10:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration