-   Slackware (
-   -   Missing Includes directive in doing make (

aherrys 12-24-2012 10:39 PM

Missing Includes directive in doing make
Hi All,

I am compiling a bluefish application in a slackware 14.0 (kernel 3.2.29), but I got stuck when I run make and it seemed to have problem when it tried to run gcc in which it complains that some header files are missing. I compare this on another slackware machine (version 13.37) in which the compilation runs OK, that there is some Include directives that are missing in the 14.0 machine. Here are the log when the problem occurred on slackware 14.0 and below it is the log of the exact same point of the compilation process on slackware 13.37 when it went OK.

got problem (slackware 14.0)

make[5]: Entering directory `/root/bluefish-2.0.3/src/plugin_about'
/bin/sh ../../libtool --tag=CC  --mode=compile gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DPKGDATADIR=\"/usr/local/share/bluefish\" -I. -I../../src    -g -O2 -Wall -pipe  -MT about.lo -MD -MP -MF .deps/about.Tpo -c -o about.lo about.c
libtool: compile:  gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DPKGDATADIR=\"/usr/local/share/bluefish\" -I. -I../../src -g -O2 -Wall -pipe -MT about.lo -MD -MP -MF .deps/about.Tpo -c about.c  -fPIC -DPIC -o .libs/about.o
about.c:21:21: fatal error: gmodule.h: No such file or directory
compilation terminated.

went through fine (slackware 13.37)

make[5]: Entering directory `/root/bluefish-2.0.3/src/plugin_about'
/bin/sh ../../libtool --tag=CC  --mode=compile gcc -DHAVE_CONFIG_H -DLOCALEDIR=
\"/usr/local/share/locale\" -DPKGDATADIR=\"/usr/local/share/bluefish\" -I. -I../
../src    -g -O2 -Wall -pipe -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0
/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2
.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/
include/gio-unix-2.0/ -I/usr/include/libxml2 -I/usr/include/enchant    -MT about
.lo -MD -MP -MF .deps/about.Tpo -c -o about.lo about.c

You can notice that on the command gcc that is issued, the one that works has lots of include directive to all the dependent package subdirectories under the /usr/include. While on the one that stuck it has no -I directive and it was the reason why it cannot find the gmodule.h

So I think there is something amiss in either when I was doing ./configure or when running the make process itself.
Can someone please help me in pointing out in direction should I looking to find the solution of this problem ? I am really lost when it got to all this C code compilation business..


PS: I ran the slackbuilds as well for this and got stuck at the same point. In fact I ran slackbuild first and got stuck so I tried my luck to compile it by hand.

ophirg 12-25-2012 02:34 AM


I am not a slackware user, but know this problem generally occurs when ./configure has some problems with dependecies

look at the ./configure output. you might find that there are missing dependancies.
in your case, glib is missing or not properly configured (gmodule.h is part of glib)
you can check using

pkg-config --cflags glib-2.0
but i suspect you have other missing dependecies too.
make sure you didn't skip some required steps in the installation.
(steps that install gtk2 for example...)

colucix 12-25-2012 05:26 AM

Moved: This thread is more suitable in Slackware forum and has been moved accordingly to help your thread/question get the exposure it deserves.

aherrys 12-25-2012 08:54 AM

Hi ophirg,

Thank you for your answer. YES ! it turns out I am missing some dependencies.. Thank you for pointing out that pkg-config command to me. Eventhough the dependencies were not that obvious because I installed the gtk, glib etc. but it turned out that there were other dependencies required by those packages as well and the pkg-config command revealed that. Once those dependencies were installed then the compile went through fine. Thanks once more.

All times are GMT -5. The time now is 09:25 PM.