-   Slackware (
-   -   Missing dependency & Hplip (

Mulligun 09-05-2007 05:58 AM

Missing dependency & Hplip
I'm trying to install my HP 930c printer on SlackWare 12. When i run sh such error occurs: "Missing REQUIRED dependency: lsb (LSB - Linux Standard Base support)". Installer suggest just to install that dependency. Is it a regular Linux package
to install to using installpkg (or similar)??? Where to find it???

Please HELP!

Okie 09-05-2007 06:12 AM

have you tried http://localhost:631/ ?

simcox1 09-05-2007 06:43 AM

I've got hplip-1.7.4a-i486-2 on my slackware 12. Just make sure /etc/rc.d/rc.hplip and rc.cups are both executeable, and then restart them both (rc.cups first) before going to http://localhost:631 .

simcox1 09-05-2007 07:00 AM

I think what you've done is download the latest hplip from their website. But if you did a full install you will already have hplip-1.7.4 installed. Unless you need a later version it should be ok.

[MDK]NooB 09-06-2007 04:00 AM

P.V. already included hplip in slack 12... if you did not install it you will find it in the ap/ directory of your installation disc or here:

you install it with pkgtool and, after installation, you jump to Setup menu (in pkgtool) and you chose wich daemons to activate: you'll need both cups and hplip...

then for the printer configuration you'll also find a useful icon in your KDE menus ^_^

All times are GMT -5. The time now is 10:12 AM.