LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Misc problems with Slackware 13.1 (https://www.linuxquestions.org/questions/slackware-14/misc-problems-with-slackware-13-1-a-831586/)

lpallard 09-11-2010 01:49 PM

Misc problems with Slackware 13.1
 
I am currently experiencing major problems with a system that should be "stable" as it is supposed to be...

I am using slack 13.1 (stable) and have the following problems:

1. Kontact is no longer usable.. Slowly it went from totally functional to complete garbage. First I lost Akonadi but kmail was still working, then I lost kmail completely. It simply hang/freeze whenever I press send to send a new email... According to my "googling", it would be caused by akonadi. My "googling" also showed that some people simply uninstall akonadi, but the problem is that if I do this, kontact simply wont start... Currently, akonadi simplified self test report says:

Code:

Database driver found.
MySQL server executable not tested.
MySQL server error log not tested.
MySQL server configuration not tested.
akonadictl found and usable
Akonadi control process not registered at D-Bus.
Akonadi server process not registered at D-Bus.
Nepomuk search service not registered at D-Bus.
Protocol version check not possible.
No resource agents found.
Current Akonadi server error log found.
Previous Akonadi server error log found.
No current Akonadi control error log found.
No previous Akonadi control error log found.

What frustrate me is that I did not touch or modify ANYTHING since I installed slack a few months ago, and it was working back then...Also I filed a bug report in KDE-Bugs and never got any replies.

2. I am also experiencing a VERY strange video problem. Please see thread http://www.linuxquestions.org/questi...isplay-830040/

To make a long story short, I recently got both laptop GeForce 8700M GT cards replaced as well as my LCD replaced and I have color problems/cannot activate SLI. Again, the color problems appeared a few weeks ago, and the SLI used to work with Slack 12.2. I never tried with 13.1 before but obviously it doesnt work. Again, using STABLE drivers as well as Slack 13.1 STABLE... Lots of details on my video issues with the link above. Gotta mention this works flawlessly in windows XP/vista/7

3. General Slack 13 sluggishness. Slack 12.2 used to be lightning fast, very responsive and extremely stable. Since I migrated to slack 13 I never felt the same thing... CLicking on buttons I can fell a delay, scrolling windows is sluggish, moving windows as well, the system uses 650MB of ram IDLE.. I think nvidia might be responsible for part of this..

Because every computer is different, and every slack installs are different, it would be nearly impossible to troubleshoot 100% accurately my problem, so I am only seeking guidance and opinion on this 3rd issue.

4. Somebody know how to have the stupid notification popup to automatically close so I dont need to click the X every time a message appears? I am talking about the KDE notification popup in the task bar.

Globally I moved from Slack 12.2 to 13 because some of my appz required KDE4... and then from 13 to 13.1 because I had problems with 13 stability. I think KDE is also a major problem with slackware... I believe the back end (core) of the system is still good, but the icing on the cake is way too fat... At the end of the day I use this machine for every day activities such as banking, finance tracking, home work, misc admin work and light entertainment (music youtube, vidz, etc) and need a machine that works... thats why I moved from windows to slack at first a few years ago. Now I kinda question the move..

Richard Cranium 09-11-2010 04:40 PM

Well, since you are having X problems, I'm not surprised that your X display is slow.

I'm running Slackware64 13.1 right now with SLI enabled. I don't run KDE unless I log in as root, which I do very rarely.

You might want to check ~/.xsession-errors to see if anything is being written into there.

lpallard 09-11-2010 05:01 PM

Richard, first of all thanks for the reply, as you can imagine I will be monitoring this thread as much as possible from my blackberry.

The xsession-errors file is 5 light-years long.... its over 1600 lines long and keep growing... What should I copy on this thread to be useful? There is errors about akonadi (of COURSE!!), Kwin, Knotify are pretty much the most "popular" processes in there, and there is roughly 1300 lines from kbuildsycoca4, but I dont see much about the X server or nvidia related...

except that:

Code:

xset:  bad font path element (#23), possible causes are:
    Directory does not exist or has wrong permissions
    Directory missing fonts.dir
    Incorrect font server address or syntax

Invalid D-BUS member name 'idle-hint' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'is-local' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'x11-display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'x11-display' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'remote-host-name' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'session-type' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'unix-user' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
<unknown program name>(2101)/ KStartupInfo::createNewStartupId: creating:  "xpsm1730;1284241899;552516;2101_TIME0" : "unnamed app"
kephald starting up
XRANDR error base:  173
RRInput mask is set!!
RandRScreen::loadSettings - adding mode:  355 1920 x 1200
RandRScreen::loadSettings - adding mode:  356 1600 x 1200
RandRScreen::loadSettings - adding mode:  357 1400 x 1050
RandRScreen::loadSettings - adding mode:  358 1400 x 1050
RandRScreen::loadSettings - adding mode:  359 1280 x 1024
RandRScreen::loadSettings - adding mode:  360 1280 x 1024
RandRScreen::loadSettings - adding mode:  361 1280 x 1024
RandRScreen::loadSettings - adding mode:  362 1280 x 960
RandRScreen::loadSettings - adding mode:  363 1280 x 960
RandRScreen::loadSettings - adding mode:  364 1152 x 864
RandRScreen::loadSettings - adding mode:  365 1024 x 768
RandRScreen::loadSettings - adding mode:  366 1024 x 768
RandRScreen::loadSettings - adding mode:  367 1024 x 768
RandRScreen::loadSettings - adding mode:  368 1024 x 768
RandRScreen::loadSettings - adding mode:  369 1024 x 768
RandRScreen::loadSettings - adding mode:  370 1024 x 768
RandRScreen::loadSettings - adding mode:  371 960 x 720
RandRScreen::loadSettings - adding mode:  372 960 x 720
RandRScreen::loadSettings - adding mode:  373 928 x 696
RandRScreen::loadSettings - adding mode:  374 928 x 696
RandRScreen::loadSettings - adding mode:  375 896 x 672
RandRScreen::loadSettings - adding mode:  376 896 x 672
RandRScreen::loadSettings - adding mode:  377 832 x 624
RandRScreen::loadSettings - adding mode:  378 800 x 600
RandRScreen::loadSettings - adding mode:  379 800 x 600
RandRScreen::loadSettings - adding mode:  380 800 x 600
RandRScreen::loadSettings - adding mode:  381 800 x 600
RandRScreen::loadSettings - adding mode:  382 800 x 600
RandRScreen::loadSettings - adding mode:  383 800 x 600
RandRScreen::loadSettings - adding mode:  384 800 x 600
RandRScreen::loadSettings - adding mode:  385 800 x 600
RandRScreen::loadSettings - adding mode:  386 800 x 600
RandRScreen::loadSettings - adding mode:  387 800 x 600
RandRScreen::loadSettings - adding mode:  388 720 x 400
RandRScreen::loadSettings - adding mode:  389 700 x 525
RandRScreen::loadSettings - adding mode:  390 700 x 525
RandRScreen::loadSettings - adding mode:  391 640 x 512
RandRScreen::loadSettings - adding mode:  392 640 x 512
RandRScreen::loadSettings - adding mode:  393 640 x 512
RandRScreen::loadSettings - adding mode:  394 640 x 480
RandRScreen::loadSettings - adding mode:  395 640 x 480
RandRScreen::loadSettings - adding mode:  396 640 x 480
RandRScreen::loadSettings - adding mode:  397 640 x 480
RandRScreen::loadSettings - adding mode:  398 640 x 480
RandRScreen::loadSettings - adding mode:  399 640 x 480
RandRScreen::loadSettings - adding mode:  400 640 x 400
RandRScreen::loadSettings - adding mode:  401 640 x 350
RandRScreen::loadSettings - adding mode:  402 576 x 432
RandRScreen::loadSettings - adding mode:  403 512 x 384
RandRScreen::loadSettings - adding mode:  404 512 x 384
RandRScreen::loadSettings - adding mode:  405 512 x 384
RandRScreen::loadSettings - adding mode:  406 512 x 384
RandRScreen::loadSettings - adding mode:  407 512 x 384
RandRScreen::loadSettings - adding mode:  408 416 x 312
RandRScreen::loadSettings - adding mode:  409 400 x 300
RandRScreen::loadSettings - adding mode:  410 400 x 300
RandRScreen::loadSettings - adding mode:  411 400 x 300
RandRScreen::loadSettings - adding mode:  412 400 x 300
RandRScreen::loadSettings - adding mode:  413 400 x 300
RandRScreen::loadSettings - adding mode:  414 360 x 200
RandRScreen::loadSettings - adding mode:  415 320 x 240
RandRScreen::loadSettings - adding mode:  416 320 x 240
RandRScreen::loadSettings - adding mode:  417 320 x 240
RandRScreen::loadSettings - adding mode:  418 320 x 240
RandRScreen::loadSettings - adding mode:  419 320 x 200
RandRScreen::loadSettings - adding mode:  420 320 x 175
RandRScreen::loadSettings - adding crtc:  353
RandRScreen::loadSettings - adding output:  354
Setting CRTC 353 on output "default" (previous 0 )
CRTC outputs: (354)
Output name: "default"
Output refresh rate: 50
Output rect: QRect(0,0 1920x1200)
Output rotation: 1
XRandROutputs::init
  added output  354
adding an output 0 with geom:  QRect(0,0 1920x1200)
output: "SCREEN-0" QRect(0,0 1920x1200) 0 true true
load xml
connected: 1
looking for current "SCREEN-0"
known "*" has score: 0.125
screen: 0 QRect(0,0 1920x1200)
looking for a matching configuration...
connected: 1
looking for current "SCREEN-0"
known "*" has score: 0.125
found outputs, known: false
activate external configuration!!
registered the service: true
screens registered on the bus: true
outputs registered on the bus: true
configurations registered on the bus: true
kwin(2133) KDecorationPlugins::loadPlugin: kwin : path  "/usr/lib/kde4/kwin3_oxygen.so"  for  "kwin3_oxygen"
kwin(2133) KWin::Extensions::init: Extensions: shape: 0x "11"  composite: 0x "4"  render: 0x "a"  fixes: 0x "40"
kwin(2133) KWin::Workspace::setupCompositing: Compositing is turned off in options or disabled
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kglobalaccel.so

New PolkitAgentListener  0x8099030
Adding new listener  PolkitQt1::Agent::Listener(0x8143da8) for  0x8099030

(process:2161): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(process:2161): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
"/usr/bin/kdeinit4(2151)" Error in thread 3042744080 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kdeinit4(2151)" Error in thread 3042744080 : "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kdeinit4(2151)" Error in thread 3042744080 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kdeinit4(2151)" Error in thread 3042744080 : "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kdeinit4(2151)" Error in thread 3042744080 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kdeinit4(2151)" Error in thread 3042744080 : "QLocalSocket::connectToServer: Invalid name"
krunner(2151)/kdepimlibs (kabc): "Unable to open resource 'file-resource'."
krunner(2151)/kdepimlibs (kabc): "Unable to open file '/home/louis-philippe/file-storage/applications-files/pim-data/addressbook.vcf'."
ERROR from solid predicate parser: syntax error
ERROR from solid predicate parser: syntax error
/usr/lib/python2.6/site-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)
Traceback (most recent call last):
  File "/usr/bin/printer-applet", line 1161, in <module>
    applet = JobManager()
  File "/usr/bin/printer-applet", line 297, in __init__
    notification = NewPrinterNotification(bus, self)
  File "/usr/bin/printer-applet", line 1050, in __init__
    bus_name = dbus.service.BusName (PDS_OBJ, bus=bus)
  File "/usr/lib/python2.6/site-packages/dbus/service.py", line 129, in __new__
    retval = bus.request_name(name, name_flags)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 306, in request_name
    'su', (name, flags))
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Connection ":1.21" is not allowed to own the service "com.redhat.NewPrinterNotification" due to security policies in the configuration file
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
[akonadiserver] search paths:  ("/usr/local/bin", "/usr/bin", "/bin", "/usr/games", "/usr/lib/java/bin", "/usr/lib/kde4/libexec", "/usr/lib/qt/bin", "/usr/share/texmf/bin", ".", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin")
[akonadiserver] Failed to use database "akonadi"
[akonadiserver] Database error: "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2) QMYSQL: Unable to connect"
[akonadiserver] Trying to create database now...
[akonadiserver] QSqlDatabasePrivate::removeDatabase: connection 'initConnection' is still in use, all queries will cease to work.
[akonadiserver] Database error: Cannot open database.
[akonadiserver] Last driver error: "QMYSQL: Unable to connect"
[akonadiserver] Last database error: "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2)"
[akonadiserver] Unable to open database "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2) QMYSQL: Unable to connect"
[akonadiserver] "[
[akonadiserver] 0: akonadiserver(_Z11akBacktracev+0x35) [0x8051f35]
[akonadiserver] 1: akonadiserver() [0x80523fe]
[akonadiserver] 2: [0xffffe400]
[akonadiserver] 3: /lib/libc.so.6(gsignal+0x47) [0xb6e5ea67]
[akonadiserver] 4: /lib/libc.so.6(abort+0x182) [0xb6e602e2]
[akonadiserver] 5: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x84) [0xb74e5dc4]
[akonadiserver] 6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc4) [0x8053364]
[akonadiserver] 7: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x8e) [0xb757e48e]
[akonadiserver] 8: /usr/lib/libQtCore.so.4(+0x10c6b5) [0xb75916b5]
[akonadiserver] 9: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3d) [0xb7592bcd]
[akonadiserver] 10: akonadiserver(_ZN6QDebugD1Ev+0x43) [0x804d7b3]
[akonadiserver] 11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x5cc) [0xb7753c9c]
[akonadiserver] 12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x58) [0xb7754bf8]
[akonadiserver] 13: akonadiserver(main+0x2ea) [0x804cd3a]
[akonadiserver] 14: /lib/libc.so.6(__libc_start_main+0xe6) [0xb6e49b86]
[akonadiserver] 15: akonadiserver() [0x804c981]
[akonadiserver] ]
[akonadiserver] "
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
[akonadiserver] search paths:  ("/usr/local/bin", "/usr/bin", "/bin", "/usr/games", "/usr/lib/java/bin", "/usr/lib/kde4/libexec", "/usr/lib/qt/bin", "/usr/share/texmf/bin", ".", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin")
[akonadiserver] Failed to use database "akonadi"
[akonadiserver] Database error: "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2) QMYSQL: Unable to connect"
[akonadiserver] Trying to create database now...
[akonadiserver] QSqlDatabasePrivate::removeDatabase: connection 'initConnection' is still in use, all queries will cease to work.
[akonadiserver] Database error: Cannot open database.
[akonadiserver] Last driver error: "QMYSQL: Unable to connect"
[akonadiserver] Last database error: "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2)"
[akonadiserver] Unable to open database "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2) QMYSQL: Unable to connect"
[akonadiserver] "[
[akonadiserver] 0: akonadiserver(_Z11akBacktracev+0x35) [0x8051f35]
[akonadiserver] 1: akonadiserver() [0x80523fe]
[akonadiserver] 2: [0xffffe400]
[akonadiserver] 3: /lib/libc.so.6(gsignal+0x47) [0xb6e7ba67]
[akonadiserver] 4: /lib/libc.so.6(abort+0x182) [0xb6e7d2e2]
[akonadiserver] 5: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x84) [0xb7502dc4]
[akonadiserver] 6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc4) [0x8053364]
[akonadiserver] 7: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x8e) [0xb759b48e]
[akonadiserver] 8: /usr/lib/libQtCore.so.4(+0x10c6b5) [0xb75ae6b5]
[akonadiserver] 9: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3d) [0xb75afbcd]
[akonadiserver] 10: akonadiserver(_ZN6QDebugD1Ev+0x43) [0x804d7b3]
[akonadiserver] 11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x5cc) [0xb7770c9c]
[akonadiserver] 12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x58) [0xb7771bf8]
[akonadiserver] 13: akonadiserver(main+0x2ea) [0x804cd3a]
[akonadiserver] 14: /lib/libc.so.6(__libc_start_main+0xe6) [0xb6e66b86]
[akonadiserver] 15: akonadiserver() [0x804c981]
[akonadiserver] ]
[akonadiserver] "
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
[akonadiserver] search paths:  ("/usr/local/bin", "/usr/bin", "/bin", "/usr/games", "/usr/lib/java/bin", "/usr/lib/kde4/libexec", "/usr/lib/qt/bin", "/usr/share/texmf/bin", ".", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin")
[akonadiserver] Failed to use database "akonadi"
[akonadiserver] Database error: "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2) QMYSQL: Unable to connect"
[akonadiserver] Trying to create database now...
[akonadiserver] QSqlDatabasePrivate::removeDatabase: connection 'initConnection' is still in use, all queries will cease to work.
[akonadiserver] Database error: Cannot open database.
[akonadiserver] Last driver error: "QMYSQL: Unable to connect"
[akonadiserver] Last database error: "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2)"
[akonadiserver] Unable to open database "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2) QMYSQL: Unable to connect"
Calling appendChild() on a null node does nothing.
[akonadiserver] "[
[akonadiserver] 0: akonadiserver(_Z11akBacktracev+0x35) [0x8051f35]
[akonadiserver] 1: akonadiserver() [0x80523fe]
[akonadiserver] 2: [0xffffe400]
[akonadiserver] 3: /lib/libc.so.6(gsignal+0x47) [0xb6dd1a67]
[akonadiserver] 4: /lib/libc.so.6(abort+0x182) [0xb6dd32e2]
[akonadiserver] 5: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x84) [0xb7458dc4]
[akonadiserver] 6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc4) [0x8053364]
[akonadiserver] 7: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x8e) [0xb74f148e]
[akonadiserver] 8: /usr/lib/libQtCore.so.4(+0x10c6b5) [0xb75046b5]
[akonadiserver] 9: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3d) [0xb7505bcd]
[akonadiserver] 10: akonadiserver(_ZN6QDebugD1Ev+0x43) [0x804d7b3]
[akonadiserver] 11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x5cc) [0xb76c6c9c]
[akonadiserver] 12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x58) [0xb76c7bf8]
[akonadiserver] 13: akonadiserver(main+0x2ea) [0x804cd3a]
[akonadiserver] 14: /lib/libc.so.6(__libc_start_main+0xe6) [0xb6dbcb86]
[akonadiserver] 15: akonadiserver() [0x804c981]
[akonadiserver] ]
[akonadiserver] "
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
[akonadiserver] search paths:  ("/usr/local/bin", "/usr/bin", "/bin", "/usr/games", "/usr/lib/java/bin", "/usr/lib/kde4/libexec", "/usr/lib/qt/bin", "/usr/share/texmf/bin", ".", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin")
[akonadiserver] Failed to use database "akonadi"
[akonadiserver] Database error: "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2) QMYSQL: Unable to connect"
[akonadiserver] Trying to create database now...
[akonadiserver] QSqlDatabasePrivate::removeDatabase: connection 'initConnection' is still in use, all queries will cease to work.
[akonadiserver] Database error: Cannot open database.
[akonadiserver] Last driver error: "QMYSQL: Unable to connect"
[akonadiserver] Last database error: "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2)"
[akonadiserver] Unable to open database "Can't connect to local MySQL server through socket '/home/louis-philippe/.local/share/akonadi/db_misc/mysql.socket' (2) QMYSQL: Unable to connect"
[akonadiserver] "[
[akonadiserver] 0: akonadiserver(_Z11akBacktracev+0x35) [0x8051f35]
[akonadiserver] 1: akonadiserver() [0x80523fe]
[akonadiserver] 2: [0xffffe400]
[akonadiserver] 3: /lib/libc.so.6(gsignal+0x47) [0xb6d08a67]
[akonadiserver] 4: /lib/libc.so.6(abort+0x182) [0xb6d0a2e2]
[akonadiserver] 5: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x84) [0xb738fdc4]
[akonadiserver] 6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc4) [0x8053364]
[akonadiserver] 7: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x8e) [0xb742848e]
[akonadiserver] 8: /usr/lib/libQtCore.so.4(+0x10c6b5) [0xb743b6b5]
[akonadiserver] 9: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3d) [0xb743cbcd]
[akonadiserver] 10: akonadiserver(_ZN6QDebugD1Ev+0x43) [0x804d7b3]
[akonadiserver] 11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x5cc) [0xb75fdc9c]
[akonadiserver] 12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x58) [0xb75febf8]
[akonadiserver] 13: akonadiserver(main+0x2ea) [0x804cd3a]
[akonadiserver] 14: /lib/libc.so.6(__libc_start_main+0xe6) [0xb6cf3b86]
[akonadiserver] 15: akonadiserver() [0x804c981]
[akonadiserver] ]
[akonadiserver] "
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
"akonadiserver" crashed too often and will not be restarted!
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
knotify(2138) KNotify::event: 24  ref= 0
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kwalletd.so
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
"/usr/bin/kontact(2186)" Error in thread 3009898256 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kontact(2186)" Error in thread 3009898256 : "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kontact(2186)" Error in thread 3009898256 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kontact(2186)" Error in thread 3009898256 : "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kontact(2186)" Error in thread 3009898256 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kontact(2186)" Error in thread 3009898256 : "QLocalSocket::connectToServer: Invalid name"
kwin(2133) KWin::Workspace::updateClientArea: screens:  1 desktops:  1
kwin(2133) KWin::Workspace::updateClientArea: Done.
knotify(2138) KNotify::event: 25  ref= 0
knotify(2138) KNotify::event: 26  ref= 0
kontact(2186)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kontact(2186)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kontact(2186)/kdeui (kdelibs): No such XML file "/home/louis-philippe/.kde/share/apps/kontact/local-kmail.rc"
kdeinit4: preparing to launch /usr/bin/korgac
kwin(2133) KWin::Client::readUserTimeMapTimestamp: User timestamp, initial: 189875
kwin(2133) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 189875
kwin(2133) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 37748804 ;WMCLASS: "kontact" : "kontact" ;Caption: "Mail - Kontact" ' : 189875
kwin(2133) KWin::Workspace::allowClientActivation: Activation, compared: 'ID: 37748804 ;WMCLASS: "kontact" : "kontact" ;Caption: "Mail - Kontact" ' : 189875 : 198675 : false
kwin(2133) KWin::Workspace::updateClientArea: screens:  1 desktops:  1
kwin(2133) KWin::Workspace::updateClientArea: Done.
knotify(2138) KNotify::event: 27  ref= 0
knotify(2138) KNotify::event: 28  ref= 0
knotify(2138) KNotify::event: 29  ref= 0
knotify(2138) NotifyByPopup::notify: 30  active notifications: () ()
kwin(2133) KWin::Client::readUserTimeMapTimestamp: User timestamp, initial: 4294967295
kwin(2133) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 189875
kwin(2133) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 52428825 ;WMCLASS: "kwalletd" : "kwalletd" ;Caption: "KDE Wallet Service" ' : 189875
kwin(2133) KWin::Workspace::allowClientActivation: Activation, compared: 'ID: 52428825 ;WMCLASS: "kwalletd" : "kwalletd" ;Caption: "KDE Wallet Service" ' : 189875 : 198675 : false
kwin(2133) KWin::Workspace::updateClientArea: screens:  1 desktops:  1
kwin(2133) KWin::Workspace::updateClientArea: Done.
QGraphicsLinearLayout::removeAt: invalid index 1
korgac(2206) KOAlarmClient::KOAlarmClient:
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
knotify(2138) NotifyByPopup::sendNotificationDBus: mapping knotify id to dbus id: 30 => 1
knotify(2138) KNotify::event: 30  ref= 1
knotify(2138) KNotify::event: 31  ref= 0
korgac(2206) KOAlarmClient::KOAlarmClient: KOAlarmClient check interval: 60 seconds.
knotify(2138) KNotify::event: 32  ref= 0
plasma-desktop(2139)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
knotify(2138) NotifyByPopup::slotDBusNotificationActionInvoked: action "2" invoked for notification  30
knotify(2138) NotifyByPopup::slotDBusNotificationClosed: 1  ->  0
knotify(2138) NotifyByPopup::slotDBusNotificationClosed: failed to find knotify id for dbus_id 1
knotify(2138) KNotify::event: 33  ref= 0
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kwin(2133) KWin::Workspace::updateClientArea: screens:  1 desktops:  1
kwin(2133) KWin::Workspace::updateClientArea: Done.
knotify(2138) KNotify::event: 34  ref= 0
knotify(2138) KNotify::event: 35  ref= 0
kdeinit4: preparing to launch /usr/bin/kwalletmanager
kdeinit4: preparing to launch /usr/lib/kde4/kio_pop3.so
kontact(2186)/libakonadi Akonadi::Control::Private::exec: Could not start/stop Akonadi!

Should I have so much stuff in there!?!?!?!?

Look at http://www.linuxquestions.org/questi...isplay-830040/

Look at the syslog messages.. apparently, the messages:
Code:

Sep 10 21:54:49 xpsm1730 kernel: NVRM: loading NVIDIA UNIX x86 Kernel Module  195.36.31  Tue Jun  1 22:08:27 PDT 2010 
Sep 10 21:55:20 xpsm1730 kernel: NVRM: RmInitAdapter failed! (0x26:0xffffffff:1076)                                         
Sep 10 21:55:20 xpsm1730 kernel: NVRM: rm_init_adapter(1) failed                                                         
Sep 10 21:55:23 xpsm1730 kernel: vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.
Sep 10 21:55:23 xpsm1730 kernel: NVRM: RmInitAdapter failed! (0x26:0xffffffff:1076)                                     
Sep 10 21:55:23 xpsm1730 kernel: NVRM: rm_init_adapter(1) failed

would mean insufficient or mis-allocated memory between the GPU's and the main RAM.. I got that from Google... That would be why my SLI is not working... Kernel problems??

Richard Cranium 09-11-2010 06:03 PM

Well, your lspci output in the other thread was very weird:

Quote:

03:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8700M GT] (rev a1)
04:00.0 3D controller: nVidia Corporation G84 [GeForce 8700M GT] (rev a1)
So I wonder if there is some type of goofy BIOS setting that is making your two identical cards report differently?

My SLI enabled cards report themselves to be the same (they are the exact same model, so they should):

Code:

02:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 9800 GT] (rev a2)
03:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 9800 GT] (rev a2)

Was this an upgrade from 12.x or a fresh install? You may want to drop out of X, rename your ~/.kde directory to something else, and restart KDE. If that clears up some of your issues, then it might be incompatible KDE configuration from the previous releases.

lpallard 09-11-2010 06:24 PM

Richard,

yes you might be right, lspci SHOULD show 2 identical descriptions such as "VGA compatible controller: nVidia Corporation G84 [GeForce 8700M GT] (rev a1)" and not a "3D controller..."

I remember it used to show that in Slack 12.2... also I am not the only one in this situation: http://www.nvnews.net/vbulletin/arch.../t-127679.html

In the BIOS there is nothing to fool around with the video cards.. I have NO on-boards... its a laptop (Dell XPSM1730)

No it was not an upgrade from anything... Fresh install from Slack 13.1 ISO DVD... Stock KDE as well (KDE4.4.3) from 13.1

Isn't all that strange? The guy who posted at the link above also has a XPS laptop like mine... could it be some firmware crap from Dell??

EDIT: this one also has a XPS M1730 and it seems that his 2nd GPU is also recognixed as 3D controller... http://centos.org/modules/newbb/view...27163&forum=40

Richard Cranium 09-11-2010 08:06 PM

I just logged in using KDE a couple of times.

Wow.

The version in 13.1 vomits a ton of crap into ~/.xsession-errors, so I guess that amount of crap in your ~/.xsession-errors is expected behavior.

I never really cared for KDE before that test; I really don't care for it now.

At any rate, I can't really help with the Dell stuff. Sorry.

lpallard 09-11-2010 08:33 PM

yeah kde 4 is pretty crappy... not far from windowz... imagine if its puking all that crap in the error log whats going on in the background.... sounds like Im not the only one that does not like kde4.

WHat are you using? Gnome? something else?

For the Dell stuff, I will try on the nvidia forums and see what I can get there... I will have this thread here and a thread over there maybe somebody got it figured out..

rob.rice 09-11-2010 09:49 PM

you most likely have errors in your install media
I had a bunch of problems with a fresh install it turned out to be a bad CD
down load the slackware ISOs and check the md5 sums
then recheck the sums of the media after you burn it

lpallard 09-12-2010 09:06 AM

Hey rob! your suggestion was smart, but I checked the md5 has for all the install file (I did not use a DVD iso but I mirrored the slack tree to my server) and all files passed the md5 checksum with success... so I believe my install repository is clean.

veeall 09-12-2010 02:31 PM

Maybe there was something configured differently for nvidia in xorg.conf in 12.2. Just a thought.

I had problems with sending mail when i messed with akonadi, trying to get rid of akonadi error message that popped up when starting kmail. Maybe removing akonadi directories could help.

Make sure there're no data you want to keep in these directories, maybe couple of them are not even necessary to remove, i blindly removed everything related to akonadi/nepomuk/kontact:

Code:

# stop akonadi
akonadictl stop
#akonadictl status # check that akonadi is really stopped as it may take some time
# clean up old akonadi files etc.
rm -R $HOME/.config/akonadi
rm -R $HOME/.local/share/akonadi/
rm -R $HOME/.local/share/local-mail/
rm -R $HOME/.local/share/contacts/
rm $HOME/.kde/share/config/akonadi*
rm $HOME/.kde/share/config/kaddressbook*
rm $HOME/.kde/share/config/kres-migratorrc
rm -R $HOME/.kde/share/config/kresources/contact/

As for kde notifications i installed 'colibri' notifications from kde-apps.org, they look fine and are completely passive, great for amarok for example. I also disabled notifications for file transfers, this reverts kde4 to displaing kde3 style popup windows for downloads.

lpallard 09-12-2010 03:28 PM

veeall
thanks for the input! there is definitely something wrong with nvidia and/or x... actually, everything is getting just slower and slower, even scrolling a page in firefox is choppy and closing a simple konqueror window is delayed...

for akonadi, well its simply a mess... i'll try what you suggest.
thanks!

tramni1980 09-12-2010 04:18 PM

lpallard,

KDE 4 is pretty good and Slackware 13.1 is pretty responsive, provided that you have set your hardware and BIOS right and have fiddled a bit configuring KDE.

To be more detailed, make sure to use the proprietary nvidia driver for your video card. You can download and install the nvidia-kernel and nvidia-driver packages from slackbuilds.org. If you have 2 video cards, make sure that you use the driver for the enabled card.
To make KDE4 more responsive, I strongly recommend you to disable Aconadi in the system settings.


Have fun

Martin

lpallard 09-12-2010 04:44 PM

Martin,

right now I am using KDE4.4.3, would you think the new 4.5 would help? Im also using Kontact & Kmail... if I delete/nuke/destroy akonadi, I lose Kontact all together...

also my main concern is the nvidia stuff.... again right now I just installed slack, and then installed the driver from Nvidia (NVIDIA-Linux-x86-256.53.run)

I never heard about the nvidia kernel and nvidia module from slackbuild.. whats the difference? I tough the nvidia driver was installing its own module....

Can you clarify?
Thanks!

Richard Cranium 09-12-2010 05:23 PM

Well, it's probably easiest to just read this and that.

zrdc28 09-12-2010 09:11 PM

I have windows 7 that ran as good as windows gets along with Slackware 12.2 on this machine a Dell gx280 with never a problem. I installed Slackware 13.1 and that is where my problems started a lot of them the same as above. Someone on this forum suggested that it might be a hardware problem.
(1) I did a memory test everything turned out ok.
(2) next I did a smartctl long test, it found an unused "before with 12.2"section of my /home had some bad blocks that was being used with 13.1. I blocked those bad blocks and everything was ok for a while then it started all over again as it turned out the hdd was crashing. I would suggest that you might look at hardware just to be sure. There is Slackware 13.1 on 2 machines here now and they are working fine.

smartctl -t long /dev/hda
smartctl -H /dev/sda to look at results of long test


All times are GMT -5. The time now is 02:07 AM.