-   Slackware (
-   -   minicom not working (

wufo 12-13-2012 12:53 PM

minicom not working
I am running 13.37 and I have a problem with minicom. I need a terminal emulator for downloading code to an embedded board. I run old tried and true, that I have used in the past, minicom. But, instead of getting the ncurses screen It just sits there. Type the command "minicom -s" or just "minicom" and nothing happens. No errors, nothing, cursor just goes down a line and sits there until I Ctrl-C.

Any help out there?


KeithE 12-13-2012 01:16 PM

Are permissions set properly (666, or read/write) for your serial port (/dev/ttyS0 = COM1, for example)? Is there a symlink to your desired serial port from /dev/modem? I found the latter to be necessary before Minicom would work, and IIRC, /dev/modem is the default for Minicom.

pdi 12-13-2012 01:23 PM

I had a similar problem. Did you check this?

wufo 12-14-2012 09:34 AM

Bingo, adding the newline to the minirc.dfl file fixed the problem.
Many thanks.


All times are GMT -5. The time now is 01:36 AM.