-   Slackware (
-   -   Midnight Commander hangs up console or xterm (

w1k0 05-28-2008 02:17 PM

Midnight Commander hangs up console or xterm
*** The problem is solved. It concerns very peculiar configuration of the system, so you aren't probably interested in reading the entire thread ***

I use Slackware 12.1 but the same problem I noticed using two former versions of Slackware.

In my system there are two users: first and second. Both users was made using the same set of commands and both use similar .bashrc and .bash_profile files. They should be the same but aren't. As the first user I can start Midnight Commander and use all its functionalities. When I start Midnight Commander as the second user using mc command, the program hangs up console or xterm respectively. As the second user I need to start Midnight Commander using mc -u command disabling concurrent shell. The result isn't satisfactory, because in that mode Midnight Commander doesn't allow to use console or xterm.

What should I do to restore the possibility of using mc command for standard operation of Midnight Commander?

Have a nice day...


T3slider 05-28-2008 02:45 PM

Is your user shell set up properly? (Check /etc/passwd. Most people use /bin/bash as their shell.)

w1k0 05-28-2008 03:09 PM

Both my users use /bin/bash:

# cat /etc/passwd | tail -n 2


I made these users using simple newuser script:

if [ ! -e ${DIRECTORY} ]
echo "Adding ${USER} and configuring his/her account."
useradd ${USER}
mkdir ${DIRECTORY}
chmod 711 ${DIRECTORY}
chown ${USER}:users ${DIRECTORY}
mkdir ${DIRECTORY}bin/
chown ${USER}:users ${DIRECTORY}bin/
chsh -s /bin/bash ${USER}
passwd ${USER}
touch /var/spool/mail/${USER}
chmod 660 /var/spool/mail/${USER}
chown ${USER}:mail /var/spool/mail/${USER}

allend 05-28-2008 07:32 PM

And what happens if you add the user using the standard "adduser" Slackware script?

w1k0 05-28-2008 08:11 PM

Problem solved by T3slider -- thank you very much
The simplest methods are the best... Now Midnight Commander works good for the second user as well. I didn't tried adduser command before for the second user, because my script worked well for the first. I assumed: if it works for the first user it must work for the second and the reason of that problem is another. I still don't know why adduser works and my script doesn't work but I don't bother with it. It's enough that Midnight Commander works well for both users.

Thank you allend for your hint once again! (I mistyped your name in the title of that post -- excuse me).

All times are GMT -5. The time now is 06:52 PM.