LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-15-2013, 01:57 AM   #1
Toutatis
LQ Newbie
 
Registered: Feb 2013
Posts: 28

Rep: Reputation: Disabled
"microcode" error message


Hello,

I get this in dmesg

-----------------------------------------------------------
[ 6.846903] microcode: CPU0: patch_level=0x010000bf
[ 6.873221] microcode: failed to load file amd-ucode/microcode_amd.bin
[ 6.873341] microcode: CPU1: patch_level=0x010000bf
[ 6.873495] microcode: CPU2: patch_level=0x010000bf
[ 6.873655] microcode: CPU3: patch_level=0x010000bf
[ 6.873781] microcode: CPU4: patch_level=0x010000bf
[ 6.873924] microcode: CPU5: patch_level=0x010000bf
[ 6.874102] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
-----------------------------------------------------------

but everything else seems to work.
(system : slackware64-current on a Phenom II X6 1090 T).

Should I do something to get rid of this message ?
 
Old 05-15-2013, 01:44 PM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,231

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
It is a harmless error -- it tries to load updated microcode if available (compared to what is included with the BIOS). While you could ignore it, it would be best to get the latest microcode (that may fix CPU bugs) and throw it in /lib/firmware/amd-ucode/. See here for an overview, and here for a download link (the amd64.org site has been down for quite a while now so you'll have to grab the last available microcode from here, linked in the above thread). There is an INSTALL file in the tarball with instructions, but basically you just have to create the /lib/firmware/amd-ucode directory and copy microcode_amd.bin and microcode_amd_fam15h.bin to that directory.

If you do that, the error will disappear and any CPU bugs that may have been present should be fixed (not that you were likely to have noticed them without updated microcode anyway).
 
3 members found this post helpful.
Old 05-15-2013, 02:38 PM   #3
emgee_1
Member
 
Registered: Aug 2009
Location: Nijmegen, The Netherlands
Distribution: Slackware 14
Posts: 38

Rep: Reputation: 6
I am very happy with the reply of T3slider. After upgrading my acer aspire 5560 to slackware 14 current and using 3.8.13 I noticed this microcode fail.

Thanks for a link to the code.

Marcel
 
Old 05-15-2013, 03:51 PM   #4
Toutatis
LQ Newbie
 
Registered: Feb 2013
Posts: 28

Original Poster
Rep: Reputation: Disabled
Thank you T3slider. But I hesitate to install this. I have already used this CPU for 2 and 1/2 years and did not found any error. Maybe I should wait to know which errors are corrected by this patch.
 
Old 05-15-2013, 05:31 PM   #5
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 836

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
Quote:
Originally Posted by Toutatis View Post
Thank you T3slider. But I hesitate to install this. I have already used this CPU for 2 and 1/2 years and did not found any error. Maybe I should wait to know which errors are corrected by this patch.
I have the same CPU and have not installed the microcode. No problems noted so far.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"iwlagn Microcode SW error detected" -- Ubuntu v9.04 (Jaunty or Mint-7) SaintDanBert Linux - Networking 1 04-08-2010 02:25 PM
bcm43xx: Error: Microcode "bcm43xx_microcode4.fw" not available or load failed naveen Linux - Wireless Networking 2 10-27-2007 07:27 AM
bcm43xx Microcode "bcm43xx_microcode5.fw" not available or load failed Shioni Linux - Hardware 3 10-16-2007 01:53 AM
FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? A6Quattro Fedora 6 07-20-2005 12:49 PM
error message when pressing "Next" "BIOS Problems" , help ! HeRCuLeSX Fedora 3 07-21-2004 02:37 PM


All times are GMT -5. The time now is 06:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration