LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-14-2020, 12:22 AM   #1
LuckyCyborg
Member
 
Registered: Mar 2010
Posts: 488

Rep: Reputation: 316Reputation: 316Reputation: 316Reputation: 316
mesa-19.3.4-x86_64-1 - crash of the X11 server on a box with AM3 Athlon x4 605e running -current and latest Plasma5


I had to rollback to the previous version: mesa-19.3.3-x86_64-1

The reason is that the latest Mesa package crashes the X11 server leaving me in console.

Please note that's used the on-board Radeon HD4250 and the system have 8GB DDR3 1333MHz.
Code:
Current Operating System: Linux darkstar.example.org 5.4.19 #1 SMP Tue Feb 11 13:39:28 CST 2020 x86_64
Kernel command line: auto BOOT_IMAGE=Slackware64 ro root=UUID=9a83ce56-19db-4a1d-839c-5273ec4306c8 resume=/dev/sdb3 scsi_mod.use_blk_mq=1 zswap.enabled=1 zswap.compressor=lzo zswap.max_pool_percent=20 zswap.zpool=z3fold rootflags=defaults,noatime,discard,commit=60
Build Date: 14 January 2020  12:43:20PM

Current version of pixman: 0.38.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 14 06:51:17 2020
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
(EE)
(EE) Backtrace:
(EE) 0: /usr/libexec/Xorg (OsLookupColor+0x138) [0x58af68]
(EE) 1: /lib64/libpthread.so.0 (funlockfile+0x50) [0x7fe3961556df]
(EE) 2: /usr/lib64/xorg/modules/dri/r600_dri.so (nouveau_drm_screen_create+0x19f830) [0x7fe394063150]
(EE) 3: /usr/lib64/xorg/modules/dri/r600_dri.so (nouveau_drm_screen_create+0x1b14dc) [0x7fe3940867bc]
(EE) 4: /usr/lib64/xorg/modules/dri/r600_dri.so (nouveau_drm_screen_create+0x19d31d) [0x7fe39405e1cd]
(EE) 5: /usr/lib64/xorg/modules/dri/r600_dri.so (nouveau_drm_screen_create+0x19e449) [0x7fe39405fba9]
(EE) unw_get_proc_name failed: no unwind info found [-10]
(EE) 6: /usr/lib64/xorg/modules/dri/r600_dri.so (?+0x0) [0x7fe393aaa450]
(EE) 7: /lib64/ld-linux-x86-64.so.2 (call_init.part.0+0x9a) [0x7fe3966a646a]
(EE) 8: /lib64/ld-linux-x86-64.so.2 (_dl_init+0x79) [0x7fe3966a6569]
(EE) 9: /lib64/ld-linux-x86-64.so.2 (dl_open_worker+0x3e3) [0x7fe3966aa653]
(EE) 10: /lib64/libc.so.6 (_dl_catch_exception+0x5e) [0x7fe3960b087e]
(EE) 11: /lib64/ld-linux-x86-64.so.2 (_dl_open+0xa6) [0x7fe3966a9c76]
(EE) 12: /lib64/libdl.so.2 (dlopen_doit+0x58) [0x7fe396167248]
(EE) 13: /lib64/libc.so.6 (_dl_catch_exception+0x5e) [0x7fe3960b087e]
(EE) 14: /lib64/libc.so.6 (_dl_catch_error+0x1f) [0x7fe3960b08ef]
(EE) 15: /lib64/libdl.so.2 (_dlerror_run+0x65) [0x7fe396167965]
(EE) 16: /lib64/libdl.so.2 (dlopen+0x36) [0x7fe3961672c6]
(EE) 17: /usr/lib64/libgbm.so.1 (gbm_format_get_name+0x268b) [0x7fe3952ce8cb]
(EE) 18: /usr/lib64/libgbm.so.1 (gbm_format_get_name+0x15e5) [0x7fe3952cc895]
(EE) 19: /usr/lib64/libgbm.so.1 (gbm_format_get_name+0x1a68) [0x7fe3952cd058]
(EE) 20: /usr/lib64/libgbm.so.1 (gbm_create_device+0x44) [0x7fe3952c9624]
(EE) unw_get_proc_name failed: no unwind info found [-10]
(EE) 21: /usr/lib64/xorg/modules/drivers/radeon_drv.so (?+0x0) [0x7fe3953320a0]
(EE) unw_get_proc_name failed: no unwind info found [-10]
(EE) 22: /usr/lib64/xorg/modules/drivers/radeon_drv.so (?+0x0) [0x7fe395321b40]
(EE) 23: /usr/libexec/Xorg (InitOutput+0xa14) [0x47e304]
(EE) 24: /usr/libexec/Xorg (InitFonts+0x1c4) [0x442f64]
(EE) 25: /lib64/libc.so.6 (__libc_start_main+0xeb) [0x7fe395f80e5b]
(EE) 26: /usr/libexec/Xorg (_start+0x2a) [0x42deea]
(EE)
(EE) Illegal instruction at address 0x7fe393ec3920
(EE)
Fatal server error:
(EE) Caught signal 4 (Illegal instruction). Server aborting
(EE)
(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
Looks like the AVX instructions strikes back...

I say that because in another box everything works perfectly, with an Intel i3-2120 and same system setup.

Last edited by LuckyCyborg; 02-14-2020 at 12:40 AM.
 
Old 02-14-2020, 04:26 AM   #2
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,714

Rep: Reputation: 674Reputation: 674Reputation: 674Reputation: 674Reputation: 674Reputation: 674
Same problem, here. with radeon.
 
4 members found this post helpful.
Old 02-14-2020, 04:53 AM   #3
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,638

Rep: Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809
Same here with nvidia 7300
Had to downgrade mesa in order to use X again
 
3 members found this post helpful.
Old 02-14-2020, 07:17 AM   #4
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64-current
Posts: 349

Rep: Reputation: 58
Nividia GTX-970, driver 440.59, Slack64-current, Plasma5-pam and everything is working fine in the x world using the new mesa-19.3.4.
 
Old 02-14-2020, 09:55 AM   #5
linuxxer
Member
 
Registered: Apr 2011
Location: I have my own planet
Distribution: SlackwareŽ
Posts: 186

Rep: Reputation: Disabled
I am also facing the same problem.

Code:
[    76.646] (II) Loading sub module "glamoregl"
[    76.646] (II) LoadModule: "glamoregl"
[    76.646] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[    76.669] (II) Module glamoregl: vendor="X.Org Foundation"
[    76.669] 	compiled for 1.20.7, module version = 1.0.1
[    76.669] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    77.296] (EE) 
[    77.296] (EE) Backtrace:
[    77.297] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x138) [0x58af68]
[    77.299] (EE) 1: /lib64/libpthread.so.0 (funlockfile+0x50) [0x7f5fb0f266df]
[    77.301] (EE) 2: /usr/lib64/xorg/modules/dri/iris_dri.so (nouveau_drm_screen_create+0x19f830) [0x7f5faed83150]
[    77.303] (EE) 3: /usr/lib64/xorg/modules/dri/iris_dri.so (nouveau_drm_screen_create+0x1b14dc) [0x7f5faeda67bc]
[    77.304] (EE) 4: /usr/lib64/xorg/modules/dri/iris_dri.so (nouveau_drm_screen_create+0x19d31d) [0x7f5faed7e1cd]
[    77.306] (EE) 5: /usr/lib64/xorg/modules/dri/iris_dri.so (nouveau_drm_screen_create+0x19e449) [0x7f5faed7fba9]
[    77.308] (EE) unw_get_proc_name failed: no unwind info found [-10]
[    77.308] (EE) 6: /usr/lib64/xorg/modules/dri/iris_dri.so (?+0x0) [0x7f5fae7ca450]
[    77.311] (EE) 7: /lib64/ld-linux-x86-64.so.2 (call_init.part.0+0x9a) [0x7f5fb145c46a]
[    77.313] (EE) 8: /lib64/ld-linux-x86-64.so.2 (_dl_init+0x79) [0x7f5fb145c569]
[    77.316] (EE) 9: /lib64/ld-linux-x86-64.so.2 (dl_open_worker+0x3e3) [0x7f5fb1460653]
[    77.319] (EE) 10: /lib64/libc.so.6 (_dl_catch_exception+0x5e) [0x7f5fb0e8187e]
[    77.321] (EE) 11: /lib64/ld-linux-x86-64.so.2 (_dl_open+0xa6) [0x7f5fb145fc76]
[    77.324] (EE) 12: /lib64/libdl.so.2 (dlopen_doit+0x58) [0x7f5fb0f38248]
[    77.327] (EE) 13: /lib64/libc.so.6 (_dl_catch_exception+0x5e) [0x7f5fb0e8187e]
[    77.329] (EE) 14: /lib64/libc.so.6 (_dl_catch_error+0x1f) [0x7f5fb0e818ef]
[    77.332] (EE) 15: /lib64/libdl.so.2 (_dlerror_run+0x65) [0x7f5fb0f38965]
[    77.334] (EE) 16: /lib64/libdl.so.2 (dlopen+0x36) [0x7f5fb0f382c6]
[    77.336] (EE) 17: /usr/lib64/libgbm.so.1 (gbm_format_get_name+0x268b) [0x7f5fb040a8cb]
[    77.338] (EE) 18: /usr/lib64/libgbm.so.1 (gbm_format_get_name+0x15e5) [0x7f5fb0408895]
[    77.340] (EE) 19: /usr/lib64/libgbm.so.1 (gbm_format_get_name+0x1a68) [0x7f5fb0409058]
[    77.342] (EE) 20: /usr/lib64/libgbm.so.1 (gbm_create_device+0x44) [0x7f5fb0405624]
[    77.344] (EE) 21: /usr/lib64/xorg/modules/libglamoregl.so (glamor_egl_init+0x53) [0x7f5faff021f3]
[    77.346] (EE) unw_get_proc_name failed: no unwind info found [-10]
[    77.346] (EE) 22: /usr/lib64/xorg/modules/drivers/modesetting_drv.so (?+0x0) [0x7f5fb041d780]
[    77.347] (EE) 23: /usr/libexec/Xorg (InitOutput+0xa14) [0x47e304]
[    77.348] (EE) 24: /usr/libexec/Xorg (InitFonts+0x1c4) [0x442f64]
[    77.351] (EE) 25: /lib64/libc.so.6 (__libc_start_main+0xeb) [0x7f5fb0d51e5b]
[    77.351] (EE) 26: /usr/libexec/Xorg (_start+0x2a) [0x42deea]
[    77.352] (EE) 
[    77.352] (EE) Illegal instruction at address 0x7f5faebe3920
[    77.352] (EE) 
Fatal server error:
[    77.352] (EE) Caught signal 4 (Illegal instruction). Server aborting
 
3 members found this post helpful.
Old 02-14-2020, 10:05 AM   #6
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Distribution: Slackware Linux
Posts: 564

Rep: Reputation: 212Reputation: 212Reputation: 212
I just rolled back mesa to recover from the same problem. My old laptop has first gen i7 and current64 with plasma5.
NO nvidia
 
2 members found this post helpful.
Old 02-14-2020, 10:08 AM   #7
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado, USA
Distribution: Slackware
Posts: 602

Rep: Reputation: 196Reputation: 196
X11/KDE is up and running fine also.

AMD A8-7600 Radeon R7, ASUS A88XM-E motherboard, amdgpu,radeon UDEV loaded modules, 64-current, ktown, no PAM (yet)
 
Old 02-14-2020, 01:30 PM   #8
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,850

Rep: Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985
Quote:
Originally Posted by LuckyCyborg View Post
I had to rollback to the previous version: mesa-19.3.3-x86_64-1

The reason is that the latest Mesa package crashes the X11 server leaving me in console.
Works on my i7 with Intel graphics, but crashes on the Phenom II with Radeon HD 4200. Same with mesa-20.0.0-rc3. Guess I better bisect it.
 
5 members found this post helpful.
Old 02-14-2020, 01:51 PM   #9
ZhaoLin1457
Member
 
Registered: Jan 2018
Posts: 405

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Quote:
Originally Posted by volkerdi View Post
Works on my i7 with Intel graphics, but crashes on the Phenom II with Radeon HD 4200. Same with mesa-20.0.0-rc3. Guess I better bisect it.
If it helps, I can confirm the X server crash with the processor: Athlon x2 7850 (AM2+ socket), memory: 4GB DDR2 800 and discrete video card: Radeon HD4350, which uses the "radeon" driver.

Please note that suspecting too a build with too high CPU instructions set, I did a (local) build of mesa package, but even the package built on my own system ended crashing the X server, like the original and I had to return to the previous official package: 19.3.3

Last edited by ZhaoLin1457; 02-14-2020 at 01:59 PM.
 
2 members found this post helpful.
Old 02-14-2020, 02:10 PM   #10
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,850

Rep: Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985Reputation: 5985
And the winner is:

Code:
4656d2d30a8c176d81f31827302cd082eff59de3 is the first bad commit
commit 4656d2d30a8c176d81f31827302cd082eff59de3
Author: Vinson Lee <vlee@freedesktop.org>
Date:   Sat Feb 1 01:12:32 2020 -0800

    swr: Fix GCC 4.9 checks.

    Fixes: f0a22956be48 ("swr/rast: _mm*_undefined_* implementations for gcc<4.9")
    Fixes: e21fc2c62527 ("swr/rast: non-regex knob fallback code for gcc < 4.9")
    Signed-off-by: Vinson Lee <vlee@freedesktop.org>
    Reviewed-by: Jan Zielinski <jan.zielinski@intel.com>
    (cherry picked from commit deb2bbf57ec1d0660dd85b7080bf5ebeb10e8768)

 .pick_status.json                                                  | 2 +-
 src/gallium/drivers/swr/rasterizer/codegen/templates/gen_knobs.cpp | 2 +-
 src/gallium/drivers/swr/rasterizer/common/os.h                     | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)
I have verified that reverting this patch fixes mesa 19.3.4.
 
8 members found this post helpful.
Old 02-14-2020, 04:59 PM   #11
tramtrist
Member
 
Registered: Jul 2018
Location: Cincinnati USA
Distribution: Slackware
Posts: 208

Rep: Reputation: 136Reputation: 136
Thank you Pat
 
1 members found this post helpful.
Old 02-15-2020, 02:12 AM   #12
linuxxer
Member
 
Registered: Apr 2011
Location: I have my own planet
Distribution: SlackwareŽ
Posts: 186

Rep: Reputation: Disabled
Quote:
Originally Posted by volkerdi View Post
I have verified that reverting this patch fixes mesa 19.3.4.
Thank you Pat this update solve my issue.
 
2 members found this post helpful.
Old 02-15-2020, 02:33 AM   #13
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,714

Rep: Reputation: 674Reputation: 674Reputation: 674Reputation: 674Reputation: 674Reputation: 674
Thank, Pat, solved here also.
 
1 members found this post helpful.
Old 02-15-2020, 04:13 AM   #14
LuckyCyborg
Member
 
Registered: Mar 2010
Posts: 488

Original Poster
Rep: Reputation: 316Reputation: 316Reputation: 316Reputation: 316
Yes, Mr. Volkerding found the culprit and the patched package works perfectly here. Thank you!
 
1 members found this post helpful.
Old 02-15-2020, 05:51 AM   #15
ZhaoLin1457
Member
 
Registered: Jan 2018
Posts: 405

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Solved also here, thanks!
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
The October Plasma5 prefers {systemd-,e}logind against ConsoleKit2, so SBo's skypeforlinux will broke the shutdown/reboot feature of Plasma5 LuckyCyborg Slackware 19 10-21-2019 10:49 AM
Plasma5: how the heck to tell to KWin that NO, IT DOESN'T CRASHED but there should be loaded around 2000 files and hundreds of web pages? Darth Vader Slackware 4 04-24-2018 06:02 AM
[SOLVED] Plasma5 - SDDM black screen after kernel/mesa/xorg update michelino Slackware 2 04-26-2016 10:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration