LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-18-2007, 07:29 PM   #1
blackbeard99
LQ Newbie
 
Registered: Nov 2007
Posts: 10

Rep: Reputation: 0
media:/ gives permission denied


When trying to access root ("/" - hda9) partition from konqueror's
media:/ folder, it gives
Permission Denied. All other partitions are accessible (/home - hda10,
/boot - hda Cool. Also hda9 icon shows that it is unmounted, but
according to mtab it is mounted:
/dev/hda9 / ext3 rw 0 0

piece of /etc/fstab:
/dev/hda9 / ext3 defaults 0 1
/dev/hda10 /home ext3 defaults 0 1
/dev/hda8 /boot ext2 defaults 0 1
it is slackware 12 thanks for any help
 
Old 12-18-2007, 07:33 PM   #2
Furlinastis
Member
 
Registered: Dec 2004
Location: Ball of Confusion
Distribution: Slackware,Bluewhite64
Posts: 252

Rep: Reputation: 30
Try adding your user name to the proper groups. /etc/group

BTW, isn't there a sticky regarding this?
 
Old 12-18-2007, 07:57 PM   #3
blackbeard99
LQ Newbie
 
Registered: Nov 2007
Posts: 10

Original Poster
Rep: Reputation: 0
i am logged in as root and i already added root to all the groups
but yes thier is a sticky i did a searches but missed the the stick me being stupid have some reading to do

Last edited by blackbeard99; 12-18-2007 at 08:00 PM.
 
Old 12-19-2007, 01:53 AM   #4
blackbeard99
LQ Newbie
 
Registered: Nov 2007
Posts: 10

Original Poster
Rep: Reputation: 0
what am i missing
root::0:
bin::1:root,bin,daemon
daemon::2:root,bin,daemon
sys::3:root,bin,adm
adm::4:root,adm,daemon
tty::5:root
disk::6:root,adm
lp::7:lp,root
mem::8:root
kmem::9:root
wheel::10:root
floppy::11:root
mail::12:mail,root
news::13:news,root
uucp::14:uucp,root
man::15:root
audio::17:root
video::18:root
cdrom::19:root
games::20:root
slocate::21:root
utmp::22:root
smmsp::25:smmsp,root
mysql::27:root
rpc::32:root
sshd::33:sshd,root
gdm::42:root
shadow::43:root
ftp::50:root
apache:x:80:root
messagebus:x:81:root
haldaemon:x:82:root
plugdev:x:83:root
power:x:84:root
pop::90op,root
scanner::93:root
nobody::98:nobody,root
nogroup::99:root
users::100:root
console::101:root
 
Old 12-19-2007, 02:58 AM   #5
pappy_mcfae
Member
 
Registered: Feb 2007
Location: Dallas
Distribution: Gentoo x86 & x86_64
Posts: 190

Rep: Reputation: 30
Post

Quote:
Originally Posted by blackbeard99 View Post
what am i missing
First of all, you are not missing anything, at least as far as your /etc/group file goes. As a matter of fact, you have your user name (root) in too many places. In order for the your optical drive (ie CD or DVD ROM) to work, you have to have your user name (root in your case) added only to cdrom and plugdev groups. Everything else that has your user name that didn't have when you began to edit this file is unnecessary. Cut and paste the code below into your /etc/group file. The code is from my /etc/group on my laptop; a machine that is successfully running Slackware 12. I am currently using said machine to post this message.
Code:
root::0:root
bin::1:root,bin,daemon
daemon::2:root,bin,daemon
sys::3:root,bin,adm
adm::4:root,adm,daemon
tty::5:
disk::6:root,adm
lp::7:lp
mem::8:
kmem::9:
wheel::10:root
floppy::11:root
mail::12:mail
news::13:news
uucp::14:uucp
man::15:
audio::17:
video::18:
cdrom::19:root
games::20:
slocate::21:
utmp::22:
smmsp::25:smmsp
mysql::27:
rpc::32:
sshd::33:sshd
gdm::42:
shadow::43:
ftp::50:
apache:x:80:
messagebus:x:81:
haldaemon:x:82:
plugdev:x:83:root
power:x:84:
pop::90:pop
scanner::93:
nobody::98:nobody
nogroup::99:
users::100:
console::101:
I only added my user name (root) to plugdev and cdrom groups. All other occurrences of the root user were there when the file was installed.

By the way, be prepared for a lot of people to give you a lot of crap about being a root user. It seems to be a favorite pastime for certain people here. I get it a lot. I usually ignore it!

The problem you are having has nothing to do with having your user name plastered all over /etc/group. Your problem is due to a missing initrd, and/or not using an smp (symmetric multi-processing support) enabled kernel. Read the file /boot/README.initrd to find out how to set up initrd. As far as using an smp kernel, either use the one that shipped with Slack 12, or compile one of your own.

If you are using the smp kernel that shipped with Slackware 12, then you are pretty much set to go. Simply follow the instructions in /boot/README.initrd to create your initrd.

If you are using a custom compiled kernel, things get a bit more interesting. I have a how-to on this issue posted on my web site. Follow this link, click on The Linux Project link at the top of the page, and go about halfway down the page to the article entitled SLACK-12 and hal. The cure for your problem exists there.

Hope that helps.

Blessed be!
Pappy
 
Old 12-22-2007, 01:09 AM   #6
blackbeard99
LQ Newbie
 
Registered: Nov 2007
Posts: 10

Original Poster
Rep: Reputation: 0
thank you very much for your help very much appreicated
 
Old 12-23-2007, 03:58 AM   #7
pappy_mcfae
Member
 
Registered: Feb 2007
Location: Dallas
Distribution: Gentoo x86 & x86_64
Posts: 190

Rep: Reputation: 30
Cool

Quote:
Originally Posted by blackbeard99 View Post
thank you very much for your help very much appreicated
You are most welcome. Happy solstice to one and all!

Blessed be!
Pappy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 04:50 AM
Permission denied in mount /media/cdrecorder from non-root account... sean04 Linux - Newbie 2 12-10-2007 12:57 PM
'permission denied" inspite of right permission flags on network drive anirudhvij Linux - Enterprise 8 05-22-2007 05:57 AM
permission denied :( wogga Linux - Software 2 05-28-2004 12:52 PM
ls/cp ... : permission denied Roadrunner Linux - Newbie 5 09-09-2003 06:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration