LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-21-2004, 03:58 PM   #1
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Rep: Reputation: 15
Making a FAT32 FS


I was wondering how I can make a FAT32 filesystem under slackware for my external hdd. Using fdisk, I changed the partition to "win95 fat32." There's also a "win95 fat32 (lba);" what are the differences between these two? My ext hdd was labeled ntfs prior to the change. When I go to make the fat32 fs, it doesn't work.

The command I use is "mkfs -t fat32 /dev/sda." But the output I get is "mkfs.fat32: No such file or directory."
 
Old 08-21-2004, 04:39 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
the LBA thing is for extended partitions (so you
can have win read logical drives in an extended
partition). The tool to use for formatting it is
mkdosfs
man mkdosfs for details

It appears that your external HDD is not being
picked up as sda. Have a look at /proc/scsi/scsi.

You also don't want to format the raw-device but
a partition in it /dev/sd<a-z><1-9>


Cheers,
Tink
 
Old 08-21-2004, 04:46 PM   #3
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Thanks, it's working now.

Last edited by linuxnubx; 08-21-2004 at 04:53 PM.
 
Old 08-21-2004, 05:22 PM   #4
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Okay, maybe not all is working fine. It won't let me mount saying that "mount: fs type fat32 not supported by kernel." I made sure to check off support for msdos fs and vfat in my .config, but it still doesn't want to mount.
 
Old 08-21-2004, 06:44 PM   #5
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
I tried changing my fstab... It doesn't seem to work... When I type in mount /dev/sda1, it gives me the error

Code:
mount point /st3 does not exist
Here is the sda1 line from fstab:

Code:
/dev/sda1        /st3             vfat        defaults           1   0
 
Old 08-21-2004, 06:57 PM   #6
Mephisto
Member
 
Registered: Oct 2002
Location: Washington D.C, USA
Distribution: Slack 12, Etch, Gutsy
Posts: 453

Rep: Reputation: 31
Quote:
Originally posted by linuxnubx
Okay, maybe not all is working fine. It won't let me mount saying that "mount: fs type fat32 not supported by kernel." I made sure to check off support for msdos fs and vfat in my .config, but it still doesn't want to mount.
You checked it off but did you compile the kernel? If you compiled, did you include vfat as a module or build it in? If as a module is the module loaded? Sorry if the answers are obvious.
 
Old 08-21-2004, 07:12 PM   #7
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Yeah, they're built as modules; how do I check if they were loaded? Anyways, I think under fstab, it should be considered "fat32" in the first place, but "vfat" instead. So I changed it to vfat. Ok, one problem after another... I did mkdir /st3, then mount /dev/sda1, but get!!!

Code:
mount: special device /dev/sda1 does not exist
instead of

Code:
mount point /st3 does not exist
Seriously, as soon as I fix one problem, another one appears.
 
Old 08-21-2004, 07:22 PM   #8
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Ok, so I figured out that my sda1 partition somehow just dissappeared, AGAIN. So I had to remake it blah blah blah... Then I had to mkdosfs -F 32 /dev/sda1... But now, of course, I get a different problem...

Code:
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       or too many mounted file systems
 
Old 08-21-2004, 07:28 PM   #9
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Nice, I got it to work using ext2 fs; now it's time to try to get it working with fat32.
 
Old 08-21-2004, 09:27 PM   #10
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Wow, still no luck with the fat32.... Can someone tell me where I went wrong? Does this code below look good or is it off?

Code:
root@gHost:/home/jgo# mkdosfs -v -F 32 /dev/sda1
mkdosfs 2.10 (22 Sep 2003)
/dev/sda1 has 255 heads and 63 sectors per track,
logical sector size is 512,
using 0xf8 media descriptor, with 312576642 sectors;
file system has 2 32-bit FATs and 32 sectors per cluster.
FAT size is 76276 sectors, and provides 9763251 clusters.
Volume ID is 41280413, no volume label.
root@gHost:/home/jgo#
 
Old 08-21-2004, 10:07 PM   #11
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
That worked fine!

Oh yeah: modprobe vfat is what you're looking for.
 
Old 08-21-2004, 10:56 PM   #12
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Ok, I typed in modprobe vfat, and got fatal error. This was when vfat was not built as module, so I built it as a module, and now it doesn't give me anything. I just type in modprobe vfat, and it doesn't appear to do anything. What does modprobe do? Anyways, I checked on my Windows XP, and it doesn't detect the FAT32 either, so something has to be wrong. I still get the error

Code:
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       or too many mounted file systems
Whenever I try to mount /dev/sda1... What's up?
 
Old 08-21-2004, 11:06 PM   #13
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
Quote:
Originally posted by linuxnubx
Ok, I typed in modprobe vfat, and got fatal error. This was when vfat was not built as module, so I built it as a module, and now it doesn't give me anything.
A great number of Unix/Linux tools work like that
and only give you feed-back if something fails.

Quote:
I just type in modprobe vfat, and it doesn't appear to do anything. What does modprobe do?
Probes loading a module, and if successful, is
happy with that :)

Quote:
Anyways, I checked on my Windows XP, and it doesn't detect the FAT32 either, so something has to be wrong. I still get the error

Code:
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       or too many mounted file systems
Whenever I try to mount /dev/sda1... What's up?
What is the actual line you're using to mount, did
you make a fstab entry that differs from what you're
typing on the command-line?

What's the output of
mount
cat /etc/fstab
lsmod


Cheers,
Tink
 
Old 08-21-2004, 11:11 PM   #14
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
Well...if you have Windoze XP, just format the drive with that. It'll let you select FAT32.
 
Old 08-21-2004, 11:15 PM   #15
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Oops, my windows xp does detect the fat32, but only with firewire connection, not usb (strange)...

Okay so out put for mount:
Code:
/dev/hda7 on / type ext2 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
/dev/hda5 on /boot type ext2 (rw)
/dev/hda8 on /home type ext2 (rw)
/dev/hda1 on /xp type ntfs (ro)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
usbfs on /proc/bus/usb type usbfs (rw)
cat /etc/fstab:
Code:
/dev/hda6        swap             swap        defaults           0   0
/dev/hda7        /                ext2        defaults           1   1
/dev/hda5        /boot            ext2        defaults           1   2
/dev/hda8        /home            ext2        defaults           1   2
/dev/hda1        /xp              ntfs        ro                 1   0
/dev/sda1        /st3             vfat        noauto,user,ro     0   0
/dev/cdrom       /mnt/cdrom       iso9660     noauto,user,ro     0   0
devpts           /dev/pts         devpts      gid=5,mode=620     0   0
proc             /proc            proc        defaults           0   0
and lsmod:
Code:
Module                  Size  Used by
nls_cp437               5760  0
vfat                   12544  0
fat                    40224  1 vfat
snd_pcm_oss            48680  0
snd_mixer_oss          17408  3 snd_pcm_oss
ipv6                  245764  10
sbp2                   22024  1
intel_mch_agp           8208  1
uhci_hcd               29328  0
ehci_hcd               25732  0
snd_intel8x0           29576  3
snd_ac97_codec         64516  1 snd_intel8x0
snd_pcm                84228  2 snd_pcm_oss,snd_intel8x0
snd_timer              22148  1 snd_pcm
snd_page_alloc          9224  2 snd_intel8x0,snd_pcm
snd_mpu401_uart         6656  1 snd_intel8x0
snd_rawmidi            20772  1 snd_mpu401_uart
snd_seq_device          6792  1 snd_rawmidi
snd                    45156  11 snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               7776  3 snd
ohci1394               31876  0
ieee1394               93368  2 sbp2,ohci1394
ntfs                  131444  1
agpgart                28076  1 intel_mch_agp

Last edited by linuxnubx; 08-21-2004 at 11:19 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
making FAT32 partition reakinator Linux - Newbie 5 10-14-2005 08:51 PM
Having trouble making Fat32 Partition eggoz Linux - Hardware 1 09-18-2005 10:12 PM
making a fat32 partition tintilin Slackware 19 12-05-2004 12:45 PM
Making mounted FAT32 partition writable by all jrittvo Fedora 14 06-07-2004 02:39 AM
Making FAT32 partitions larger than 32GB's syzygy_eolith Linux - Newbie 5 04-23-2004 12:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration