-   Slackware (
-   -   make seems to be corrupt (

0zMe 01-30-2012 08:43 PM

make seems to be corrupt

today I tried to install some new software on my slackware 13.37.
i download recordmydesktop from slackbuilds and tried to install it as usually. normally I never get problems with slackbuilds but this time I got an error.

[code]./libotr.SlackBuild: line 80: /usr/bin/make: cannot execute binary file[/quote]

On line 80 there is only make.

I also tried to install anything else from slackbuilds or a software from source but always got the same error.
I'm logged in as root.

what could be the problem? is my make corrupt?

thanks in advance

Richard Cranium 01-30-2012 09:20 PM

Did you install the 64 bit version of make on a 32 bit system? How about the reverse?

What does "file /usr/bin/make" tell you?

0zMe 01-31-2012 12:21 PM

I'm using a 32-bit system.


sh-4.1$ file /usr/bin/make
/usr/bin/make: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), stripped

gnashley 01-31-2012 02:57 PM

32-bit system/ELF 64-bit doesn not compute. Warning, Will Smith...

ponce 01-31-2012 03:16 PM

I would try an

ls /var/log/packages/*x86_64*
to see what you have to substitute ;)

can it be you set a slackware64 mirror in /etc/slackpkg/mirrors?

0zMe 01-31-2012 04:32 PM


sh-4.1$ ls /var/log/packages/*x86_64*
in /etc/slackpkg/mirrors I have just selected a current mirror.

dive 01-31-2012 05:46 PM

Are you actually on -current or 13.37?

Don't select -current unless you're experienced.

dc_eros 01-31-2012 05:59 PM

I have experienced this last year while compiling some stuff. Helpful folks at the IRC pointed out that I could have updated from -current where a 64bit make was pushed and a several hours later was fixed by another update on current.

What I did was remove make and install it again via slackpkg using my mirror.

See ChangeLog on updates for make in 32 bit last November or so.

0zMe 01-31-2012 06:04 PM

yes I'm on 13.37 current.

By the way I could solve the problem. I removed make an installed it again from mirror

All times are GMT -5. The time now is 10:25 PM.