-   Slackware (
-   -   make -j doesn't work on Slack64 14.1 (

Linux.tar.gz 04-27-2014 03:34 AM

make -j doesn't work on Slack64 14.1

I'm on a Core i3 laptop.

I installed a bunch of SBo packages, and i'm now compiling a kernel.
I have 4 visible processors, but make -j8 still use only one at a time or 25% of each.

I don't know where to start to debug.

pan64 04-27-2014 05:15 AM

you can try to check it with htop for example. You should see several build commands running parallel. You also can try to use -j16 or -j1 to see if there were any differences.

Richard Cranium 04-27-2014 12:34 PM

What does "echo $MAKEFLAGS" output?

Linux.tar.gz 04-28-2014 12:27 PM

It outputs blank.

Tried to change it, nothing.
Also tried to increase the -j, nothing.

Linux.tar.gz 04-28-2014 12:45 PM

WTF !!! I realized i have the same problem on another machine !

I was able to compile a kernel yesterday with 4 cpu, today i can't (i'm using the same host kernel).

Richard Cranium 04-28-2014 04:46 PM


Originally Posted by Linux.tar.gz (Post 5160645)
It outputs blank.

OK, it's not overriding what you are attempting to use, so that's good.


Tried to change it, nothing.
What does that mean?

[/QUOTE]Also tried to increase the -j, nothing.[/QUOTE]

Well, here's a quick test: Grab the source for clisp and apply the patche that I mention here.

You'll want to not force "make -j1 blah" that I have in the last code block of the post. You can keep it at "-j7" or whatever.

If you run that slackbuild and it fails, then you can be pretty sure that you are running multiple compile jobs.

pan64 04-30-2014 10:38 AM

Just please tell me how do you know "make -j8 still use only one at a time"? Have you tried htop or top or something similar?

Linux.tar.gz 05-01-2014 02:45 AM

I look at both gkrellm and top.

All times are GMT -5. The time now is 11:51 PM.