-   Slackware (
-   -   make hsfconfig stay (

crkoa 11-19-2005 03:05 AM

make hsfconfig stay
Hello, I've figured out how to get my internal laptop modem (Conexant 56k ACLink) to work with Slackware 10.0. But when I shutdown and restart, the settings are gone. If I go through the whole "make install" and "hsfconfig" process again when I first bootup, it works fine. But if I don't, kppp can't find my modem. If I try to run kppp without going through the "make install" and "hsfconfig" process first, after kppp can't find the modem, then the process doesn't work and I get an error. Can someone tell me why the settings do not stay after shutdown and what I can do to make them stay? I'm using the driver from

One other piece of information that may be relevant is that I had to install with the "noieee1394" switch because my system would freeze when looking for those type of devices that aren't there during installation. Also, I've removed the hotplug option from lilo because that also caused the system to freeze on startup.


dracolich 11-19-2005 11:34 AM

Are you losing the actual modem device during shutdown? When you boot do you have /dev/ttySHSF0 ? And do you have /dev/modem linked to it? I found that I was losing the /dev/modem link during shutdown and all I was having to rerun hsfconfig to recreate it. A simpler solution I found is to add a line in /etc/rc.d/rc.local to create the link during startup.

crkoa 11-19-2005 06:22 PM

I'm fairly new to linux so I'm not sure if it's the link I'm losing or what. I just know that I have to rerun hsfconfig everytime I restart the system or kppp can't find the modem. Also, I'm pretty sure that my modem is on ttys1 (com2). So if I don't run hsfconfig, I can't get kppp to work by switching the device to ttys1 either (or any other for that matter). So I would think it's not just the link. But maybe I'm wrong, like I said, I'm a newbie.


All times are GMT -5. The time now is 02:28 AM.