LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 06-11-2006, 11:26 PM   #1
bleck
LQ Newbie
 
Registered: Jun 2006
Posts: 14

Rep: Reputation: 0
Madwifi, ath0 not there.


Alright, so I installed 10.2, downloaded 2.6.16.20, compiled with hotplug and all the necessary components to compile madwifi. Got madwifi, made the package following the instructions from the wiki (also tried just compiling then with make and make install). Problem is, it installed, and it loads the ath_pci at boot, but there is no ath0. Hotplug is working fine, lspci shows the Atheros AR5212 card. Just ath0 doesn't exist. I run the whole wlanconfig line, but it says that the device doesn't exist. Any ideas?
 
Old 06-12-2006, 12:08 AM   #2
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
I use the same distribution, kernel, driver, and wireless chipset, yet I have never had this problem.

What is the relevant dmesg output from (as root):
Code:
modprobe -r ath_pci
modprobe ath_pci
Both ifconfig and iwconfig show no mention of ath0?

Do you receive an error when you run (as root):
Code:
ifconfig ath0 up
 
Old 06-12-2006, 12:51 AM   #3
bleck
LQ Newbie
 
Registered: Jun 2006
Posts: 14

Original Poster
Rep: Reputation: 0
modprobe -r ath_pci simply loads the modules. lsmod shows all the correct modules as loaded. ifconfig ath0 up says "ath0 : unknown interface: No such device". I think this is related to acpi. With a slax live cd, if I load acpi=off, i get the same problem. when its on, ath0 shows fine and works fine, but the problem is if I try to load into KDE (after KDM) acpi turns off the backlight. So with that problem, last time i recompiled the kernel I disabled ACPI. Is there a way to fix this in KDE loading? Make it so that it will not turn off my backlight. It does it in both the Live CD and slackware. So i want to enable acpi in the kernel, but still be able to use KDE. Any suggestions?
 
Old 06-12-2006, 01:04 AM   #4
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Please post the result of
Code:
ifconfig
iwconfig
Not 'ifconfig ath0 up' or 'iwconfig ath0 up', just 'ifconfig' and 'iwconfig'.

Lets take care of that, we'll tackle ACPI issues in a bit.

Last edited by cwwilson721; 06-12-2006 at 01:06 AM.
 
Old 06-12-2006, 01:09 AM   #5
bleck
LQ Newbie
 
Registered: Jun 2006
Posts: 14

Original Poster
Rep: Reputation: 0
iwconfig shows etho and lo, and "no wireless extensions" im going to recompile the kernel here, with acpi support, load into flux and see if the ath0 is seen then. Like I said, when i disable acpi on the live cd, ath0 is fine. When i have it load with acpi enabled, ath0 isn't there either. Odd thing was the acpi thing started right after I compiled the kernel with acpi support. Possibly a bug with my chipset or something, with that kernel. Was going to try another kernel and see if that works, im not horribly set on 100% bleeding edge. But I am going to try to compile the kernel with ACPI support, and then not load into KDE and see if it loads just like the LiveCD. I usually use gnome, but I like switching every once in a while, showing my friends what linux is all about and all. At least then I won't have to boot to this live CD when I want to check the forums again
 
Old 06-12-2006, 01:11 AM   #6
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Again, please post the results of
Code:
ifconfig
iwconfig
And of
Code:
lsmod
 
Old 06-12-2006, 01:22 AM   #7
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Quote:
Originally Posted by bleck
modprobe -r ath_pci simply loads the modules.
modprobe -r ath_pci removes the ath_pci module. modprobe ath_pci loads it again.

I was interested in any error messages that may show up in dmesg.
 
Old 06-12-2006, 01:36 AM   #8
bleck
LQ Newbie
 
Registered: Jun 2006
Posts: 14

Original Poster
Rep: Reputation: 0
No error messages. Sorry about that, i meant it unloads and loads fine, no error messages at all. It ended the acpi thing. Maybe some kind of incompatibility with ACPI and it activating the card properly. I recompiled the kernel with acpi support, and now ath0 shows fine, and im connected. All is good there. Problem now is KDE turning off my backlight when I log in. Fluxbox works fine (im assuming it doesn't have the acpi function of turning off the backlight) and it seems the other light window managers does it too. Haven't tried gnome. Any ideas on how to get that to stop turning off the backlight?

Last edited by bleck; 06-12-2006 at 01:40 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Madwifi-old + Aircrack/Trouble compiling madwifi Ashex Linux - Software 7 04-05-2006 11:39 PM
Madwifi-old + Aircrack/Trouble compiling madwifi Ashex Linux - Software 0 03-05-2006 06:55 PM
"dhcpd ath0" Problem with madwifi andydicktwin Linux - Networking 4 06-26-2005 04:29 PM
Debian Sarge + madwifi : cannot bring up interface ath0 Pingus Debian 1 06-01-2005 04:48 AM


All times are GMT -5. The time now is 05:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration