LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-22-2016, 12:38 AM   #1
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: CentOS, OpenSUSE
Posts: 3,444

Rep: Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124
LXDM login manager: restart X on logout?


Hi,

I'm using the LXDM login manager on all my Slackware desktops, and I have a small but nagging problem with it.

Login managers shipping with Slackware restart X upon logout, which has a positive side effect: on the login screen, the system reverts to the default X keyboard layout defined in /etc/X11/xorg.conf.d/90-keyboard-layout.conf, for example:

Code:
Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "ch"
        Option "XkbVariant" "fr"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
Now on systems with many users - like in our local school or the public library - some folks define a custom keyboard layout different from the default layout. In Xfce you can define that (like in KDE or GNOME), and under the hood, there's some command like 'setxkbmap -layout ch -variant de' or 'setxkbmap -layout fr' running.

Now here's the problem. When one of those users logs out, the login screen keeps the last defined custom layout, which will eventually become a problem for the subsequent user typing in his login/password.

And here's the question. How can I get LXDM to behave like XDM or KDM, e. g. respawn so the keyboard gets back to its default layout?

Cheers,

Niki
 
Old 05-22-2016, 02:06 PM   #2
heyjann
Member
 
Registered: Dec 2015
Posts: 102

Rep: Reputation: Disabled
Just double-checking, you have uncommented reset = 1 in the [server] section of /etc/lxdm/lxdm.conf already?
 
1 members found this post helpful.
Old 05-23-2016, 03:15 PM   #3
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: CentOS, OpenSUSE
Posts: 3,444

Original Poster
Rep: Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124Reputation: 2124
Quote:
Originally Posted by heyjann View Post
Just double-checking, you have uncommented reset = 1 in the [server] section of /etc/lxdm/lxdm.conf already?
You're a star. I just discovered that option.

Thanks very much.

Niki
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] LXDM installed but no /usr/bin/lxdm G-Known Slackware 2 12-16-2015 08:20 AM
[SOLVED] Setting LXDM as default display manager for Ubuntu 15.04 batabuntu Linux - Newbie 19 08-03-2015 07:47 AM
how to logout xdm graphical login manager? raleeha Slackware 1 09-18-2011 02:42 AM
LXDM just restart when I login (Arch Linux) MFserver Linux - Software 1 08-19-2011 03:37 PM
Problem: Default Login Manager &Logout Dialog Ray2047 Debian 6 12-24-2005 07:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration