-   Slackware (
-   -   lsusb shows no wireless adapter (

waddles 11-23-2012 03:49 PM

lsusb shows no wireless adapter
Running Slackware 13.37, with a Belkin F5D5070 plugged into a NEC Corp. HighSpeed Hub.
lsusb shows the hub but not the adapter.
/port/net/wireless is empty save for the header.
iwconfig shows:
lo no wireless extensions.
eth0 no wireless extensions.
ppp0 no wireless extensions.
This adapter worked OK under XP but now using with Linux it is apparently unrecognized.
I am out of ideas would someone please suggest a next step?
BTW the hub and adapter's lights are on.

frankbell 11-23-2012 08:40 PM

I found a webpage on that specific device. I have no way to test it, but here's the link:

Hope it helps.

waddles 11-29-2012 02:27 AM

lsusb shows no wireless adapter
Thanks and yes it did. Were it not for this I would have been misinformed that the F5D7050 (note the typeo) didn't work. Now I need to find the CD that came with it which I always do but my library seems to have expanded making me feel a bit like Alice in wonderland. Is there any other way to determine the chipset embedded? Thanks again big.

allend 11-29-2012 10:14 AM

Apparently your device has a number of different versions.

The output from 'lsusb' should also give you some hints.e.g.

waddles 11-29-2012 05:32 PM

Was able to determine from the FCC ID that the version is ver. 4.x. That then identified the chipset as zd1211 and AL2230. I have learnee that zd1211rw is a community effort to rewrite ZyDAS's ZD1211 driver. zd1211rw has been included in the kernel since Linux 2.6.18.
I am running 2.6.37. Here is what I get when running
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I would think that if the adapter light is on that it would be recognized by the system and since the driver is already in the kernel there would be no reason for it not to be working. Confused!

allend 11-29-2012 06:27 PM

Your device is supported by the zd1211rw kernel module. Checking the information here in the source for Slackware 13.37 shows that the device should be supported.
Do you see 'zd1211rw' and the dependencies 'mac80211' and 'cfg80211' in the output of 'lsmod'?
Have you tried 'modprobe zd1211rw'?
Is there any indication that the device has been recognised as being plugged in the output of 'dmesg'?

waddles 11-30-2012 03:33 AM

did not have 'zd1211rw', 'mac80211', or 'cfg80211' in the output of lsmod until after executing modprobe zd1211rw.
Doing that got those three inserted plus rfkill.
After doing that checked dmesg and got:
usbcore: registered new interface driver zd1211rw
Still don't see anything different with lsusb command. Maybe I shouldn't?
BTW thanks for jogging my brain I couldn't recall lsmod for anything/price but wanted to look at the modules.
Ran iwconfig and only get lo and eth0 plus internet connection.

allend 11-30-2012 06:00 AM

Hmm - Nothing in dmesg.
Silly question -Is /etc/rc.d/rc.messagebus executable so that DBUS is enabled at boot?

waddles 12-01-2012 03:51 AM

lsusb shows no wireless adapter
Yes, rc.messagebus was/is set to 751.
I peeked at /proc/self/net/wireless and it seems empty:
Inter-| sta-| Quality | Discarded packets | Missed | WE
face | tus | link level noise | nwid crypt frag retry misc | beacon | 22
Is there an means to test if the system's USB is functional sans looking at the mboard to look for disconnects?

allend 12-01-2012 07:45 AM

I am out of ideas on the software side, so it may be time to consider a hardware issue.
Have you used other USB devices (e.g. memory stick, external hard drive, printer/scanner, camera) successfully?
Is there a BIOS setting that enables USB?
Have you tried different USB ports? (I had dealings with one box that had front USB ports that did not work, although the rear ports were OK. This was a motherboard problem in the particular model.)

waddles 12-02-2012 05:58 PM

lsusb shows no wireless adapter
Thanks just checked front ports they are OK.
I noted in rc.modules that after "loaded USB hub support most USB devices will trigger the kernel to load their modules automatically". Since that does not happen for the F5D7050 do U know if setting a script in rc.local would correct the issue of not having zd1211rw loaded be corrected? Asking as perhaps this could be counter productive.
Have loaded pictures (.avi) via usb port and in past have had web camera work (not now tho which is another issue).
That satisfies the BIOS.
Have tried front and back ports both same same.

allend 12-03-2012 07:42 AM

I came across this which may be relevant

What happens when you do:
'modprobe -r usbserial' (assuming that usbserial already appears in the output of 'lsmod')
followed by
'modprobe usbserial vendor=0x050d product=0x705c'
and then do
'lsusb' ?

waddles 12-04-2012 12:19 AM

lsusb shows no wireless adapter
Without thinking I did a modprobe usbserial before checking.
Then did: 'modprobe -r usbserial and modprobe usbserial vendor=0x050d product=0x705c'
A lsusb came back with no info as before. Note I had modprobed zd1211rc prior to this.
I went into /etc/rc.d and ran egrep -i usb and there are only 3 scripts that were found to contain "usb": rc.S, rc.M, rc.modules. Also did a similar search for serial, belkin, and f5e7050 with no results.
Then I looked at serial and noted that I do not have rc.serial executable. Could this be the problem? Could there be other modules that need to be loaded from rc.d?
BTW neither mtab nor fstab have usbfs. How do I determine if usbfs is functional or is that needed?
Found these 2 refs:
which are pointing at the fact I have not installed wicd. Could this be the solution?
Do I need to edit rc.inet1.conf?

allend 12-05-2012 08:41 AM

My apologies for the slow reply, but I have been AFK.

Not having rc.serial executable is not the problem. That only services RS232.

Before worrying about the GUI network manager, you still need the device to be recognised and the appropriate kernel modules loaded when your device is plugged.


NEC Corp. HighSpeed Hub.
From what I have seen, this should show in the output of lsusb with ID 0409:005a NEC Corp. HighSpeed Hub, yet it is not in the output of lsusb that you posted. Exactly what is this device?

waddles 12-05-2012 09:55 PM

I removed the hub so only looking at the Belkin F5D7050 wireless adapter.
The 2 articles referenced to I fast scanned of them and they seemed to suggest the adapter needed to be configured in rc.inet1.conf and possibly elsewhere. The elsewhere could be strictly if I were attempting to run a wireless network but not sure.
At this point setting up rc.inet1 seems imperative but don't know/tested if the modules need calling first and possibly in rc.modules but have yet to examine code there.
Tried to modprobe zd1211rw and unplug/replug the adapter thinking that might work to get recognition but didn't.
Later... I see that if I want to connect to an access point that I need to configure rc.wireless.conf. It is not clear to me from reading if the ESSID, encrypted keys, and WAP channel to be inserted into rc.wireless.conf are from my machine or from that advertised by the access point. I believe the latter since I understand I could do this with iwconfig.
Without the Belkin adapter having been seen tho, I doubt anything I put in rc.wireless.conf will matter.
This latter factor is really buffaloing me. I feel sure from my notes that I have employed this wireless adapter on Slackware before and I have seen that others have too on earlier versions of Slackware and Fedora.

All times are GMT -5. The time now is 06:41 PM.