LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-11-2008, 04:38 PM   #1
archiphile
LQ Newbie
 
Registered: Jul 2008
Location: Boston,MA,USA
Distribution: Slackware 12.1, Fedora 8, MS Widows XP Pro
Posts: 7

Rep: Reputation: 0
lsusb command not working Slackware 12.1


as the title state I am unable to envoke the *lsusb* command.

I am trying to diagnose why my wheel mouse is not working. Thought that I would take a look and see if SWL 12.1 could read my USB Busses and tell me a little about my mouse so that I can find the packages and drivers for it.

I have also edited the /etc/X11/xorg.conf file and I have not come up with anything that will allow my wheel on my mouse to scroll.

Output from above file

Code:
Section "InputDevice"

# Identifier and driver

   Identifier "Mouse1"
   Driver     "mouse"


#  Option     "Protocol"     "Logitech"
#  Option     "Buttons"      "5"
#  Option     "ZAxisMapping" "4 5"
If anyone would be so kind as to tell me what I have done wrong and assist me in making it right that would sure be great.


Best,
Archiphile
 
Old 07-11-2008, 05:23 PM   #2
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,623

Rep: Reputation: Disabled
You are probably trying to run lsusb as a non-root user? lsusb is in /sbin, which is not in the normal user's default path. So either su to root or run "/sbin/lsusb" or add /sbin to your default path.

Brian
 
Old 07-11-2008, 06:27 PM   #3
archiphile
LQ Newbie
 
Registered: Jul 2008
Location: Boston,MA,USA
Distribution: Slackware 12.1, Fedora 8, MS Widows XP Pro
Posts: 7

Original Poster
Rep: Reputation: 0
I just ran the command again, as root, as before, all that it did was go to a new line
this is the I/O

Code:
<username>@darkstar:~$ su
Password*******
root@darkstar:/home/<username>/~# /sbin/lsusb
root@darkstar:/home/<username>/~#
that is what the I/O looked like on my konsole.

As for the other problem I am still trying to sus it out. I can understand why that did not work.

I copied the input from LQ Wiki....

Any assistance would be greatly appreciated.

Best,

Archiphile
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
technique to know usb root hub by parsing lsusb -v command output in SLES10 2.6.16 ke deedhnd Linux - Server 0 05-02-2008 10:06 AM
suse 10.3: 'bash: lsusb: command not found...' sjclemmy Linux - Newbie 2 11-26-2007 07:08 AM
lsusb, is this command exist ? wahaha Linux - Software 3 03-10-2007 03:58 PM
PC hangs on lsusb command Adrian Baker Linux - General 0 07-07-2005 10:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration