-   Slackware (
-   -   lsmod reports no modules (

props666999 05-30-2005 06:09 PM

lsmod reports no modules
I have moved to the kernel

but after the login prompt when i type lsmod the shell reports no modules

i think i did something wrong

Im on slackware 10.1 and downloaded the kernel and unziped it .

then make mrproper , make menuconfig , make bzImage, cp bzImage, and .config to the /boot directory , make modules , make modules_install then created some symlinks

ln -s /boot/
ln -s /boot/config
ln -s /boot/vmlinux

for the modules to be properly installed do i need to make something
apart from make modules and make modules_install


odious1 05-30-2005 06:15 PM

did you compile anything as a module? is your new kernel atually booted, did you run lilo after compiling?


props666999 05-30-2005 06:41 PM

Yes i have compiled my nic card (sis900 module)
radeon etc..

Yes im on the new kernel , it works fine with no error messages

yes i ran lilo

gbonvehi 05-30-2005 08:44 PM

Is /etc/rc.d/rc.hotplug executable?

franznietzsche 05-30-2005 09:06 PM

Is there anything in rc.modules that is supposed to load?

Its perfectly possible to run a system with no loaded modules. If you meant to have modules, you have to tell it to load them. I wouldn't use rc.hotplug, takes too long. I would edit rc.modules to include all the modules you want to load.

props666999 05-31-2005 03:31 AM

gbonvehi the hotplug runs everytime at the begining . I did it from the pkgtool

I uncheck some modules that i need but without any success

the modules cannot be inserted

keefaz 05-31-2005 03:43 AM

Any error output ? What happen when you try to modprobe sis900 ?
What do dmesg and /var/log/syslog say ?

Also do you see your module when you do :
modprobe -l | grep sis900

props666999 05-31-2005 03:56 AM

keefaz i ve tried modprobe -l | grep radeon as you suggested

and it works - reports that radeonfb and radeon modules
found and inserted

but lsmod reports nothing strange

keefaz 05-31-2005 04:00 AM

modprobe -l does not show the inserted modules,
it shows the modules that are available

Also, you say that "lsmod reports nothing strange"...
What do you mean ? It lists your modules ?

props666999 05-31-2005 04:02 AM

sorry i mean lsmod reports nothing it is empty which is strange

thank you

keefaz 05-31-2005 04:10 AM

What happen when you attempt to do :
modprobe radeon

props666999 05-31-2005 04:14 AM

well i did modprobe and the radeon module appears on lsmod

thats a step forword , but under Used by it just a - usually i think
it is 1 or 0 . I mean when you lsmod a Module , Size and Used by
columns appears

thanks again

keefaz 05-31-2005 04:55 AM

Could you look at the output of dmesg command
and tail /var/log/syslog when you rmmod and
modprobe radeon module ?

props666999 05-31-2005 05:29 AM

when i compiled the new 2.6 kernel i didn't tick the
unloading module capabililty , so i cannot rmmod modules

dmesg reports
FATAL : Module ide_scsi not found
FATAL : agpgart not found
FATAL : Module emu10k1 not found

keefaz 05-31-2005 05:54 AM

I would recompile the kernel with unloading modules feature
and agpgart as module (it is better to compile it as module)
Also try compile emu10k1 as module too, to keep alsa
happy if you want

All times are GMT -5. The time now is 02:00 PM.