-   Slackware (
-   -   Lost UEFI boot entry. (

Richy_T 02-07-2014 12:37 PM

Lost UEFI boot entry.
So I managed to get 14.1 installed on a UEFI box using LVM. So far so good. Not had a lot of time to get to it so the other day, I uninstalled sendmail, powered off and unplugged the SATA drive.

Today I tried to boot but forgot to plug in the drive. No biggie. Power off, replug and boot, right? But I start getting errors about rebooting and selecting proper boot device.

Investigation reveals that the drive is good, partitions appear to be good. Eventually I conclude that apparently the bios is supposed to keep boot entries and apparently mine has become lost.

From what I have read so far, efibootmgr can install one. But that is not anywhere I can see when I boot from the DVD. Does Slackware use something else or do I have to mount my partitions? Apparently some bioses, this can be done with a bcfg command but my uefi shell does not have this command.

I guess another important question is whether this can be prevented from happening again? It seems dumb to throw away config information simply because a drive was unplugged. This was a FM2-A55M-E33 motherboard if that helps.

I'll be updating this thread as I work out what's going on but helpful information provided would be much appreciated.

Richy_T 02-07-2014 12:56 PM

Hmm. Tried using efibootmgr from a mounted partition and no go. It looks like efibootmgr can only be used from a UEFI boot which booting from the DVD is not. So how does Slackware do it?

metaschima 02-07-2014 01:43 PM

I have a gigabyte board that does this kind of stuff, which is annoying. Here's what I did to prevent such issues. There is a default boot location at '/EFI/boot/bootx64.efi' (/boot/efi/EFI/boot/bootx64.efi). Slackware installs elilo.efi to '/EFI/Slackware/elilo.efi' (/boot/efi/EFI/Slackware/elilo.efi). So you could just copy or move the 'Slackware' directory to 'boot' and rename 'elilo.efi' to 'bootx64.efi' and it should be able to boot without any registered boot options.

Also see:

Richy_T 02-07-2014 01:48 PM

So eventually I have found my way to /mnt/usr/sbin/eliloconfig which apparently *does* use efibootmgr. So the question becomes, how to use that from a boot without getting that modprobe message. ???

At this stage, I have done a full reinstall but I will not feel safe moving forward unless I know for sure I can reinsert this UEFI entry.

I am thinking this option might be depending on whether the USB CD drive is started in UEFI or legacy mode. I will have to play with things.

Richy_T 02-08-2014 08:04 PM

Also thinking that when the Slackware installer suggested skipping LILO, I should have gone ahead and installed it anyway as the motherboard supports both UEFI and legacy booting.

All times are GMT -5. The time now is 02:26 AM.