-   Slackware (
-   -   Losing Wireless Connection After Logout/Sleep (

RJwen 09-03-2012 11:17 PM

Losing Wireless Connection After Logout/Sleep
Hi Slackers,

Wicd always lose connection after logout/wake up from sleep.

So I thought this is the wicd problem, then I uninstalled wicd, and configure /etc/rc.d/rc.inet1.conf and /etc/wpa_supplicant.conf according to the awesome guide from:

It is working just fine, but then again it loses the wireless connection when I re-login after Logout/Sleep.

I try to restart rc.inet1 and here is the result:
Polling for DHCP server on interface wlan0:
dhcpcd[3367]: version 5.2.11 starting
dhcpcd[3367]: wlan0: waiting for carrier
dhcpcd[3367]: timed out
dhcpcd[3367]: allowing 8 seconds for IPv4LL timeout
dhcpcd[3367]: timed out

Then I run bash-4.1# wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf , and here is the result:
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

After fiddling with rc.inet1.conf again and again, I still can't make it work, I have to do shutdown -r now to bring back the wireless connection and internet to live.

Moreover, even on LQ, there is only one relevant Thread when I clicked "click here to Find Similar Threads" button on the tread creating page, which I don't think it is solved yet.

Any Linux Gurus out there has any idea what have happened? or Eric himself perhaps ? :D

Thanks and cheers...

RJ :)

dr.s 09-04-2012 12:01 AM

Sorry not a Linux guru, but on my laptop Wicd recovers within seconds of waking up from either suspend or hibernate. When you selected your wifi network, did you turn on the option to "Automatically connect to this network"?

RJwen 09-04-2012 12:17 AM

Of course I do "Automatically connect to this network"

Using Wicd, short after re-login from Logout/sleep, it works for a little while then it loses connection (but If I hover it to the wicd icon try, it still says "connected to.... "

And now even I uninstall wicd, and configure rc.inet1.conf and wpa_supplicant.conf, the same phenomenon happens. It seems now it is not wicd problem, and I don't think I config rc.inet1.conf and wpa_supplicant.conf wrongly (else it will refuse to connect to internet at start-up)

However, let me just paste my relevant portion of rc.inet1.conf and wpa_supplicant.conf here.
From rc.inet1.conf:
# Default gateway IP address:

WLAN_RATE[4]="54M auto"

From wpa_supplicant.conf:
# WPA protected network, supply your own ESSID and WPAPSK here:
proto=WPA RSN
pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40

RJwen 09-04-2012 10:41 AM

Or does anyone know where Slackware store the Sleep (Suspend to RAM) config file?
I don't seem to find it.

/etc/pm/sleep.d , /etc/pm/power.d , /etc/pm/config.d are all empty directory,
if nothing is wrong with the rc.inet1.conf and wpa_supplicant.conf then the problem might resides in the sleep config file.

This really bugs me as so little information about this even on google and LQ.

Oh yeah, to make things precise, I'm still connected to the internet after re-login from logout, but not re-login after Sleep/Suspend to RAM

Hopefully someone could enlighten me on this one.

Cheers... :)


turtleli 09-04-2012 11:57 AM

What wireless card are you using? Perhaps the wireless driver does not like suspend/resume?

After resuming, try unloading and reloading your wireless driver if it is a module and see whether you can get a wireless connection.

RJwen 09-04-2012 08:32 PM

Hi Turtleli

My wireless card is
Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

My wireless driver is (using the one from

Do you suspect any problem with this ?



RJwen 09-04-2012 09:14 PM

And btw, I just tried Hibernation (Suspend to Disk), it seems my system takes it as Shutdown, LOL. (Although I can just press spacebar to start-up the computer, but it indeed running up the whole start-up process).

Now this whole Sleep/Hibernate thing starting to get very annoying...... haha.

turtleli 09-05-2012 04:03 PM

Sleep/hibernate - I don't know much about it so I cannot help you there.

Wireless - There are reports of the b43 driver not working after waking from suspend. You can test whether it affects you. After resuming, if you cannot connect, use (I am assuming you are using one of the default Slackware kernels):

modprobe -r b43
modprobe b43

Then try and connect as you normally do. If it connects then the problem is most likely the b43 driver not working well with suspend.

RJwen 09-09-2012 05:15 AM

Hi Turtleli,

Currently I'm in Tibet now, can't really try it with my wireless.

I'll try it out as soon as I get back home.

Cheers... :)


guanx 09-09-2012 05:50 AM


Originally Posted by RJwen (Post 4772401)
Or does anyone know where Slackware store the Sleep (Suspend to RAM) config file?
I don't seem to find it.

Suspend to disk data in swap partition, resume will be automatic or you can specify resume= as a kernel parameter. You'd better open a new thread since this is not related to the WiFi driver.

BTW, The two checkboxes in wicd: "Connect automatically" and "Never connect to this network" have exactly the same string in their Chinese translation. Not sure if this affects you.

RJwen 10-20-2012 11:12 PM

Now after upgrading to 14, this issue is magically automatically fixed.

Not sure what is happening behind though. haha.

All times are GMT -5. The time now is 01:48 AM.