-   Slackware (
-   -   Long installation doesn't seem right... (

squeaks_27 01-25-2003 11:37 AM

Long installation doesn't seem right...
I tried installing slackware 8.1 last night and things went pretty well. I chose the full install (2GB) and thought that it would take under an hour to install all the packages. It wasn't done so i left it on over night (total of 12 hours) and when i woke up, it's still not finished!!

This just doesn't seem right. Does anybody know how long it usually takes? I think it might be due to a slow computer but mine is faster than what it's the basic requirements. Oh, one more thing, for periods of time, there's no light on my cd rom, maybe that helps.

P2 333
64 megs ram

I'm new to this linux stuff but have used redhat 7.2 and 8.0 at home and some at school.

Thanks in advance.
P.S. This is a great place to find help, so far i've had no need to post cause i've been able to find all the answers! Keep up the good work!

LSD 01-25-2003 12:28 PM

12 hours? Even for the full install it shouldn't take that long...

I have a 128Mb P2 495 (Overclocked from 400...) and it never takes more than about an hour to install Slack. Admittedly, thats with a considerably less than full install but even when I installed the stuff like KDE, GNOME and XFree86 it never took 12 hours to finish, thats just ridiculous.

squeaks_27 01-25-2003 12:52 PM

that's what i thought
i guess i'll just pull the pull the plug and try again, maybe use a different computer.


Astro 01-25-2003 02:26 PM

Something about this kind of problem was posted before, not sure where though, when I find out I'll add the thread here

squeaks_27 01-25-2003 04:28 PM


don't worry about it. I switched everything computers. It wasn't detecting anything but things seem to be working now, I was able to boot into one of my os on a hard drive.

I'll try again tonight, but i think all will go well.

Thanks again

Astro 01-25-2003 05:13 PM thats the thread if you wanna take a lok, not too much there, but just FYI

squeaks_27 01-26-2003 11:14 AM

I tried again this morning and you're right, it takes about a half hour to install. I made my newer cd the master to boot from and it was almost instantaneous.

Few questions to complete my up and running system.

1. I installed everything and it boots up into enlightment, i thought i'd try it out, but i don't like it, how do i make it boot into kde by default?

2. What i want to try is actually fluxbox, seeing my system is older, how would i go about doing that? same deal as above, being able to switch different ones.

3. i have cable internet, and i went through the install the first time around, and when it asked me about the modem, i answered pci 4, since that's where it's at, but when i went back to fix that with the install cd, i saw that there was a 'network' option to probe for my card, it found it. NOW, how to i switch it?

4. it's probably around, i used grub and can configure that, but i how to i add a timer to lilo to give me time to select an o/s cause right now it's almost instant.

Thank you all very much

Excalibur 01-26-2003 12:10 PM

1. I think "xwmconfig" is the command you are looking for. It should present the same menu from the installation.

2. I am not sure here, but I think fluxbox has to be downloaded. Suggest doing a search here on LQ for fluxbox.

3. The modem symlink and networking are not the same. Cable isntalls that I have configured have been ethernet based. After installing the driver for for you ethernet adapter, run "dhcpcd eth0", or use the ethernet adapter that is connected to the cable service. Most of them I think just use dynamic assignment and respond dhcp requests.

4. In the /etc/lilo.conf add or modify the line "delay=50", the number is in tenths of a seconds if I recall correctly. A value of 50 would be 5 seconds. After making the modification, you must run the "lilo" command to update the boot record.

squeaks_27 01-26-2003 12:28 PM

I'll try that out later on today, thanks for the quick and to the point reply

LSD 01-26-2003 12:31 PM

There are a couple of ways to change the default WM/Desktop depending on whether you just want to change it on a per-user basis or want to make your choice the system-wide default.

In the former case, you have to create or modify a file called .xinitrc in your home directory and add the command startkde to the end, removing any commands for other WMs as you go. The latter case is a little more involved. The system default WM is also controlled by an xinitrc file but it lives in the directory /etc/X11/xinitrc. To allow choice between the various WMs, Slackware maintain individual scripts for them and just create a symlink called xinitrc which points to the chosen default. These scripts are named in the format xinitrc.<WM name> and there should be one for kde, called xinitrc.kde. If Enlightenment isn't started from a local xinitrc file, the xinitrc symlink should be pointed at an xinitrc script here that automatically starts it. Remove the symlink and recreate it but this time pointing it toward the xinitrc.kde script. rm xinitrc && ln -s xinitrc.kde xinitrc should do the trick. Now, in both cases all that should be required now is a restart of X and KDE should start automatically.

As for fluxbox, if its already installed then use a procedure similar to the above (substituting exec fluxbox for startkde in the local procedure and xinintrc.fluxbox for xinitrc.kde in the system wide) to start it but if it isn't either find a slackpack or download the source (compiling it with the customary ./configure && make && make install commands) and once installed, configure your system to start it as mentioned above (If compiling from source, you'll have to create an xinitrc.fluxbox script to make it available as a system wide option. That isn't difficult, just create the file in a text editor, type the command exec fluxbox into it and save it. If you install using a Slackpack then it should be created for you).

As for question 4, you can change the LILO delay but opening /etc/lilo.conf in a text editor and adding a timeout line to it alng with the number of seconds you want it to wait for multiplied by 10. For example, my timeout line says this:


timeout = 1200
which sets up a 2 minute countdown. Once you've added/edited it, save the file and exit the text editor and issue the command lilo to apply the changes.

squeaks_27 01-26-2003 05:17 PM


i tried xwmconfig and that worked great, i have tried all of the windows managers and all's good in that department. is there a way to boot straight into gui? bypassing going into CUI and startx?

i ran that "dhcpcd eth0" and it did nothing but execute?? and bring me back to enter my next command. I don't think it worked cause the interenet still doesn't work!

lilo: i entered delay=300 (30 secs) and for some reason it shows the text "LILO 22.2 ." at the bottom of the screen for 30 secs but i have no menu to select xp and it defaults to slackware after 30 secs. I take it the default o/s is whichever comes first?


i checked out the dir /etc/X11/xinitrc and all the files were there (eg. xinitrc.kde and so forth). I opened up the file .xinitrc in my home dir and at the bottom it had startkde, or xcfe, depending on what i had changed the WM to in xwmconfig. So i guess it does it automatically for me, which is nice.

about this installing from source, i've had some success in the pass with the tar.gz files. after i "tar -zxvf" a file, it makes a dir which i go into and then ./configure && make && make install, my question is that where does this go and can i delete that folder when all is finished? and are there options that are supposed to go with the ./configure (hence to configure for your needs)?

Thanks a lot for walking me through these steps!

If you need i could post my lilo.conf file if that would help, and i really need this internet thing to work but i can't find anything to configure the hardware!!

I'll be checking back soon, thanks again!

squeaks_27 01-26-2003 05:25 PM

one more thing,

when i booted into kde, it told me my soundcard wasn't detected, is there a command to probe for it? it's soundblaster ct4170 from what i can see physically, do i need to find drivers for this on the net? ps. this isn't as high on the priority list as the internet though


squeaks_27 01-26-2003 10:10 PM

Hey guys

believe it or not, the complicated problem for lilo was pretty easy, i wasn't gettin the menu, but all i needed to do was hit the left shift button and voila! a selection appeared. I think i found a website for the card so i'll keep you updated. And in the meantime i'll try and find a post on this site for the soundcard, seeing i had a similar problem last time, with an ess card.


squeaks_27 01-26-2003 10:28 PM

Getting a lot done at the last minute...


here's what i did:
1. netconfig
2. selected dhcp
3. probed for card
4. Found it and accepted it
5. Type /etc/rc.d/rc.netdevice and press <Enter>.
Type /etc/rc.d/rc.inet1 and press <Enter>.

now slackware is the best!! no more redhat as soon as sound works, which at this rate....tomorrow!

Sorry i just posted all my questions without looking for some answers first, next time i'll do just a bit more research ;)

squeaks_27 01-26-2003 11:43 PM


After much reading, i found out everyone has my problems, ha ha

again, for those searching here's what i did:

1. chmod 666 /dev/dsp* /dev/mixer*, /dev/audio* /dev/sequencer* and /dev/midi*

2. vi /etc/rc.d/rc.modules and uncommented (deleted the #) /sbin/modprobe sb io=0x220 irq=5 dma=3 dma16=5 mpu_io=0x300

PERFECT... now everything is running i can have some fun, thanks for those who helped but i think i learnt something here, do all you can do first before asking questions and not be spoon fed.

I think i'm going to love this slackware stuff!

All times are GMT -5. The time now is 12:14 AM.