LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Loading Linux very slow (https://www.linuxquestions.org/questions/slackware-14/loading-linux-very-slow-690296/)

joshua'83 12-13-2008 07:15 AM

Loading Linux very slow
 
hey,

i have a problem with my laptop loading slackware 12.1. i use the standard kernel that ships with slackware 12.1, which is 2.6.21.5-smp. since i don't know to what this problem might be connected i just describe my problem naivly. after entering my boot choise in lilo there comes the line:

Loading Linux............................
Bios Data Check successful

and so on. my problem is with the dotted line. i know that the length of the line is connected with the size of the kernel but the size is not my problem (i used the standard kernel on my desktop for a long time and it loaded linux in no time with half the ram). my problem si that the dots come very slowly. it takes my laptop about 15-20 secondes to complete the line. compiling a smaller kernel reduces the overall time but the dots still come slowly.

any ideas. would and ramdisk be helpful?
thx joshua

H_TeXMeX_H 12-13-2008 07:26 AM

welcome to LQ

I too have had this problem on an old laptop and there are 2 possible solutions:

1) Install and use grub from /extra instead of lilo, basically installpkg it and run 'grubconfig' as root

2) Use lilo 'compact' option, so somewhere in '/etc/lilo.conf' add the word 'compact' like:
http://www.control-escape.com/linux/lilo-cfg.html
Then run '/sbin/lilo' as root to update the config.

guanx 12-13-2008 08:03 AM

Quote:

Originally Posted by joshua'83 (Post 3374018)
hey,

Loading Linux............................
Bios Data Check successful
and so on. my problem is with the dotted line. i know that the length of the line is connected with the size of the kernel but the size is not my problem ... (snip)

thx joshua

Uncomment this line in "/etc/lilo.conf":
#compact # faster, but won't work on all systems.

Seel man lilo.conf for details.

joshua'83 12-13-2008 08:13 AM

worked
 
hey H_TeXMeX_H,

i tried the second option since i don't really like grub. it worked. thank you very much. do you know what the option does. the link you posted just states "Makes LILO read the hard drive faster." how? or in other words, what happens during the statment "Loading Linux.........."

joshua

H_TeXMeX_H 12-13-2008 09:02 AM

Here's the exact reason why, it's written in lilo.conf too, usually:
http://www.linuxquestions.org/questi...5/#post2921883

guanx 12-13-2008 10:08 AM

Quote:

Originally Posted by joshua'83 (Post 3374062)
hey H_TeXMeX_H,

i tried the second option since i don't really like grub. it worked. thank you very much. do you know what the option does. the link you posted just states "Makes LILO read the hard drive faster." how? or in other words, what happens during the statment "Loading Linux.........."

joshua

I have suggested you to read "man lilo.conf".
If you really want to know what happens with "compact", that manual is clearer than any other docs because it is from the author of LILO.

jannekrille 12-13-2008 04:01 PM

Hi joshua'83,

Are you sure you're not running the huge kernel, and without an initrd? In that case, those dots comes in a slow pace. When using the generic kernel, it loads much faster for me, (although the complete boot still takes it's time, of course).

Jan-C.

joshua'83 12-14-2008 08:20 AM

Quote:

Here's the exact reason why, it's written in lilo.conf too, usually: http://www.linuxquestions.org/questi...5/#post2921883
thanks H_TeXMeX_H. i'll have a look into it.

Quote:

I have suggested you to read "man lilo.conf".
If you really want to know what happens with "compact", that manual is clearer than any other docs because it is from the author of LILO.
thank you too guanx. well "man lilo.conf" was obvious, wasn't it? just a bit too obvious for me to do it :). i'll look into it as well.

Quote:

Are you sure you're not running the huge kernel, and without an initrd? In that case, those dots comes in a slow pace. When using the generic kernel, it loads much faster for me, (although the complete boot still takes it's time, of course).
actually `uname -r` returns 2.6.21.5-smp but i think it is a huge kernel. maybe i should setup an initrd. i don't really know how to do but i read the kernel documentation for initrd and i think there's a description.

thank you all, joshua

bgeddy 12-14-2008 08:37 AM

Quote:

i use the standard kernel that ships with slackware 12.1, which is 2.6.21.5-smp.
That's not the standard with 12.1, 2.6.24.5 is. The one you quote comes with Slackware 12.0. If you haven't specifically setup an initrd then you will be running the huge kernel. Have a look at /boot/README.initrd and man mkinitrd for help on building one.

jannekrille 12-14-2008 11:24 AM

bgeddy said:
Quote:

Have a look at /boot/README.initrd and man mkinitrd for help on building one.
And don't forget to change /etc/lilo.conf and run lilo after making (or re-making) the initrd. Here is a clever script that can help you make a proper initrd:
http://www.slackware.com/~alien/tool...d_generator.sh

guanx 12-15-2008 07:48 AM

Quote:

Originally Posted by jannekrille (Post 3374430)
Hi joshua'83,

Are you sure you're not running the huge kernel, and without an initrd? In that case, those dots comes in a slow pace. When using the generic kernel, it loads much faster for me, (although the complete boot still takes it's time, of course).

Jan-C.

Neither the kernel image nor the initrd has anything to do with the slow pace of ".......". It happens if you are so unlucky that you have specific BIOS / HDD combinations. Suppose you have a 4MB kernel image spanning across 8192 sectors, your HDD spins at 5400 rpm, and if you read only one sector at a time, your next read must wait for the HDD to turn around because of no read-ahead, then in the worst case, your HDD must turn 8192 rounds before your kernel can be loaded, that will cost 8192/5400=1.5 minutes.


All times are GMT -5. The time now is 11:25 AM.