-   Slackware (
-   -   loaded slackware, won't finish booting. stops at cs: IO Port probe (

Whitehat 10-15-2003 12:19 PM

loaded slackware, won't finish booting. stops at cs: IO Port probe
Hey all,

I just loaded slackware 9.1.

It is installed on a Dell Latitude D600. Pentim M 1.3Ghz.

I have a Cisco Aironet wireless card in the PCMCIA slot.

It will not boot with or without the card in the slot.

It hangs at:

cardmgr[60]: watching 2 sockets
cs: IO port probe 0x0c00-0x0cff: clean
cs: IO port probe 0x0800-0x08ff:

Those are the last 3 lines and it just sits there.

I have to get into the Linux OS so I can add the proper lines to LILO so I can also boot to Windows XP.

So right now my laptop is just sitting there :D

Looks kinda neat :)

Thanks in advance to you folks!


P.S. - is there a way for me to boot off of the Slack CD and edit my lilo stuff? That way while I'm finding a solution I can be booted into Win XP?

skog 10-15-2003 12:33 PM

booting into slack
when u boot off the slack cd it stops at a certain point and asks which kernel to boot or if you need any extra settings. right above that line it will show how to boot ur machine in a pinch somehthing like vmlinuz root=/dev/hda1 ro noinitrd ... u can try that if ur pcmcia stuff is in the kernel ... but its probably coming from rc.hotplug or rc.modules not sure never run slack on a pc with pcmcia so ull get the same error msg if so. but

u can boot off the cd like u are going to install slackware, but instead of running setup just mount the partition that will contain the lines u need to add and edit it.

something like:
boot off the cd
mkdir /mnt/hd
mount /dev/hda1 /mnt/hd
cd /mnt/hd/etc
edit file cuaseing the problem and reboot

Assuming that the pcmcia stuff is coming from rc.hotplug or rc.modules ull just need ur /etc directory which is probly on your root partition.

skog 10-15-2003 12:38 PM

continue from previous
forgot about ur lilo problem...

just boot into slack install dont run setup ... mount ur partitions in /mnt and chroot urself in the new mount points.

so something like:
make the dirs in /mnt u need
mount them in /mnt
cd to them
chroot /mnt/hd /bin/bash

now ull be inside ur root partition like u booted off of it ... u can edit and rerun lilo.
ur path probly wont be setup so just give absolute paths: /sbin/lilo /bin/vi ...

Whitehat 10-15-2003 12:57 PM

wow........Linux sure don't wanna run on this laptop.

I have never had so many problems with a laptop before and Linux.

Must be because it's a dang Dell.

Awe crap.


Thanks skog. I tried some of that stuff you said. I need to do a bit more research. Right now I can't get jack working so I had to do an "fdisk /mbr" from a Win98 boot disk just so I can get back into WinXP and do my work today.

Oh well........more Linux headaches :) Yay...

Whitehat 10-15-2003 01:57 PM's the deal.

Screw Active Directory for now. I'm getting my Laptop running Linux :)

I'll get back to you.

Whitehat 10-15-2003 03:18 PM

OK, I should have done WAY more research before posting. I feel like a fool :D

Here is what I did:

First after installing Slackware 9.1 and putting LILO on the MBR, I rebooted and booted off of the Slackware CD.

I then mounted my HD stuff as skog stated to do above:

make the dirs in /mnt u need
mount them in /mnt
cd to them
chroot /mnt/hd /bin/bash

After this I was able to edit my lilo.conf in the /etc folder. Which worked nicely :)

I then decided to modify the /etc/pcmcia/config.opts as follows:

from include port 0x100-0x4ff, port 0x800-0x8ff,port 0xc00-0xcff to include port 0x100-0x4ff,port 0xc00-0xcff (credit to Mark Holbrook from here )

I then added hdparm -d1X66 -c3 -m16 /dev/hda to my rc.local file using pico (my favorite editor) ;)

Now I boot this bad boy and I get my Options of Windows XP Pro and Slackware Linux 9.1

Dang.... Slack is sure a fine OS I must say.

I simply needed some patience.

So maybe later tonight or tomorrow I'll do Xfree86 and config my display, and then I should be all set. This version of Slack is supposed to have ACPI support for this laptop. I'll keep ya posted.

Peace out .

All times are GMT -5. The time now is 02:16 PM.