-   Slackware (
-   -   LMMS Slackbuild Error with Slackware Current (GCC 4.4.3) (

smoooth103 01-30-2010 08:38 PM

LMMS Slackbuild Error with Slackware Current (GCC 4.4.3)
I am trying to build "LMMS - Linux MultiMedia Studio" on Slackware Current.

CMake is halting on "printf" lines in various .cpp files. I am assuming it's a conflict with the newer GCC? Does anyone know a work around for this issue?

I've tried commenting out the printf lines but I think they may be needed in the application. Apparently there are lots .cpp using the printf call.

any ideas?

Daedra 01-30-2010 08:51 PM

have you tried compiling the newest version (0.4.6)?

smoooth103 01-30-2010 08:55 PM

Nope not yet -- I will try though. I'm searching the web and it looks like a bug in GCC but it looks like it has been resolved. Not sure how I need to go about incorporating the bug fix. Maybe just wait for a new GCC to be added in current perhaps.

Daedra 01-30-2010 08:58 PM

I'm pretty sure that the newest version should work, I just found this...

We're glad to announce the availability of LMMS 0.4.3. This version is a
maintainance release of the 0.4.x series. It fixes most of the bugs found in
version 0.4.2 and brings in improvements on performance and stability. Thanks
to all who helped making up this release (especially those who kept up testing
and reporting bugs)!

Detailed changes:

* fixed various bugs regarding MIDI recording and record accompany
* do not lockup when freezing pattern
* sampleBuffer: fixed small bug in usage of libsamplerate API which caused
lots of zero samples at the end of various samples (e.g. in
* sampleBuffer: do not load samples bigger than 100 MB
* integrated latest libsamplerate which is both faster and more reliable
* various fixes to allow compilation with upcoming GCC 4.4
* simplified formulas for calculating envelope and LFO data resulting in about
3x performance when changing envelope or LFO parameters frequently (e.g. by
* audio mixer: heavily improved organization of worker-threads resulting in
much better performance and stability (especially with Hyperthreading-enabled

and 0.4.3 isn't even the newest version anymore.

smoooth103 01-30-2010 09:06 PM

Thanks Daedra. It appears to be compiling fine with 0.4.6. Just would have never guessed that much of the code would have changed in a .0.0.4 increase. Now it's failing on a later part in the install part of the slackbuild but it definitely fixed the harder compiler problem! Thanks, dumb me. Should have tried that first :)

All times are GMT -5. The time now is 04:13 AM.