-   Slackware (
-   -   Little problem building kernel (

AuroraZero 01-11-2010 05:18 PM

Little problem building kernel
I am running Slackware 13 and I want to downgrade the kernel. Downgrade why do that? because i want to be able to run the ATI drivers for my video card and they will not work on the 2.6.29 kernel. I decided to use the kernel. I have built the kernel and set up lilo. At first I had a common and I needed to build an intrid.gz. I have done this now another problem surfaces.

This is the problem


initrd.gz Loading kernel modules for initrd.gz:
mount: mounting /dev/hda3 on /mnt failed: No such device or address

ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead. You can try to fix it. Type 'exit' when things are done.

/bin/sh: can't access tty: job control turned off

I think that the driver for my hard disk controller is not loading. Or the driver for the hard disk itself I am not sure which. I need someone to point me in the right direction to see if my hypothesis is true or not.

This is my lilo.conf

# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/hda


# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
# VESA framebuffer console @ 1024x768x256
#vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda3
  label = SlackwareKDE
image = /boot/vmlinuz
  root = /dev/hda3
  label = SlackwareCMD
  append = "init 3"
image = /boot/vmlinuz-custom-
  root = /dev/hda3
  initrd = /boot/initrd.gz
  label = SlackwareNew
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/hda1
  label = Windows
  table = /dev/hda
# Windows bootable partition config ends

Any help will be greatly appreciated.

Thank You,

forum1793 01-11-2010 08:43 PM

Catalyst 9.11 or 12 builds nicely on, so by your post we'll have to assume you have a graphics card that is no longer supported and you need to use catalyst 9.3?

Someone else tried this but I'm not sure if they reported any success. It might be such that you cannot go back that far, I don't know.

One solution is to use slackware 12.2 and then increase kernel to one that works for catalyst 9.3 if the stock doesn't (I can't remember).

But as you've already gone this far, give it a try.

Compile the kernel with what you need built in for booting. This way you don't need initrd.

If you boot slackware13 with the smp generic kernel that comes with slackware (assumes you have a functioning initrd otherwise try huge kernel), make note of ide or sata lines.

Then when configuring kernel build (make menuconfig or make gconfig or make xconfig) choose corresponding entries in ide and sata part. If using sata, I think you still need to enable scsi-disk under scsi part. Also be sure to build in file operating systems for your hd (ext2, ext3, ext4, jfs, xfs...etc). That way you shouldn't get kernel panic.

You might also consider the open source drivers which are supposed to be in good shape including with 3d acceleration for earlier gpus.

Post your results to help others because for people with ATI gpus prior to HD series (r100-r500 probably) this will be a recurring problem.

Slackware folks might want to offer an additional kernel in extra just for this problem if the open source drivers are not adequate.

AuroraZero 01-11-2010 08:50 PM

You are correct I need the 9.3 drivers since it is a radeon xpress card. The open drivers I have installed are not enough to do what I need them to do. They work ok but they seem to crash a lot. I used the kernel config file from the generic slackware kernel when I built the new one and I would have though they had those in since this kernel works. I will take a look and see exactly what they did though.

forum1793 01-11-2010 09:25 PM

I should have pointed out one more thing. After booting with functioning setup, issue lspci as root. Then note relevant entries such as pci bridge. If this is ati sb700, you'll want the atiixp. In the kernel config that is:
Device Drivers -> ATA/ATAPI... -> ATI IXP chipset
SCSI... scsi device support
SCSI scsi disk support
SCSI scsi generic support
Serial ATA SATA Port Multiplier
Serial ATA -> ATA SFF Support
Serial ATA -> ATA SFF Support ->ATI PATA
Serial ATA -> ATA SFF Support ->Generic PATA
Device Drivers -> Graphics support -> /dev/agpgart (M) (module)
Device Drivers -> Graphics support -> Direct Rendering N (NO)
Device Drivers -> Graphics support -> Support for frame buffers (Y) but make sure all FBs under it are unchecked or say N or NO.

File Systems -> Second Extended
File Systems -> EXT3
File Systems -> The Extended 4 (if you use this)
File Systems -> others you use (xfs, jfs, reiserfs)

This is obviously only partially useful for kernel config. The above worked for me, in those areas, but your hardware is likely different and you may need to adjust. This is also from my fairly recent config and 2.6.27.xx might not be exactly the same but this should give an idea.

forum1793 01-11-2010 09:35 PM

Xpress? Is this the express 1200 or 1250 or X1200 or X1250?

Slackware comes with fairly recent mesa, drm, radeon, and radeonhd drivers which might work OK for these.

Backup your xorg.conf and try this

Section "ServerLayout"
        Identifier    "Simple Layout"
        Screen        "Screen 1"

Section "Monitor"
        Identifier  "mon1"

Section "Device"
        Identifier  "RadeonVid"
        Driver "radeonhd"
#        Option "HDMI" "all" #this for sound over hdmi
        Option "AccelMethod" "EXA"
        Option "DRI"  "on"  #xorg log says on per default maybe not needed

Section "DRI"
  Mode 0666  #I don't remember where this came from and may not be needed.

Section "Screen"
        Identifier "Screen 1"
        Device    "RadeonVid"
        Monitor    "mon1"
        DefaultDepth 24
        SubSection "Display"
          Depth 24

If that works or not, change radeonhd to radeon and try again. Do these work with the existing slackware13.0 setup including 2.6.32.x kernel?

adamk75 01-12-2010 07:26 AM

AuroraZero, you will also have to downgrade all of Xorg if you really want to stick with the catalyst drivers, and doing that is just asking for problems. If you must stick with catalyst, use an older distribution. Honestly, though, I would spend more time trying to get the radeon drivers working properly than I would on getting fglrx running.


voyciz 01-12-2010 07:43 AM

Provide some more info.
fdisk -l
cat /etc/fstab

AuroraZero 01-12-2010 07:12 PM

I think I may have to try to get the open drivers to work. I do not want to downgrade Xorg at all. I am sure someone will make either the catalyst drivers work or the open drivers will get better. It is a Xpress 200m. The laptop is a Hp ZV6000 and I love it except for this little problem.

forum1793 01-13-2010 08:01 PM

Your 200m uses the

The open source drivers are already pretty good.

Try what comes standard with slackware and try the xorg.conf file I posted above but change radeonhd to radeon. Your chipset is not likely to be supported by radeonhd.

If that doesn't work or you need better, look into compiling newer libdrm, mesa, xf86-video-ati. Maybe before doing that run through the logs (mesa and radeon) for r300 to see if improvements are likely. You could also try newer 2.6.33-rc3 kernel.

adamk75 01-13-2010 08:08 PM

There was a bug in Mesa this past summer, that I believe made it into the 7.5 release, regarding integrated ATI GPUs. A newer Mesa is much more likely to perform better.


AuroraZero 01-16-2010 01:00 PM

This configuration works okay


Section "ServerLayout"
        Identifier    "Simple Layout"
        Screen        "Screen 1"

Section "Monitor"
        Identifier  "mon1"

Section "Device"
        Identifier  "RadeonVid"
        Driver "radeonhd"
#        Option "HDMI" "all" #this for sound over hdmi
        Option "AccelMethod" "EXA"
        Option "DRI"  "on"  #xorg log says on per default maybe not needed

Section "DRI"
  Mode 0666  #I don't remember where this came from and may not be needed.

Section "Screen"
        Identifier "Screen 1"
        Device    "RadeonVid"
        Monitor    "mon1"
        DefaultDepth 24
        SubSection "Display"
          Depth 24

But it acts like it is still trying to autodetect the card when KDE starts. I am running KDE 4.2.4 and here is my Xorg configuration.

Section "ServerLayout"
        Identifier    " Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/local"
        FontPath    "/usr/share/fonts/TTF"
        FontPath    "/usr/share/fonts/OTF"
        FontPath    "/usr/share/fonts/Type1"
        FontPath    "/usr/share/fonts/misc"
        FontPath    "/usr/share/fonts/CID"
        FontPath    "/usr/share/fonts/75dpi/:unscaled"
        FontPath    "/usr/share/fonts/100dpi/:unscaled"
        FontPath    "/usr/share/fonts/75dpi"
        FontPath    "/usr/share/fonts/100dpi"
        FontPath    "/usr/share/fonts/cyrillic"

Section "Module"
        Load  "extmod"
        Load  "dbe"
        Load  "glx"
        Load  "dri2"
        Load  "dri"

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel"  "hpzt11xx"
        Option      "XkbLayout"  "us"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"

Section "Monitor"
        #DisplaySize          330  210        # mm
        Identifier  "Monitor0"
        VendorName  "LPL"
        ModelName    "0"

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "NoAccel"                    # [<bool>]
        #Option    "SWcursor"                  # [<bool>]
        #Option    "Dac6Bit"                    # [<bool>]
        #Option    "Dac8Bit"                    # [<bool>]
        #Option    "BusType"                    # [<str>]
        #Option    "CPPIOMode"                  # [<bool>]
        #Option    "CPusecTimeout"              # <i>
        #Option    "AGPMode"                    # <i>
        #Option    "AGPFastWrite"              # [<bool>]
        #Option    "AGPSize"                    # <i>
        #Option    "GARTSize"                  # <i>
        #Option    "RingSize"                  # <i>
        #Option    "BufferSize"                # <i>
        #Option    "EnableDepthMoves"          # [<bool>]
        #Option    "EnablePageFlip"            # [<bool>]
        #Option    "NoBackBuffer"              # [<bool>]
        #Option    "DMAForXv"                  # [<bool>]
        #Option    "FBTexPercent"              # <i>
        #Option    "DepthBits"                  # <i>
        #Option    "PCIAPERSize"                # <i>
        #Option    "AccelDFS"                  # [<bool>]
        #Option    "IgnoreEDID"                # [<bool>]
        #Option    "DisplayPriority"            # [<str>]
        #Option    "PanelSize"                  # [<str>]
        #Option    "ForceMinDotClock"          # <freq>
        #Option    "ColorTiling"                # [<bool>]
        #Option    "VideoKey"                  # <i>
        #Option    "RageTheatreCrystal"        # <i>
        #Option    "RageTheatreTunerPort"        # <i>
        #Option    "RageTheatreCompositePort"        # <i>
        #Option    "RageTheatreSVideoPort"        # <i>
        #Option    "TunerType"                  # <i>
        #Option    "RageTheatreMicrocPath"        # <str>
        #Option    "RageTheatreMicrocType"        # <str>
        #Option    "ScalerWidth"                # <i>
        #Option    "RenderAccel"                # [<bool>]
        #Option    "SubPixelOrder"              # [<str>]
        #Option    "ShowCache"                  # [<bool>]
        #Option    "DynamicClocks"              # [<bool>]
        #Option    "VGAAccess"                  # [<bool>]
        #Option    "ReverseDDC"                # [<bool>]
        #Option    "LVDSProbePLL"              # [<bool>]
        #Option    "AccelMethod"                # <str>
        #Option    "DRI"                        # [<bool>]
        #Option    "ConnectorTable"            # <str>
        #Option    "DefaultConnectorTable"        # [<bool>]
        #Option    "DefaultTMDSPLL"            # [<bool>]
        #Option    "TVDACLoadDetect"            # [<bool>]
        #Option    "ForceTVOut"                # [<bool>]
        #Option    "TVStandard"                # <str>
        #Option    "IgnoreLidStatus"            # [<bool>]
        #Option    "DefaultTVDACAdj"            # [<bool>]
        #Option    "Int10"                      # [<bool>]
        #Option    "EXAVSync"                  # [<bool>]
        #Option    "ATOMTVOut"                  # [<bool>]
        #Option    "R4xxATOM"                  # [<bool>]
        Identifier  "RadeonVid"
        Driver      "radeon"
        VendorName  "Unknown Vendor"
        BoardName  "Xpress 200m"
        BusID      "PCI:1:5:0"

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport  0 0
                Depth    1
        SubSection "Display"
                Viewport  0 0
                Depth    4
        SubSection "Display"
                Viewport  0 0
                Depth    8
        SubSection "Display"
                Viewport  0 0
                Depth    15
        SubSection "Display"
                Viewport  0 0
                Depth    16
        SubSection "Display"
                Viewport  0 0
                Depth    24

Any help with this will be greatly appreciated.

adamk75 01-16-2010 03:08 PM

I believe you need to use the 'radeon' driver *not* 'radeonhd'. RadeonHD is for r500, r600, and r700 GPUs. The Xpress 200 does not fall into the category, as I understand it (though the Xpress 1200/1250/1270 do).


forum1793 01-16-2010 03:21 PM

As I suggested earlier, in the shorter xorg.conf I gave you, change radeonhd to radeon. I suggested radeonhd prior to knowing what your card was.

But when reviewing your xorg.conf, you are using the radeon driver. You could remove everything with # in front for clarity. Also you can probably safely get rid of everything with depth less than 16 and maybe only keep 16 and 24. I only have 24 in my xorg.

Another thing you could try is renaming xorg.conf so you have a backup and starting X without any xorg. It's not supposed to be needed anymore. I still use it because I sometimes tell it to run radeonhd or fglrx.

adamk75 suggested compiling newer mesa as 7.5 he thought had a bug. You could compile this yourself but you could also move to slackware-current which probably already is up to 7.7 along with newer libdrm and xf86-video-ati.

You'll also have to tell us what problem your having with the open-source drivers. Look through dmesg, lspci (as root), lsmod.
Also do glxinfo and glxgears from CLI in X and maybe some message will be given.

Also look through /var/log/Xorg.0.log for errors and warnings.

cat /var/log/Xorg.0.log | grep EE
cat /var/log/Xorg.0.log | grep WW

AuroraZero 01-16-2010 03:25 PM

I am using the radeon driver not the radeonHD. I am thinking it is trying to find the best possible rendering engine though.

adamk75 01-16-2010 03:49 PM

What do you mean by "the best possible rendering engine". Please explain exactly what problems you are having when you use the 'radeon' driver.


All times are GMT -5. The time now is 11:07 AM.