LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-24-2003, 05:27 AM   #1
jazzyjazz
Member
 
Registered: Oct 2003
Location: Brussels
Distribution: Slackware-current
Posts: 42

Rep: Reputation: 15
Little Alsa question


Hello ppl

I recompiled my kernel to 2.6 with ALSA support and all,

Now when i play music in xmms the sound is good for some moments then it starts craking and musics speeds up then it goes back to normal. Now this is quite annoying.

So i tried to change the output plugin in xmms from OSS to ALSA and here is the funnt thing.

When i start xmms as a normal user and change the output plugin from OSS to ALSA i can't play music anymore while when i start xmms as root i can change the output plugin to ALSA and then music plays with no error and no more cracking.

so, what do i have to change in order to use the ALSA output plugin as a normal user aswell ?

Thx in advance and have a nice day
 
Old 11-24-2003, 07:25 AM   #2
linen0ise
Member
 
Registered: Jul 2003
Distribution: slack...nothing but slack
Posts: 52

Rep: Reputation: 15
hi,
did you set the permissions for the /dev/mixer* and /dev/dsp* device files correctly ?

chmod 666 /dev/mixer*
chmod 666 /dev/dsp*
 
Old 11-24-2003, 08:26 AM   #3
jazzyjazz
Member
 
Registered: Oct 2003
Location: Brussels
Distribution: Slackware-current
Posts: 42

Original Poster
Rep: Reputation: 15
i did what u did but still the same :/

tho when i start xmms from console i get this error

** WARNING **: alsa_setup_mixer(): Attaching to mixer hw:0 failed: Permission denied
 
Old 11-25-2003, 02:18 AM   #4
jazzyjazz
Member
 
Registered: Oct 2003
Location: Brussels
Distribution: Slackware-current
Posts: 42

Original Poster
Rep: Reputation: 15
cmon guy could u help me out here ?

i tried everything i looked even on post on anotehr forul and still the same ...

i tried chmod +rw , trying adding a new group only for audio still nothing :/

and that hw is says int in /dev/

hope to hear something ...
 
Old 11-25-2003, 03:13 AM   #5
kadaver
Member
 
Registered: Nov 2003
Location: Beautiful Northern-sweden (Luleň)
Posts: 90

Rep: Reputation: 15
try
chmod u+s /dev/dsp
chmod u+s /dev/mixer
 
Old 11-25-2003, 05:15 AM   #6
jazzyjazz
Member
 
Registered: Oct 2003
Location: Brussels
Distribution: Slackware-current
Posts: 42

Original Poster
Rep: Reputation: 15
Still nothing


when root and i play a song i see in console :
Message: output format: 7
Message: fmt 5, channels: 2

Now after i've done chmod u+s as normal user i see along with the same error msg ofcourse:
Message: output format: 7

Before i didnt get any message as normal user, so i think we'r getting closer


Last edited by jazzyjazz; 11-25-2003 at 05:20 AM.
 
Old 11-25-2003, 06:44 AM   #7
LinFreak!
Member
 
Registered: Jul 2003
Location: England
Distribution: slack9.1
Posts: 209

Rep: Reputation: 30
Did you re-install alsa after you re-compiled your kernel? That had a big effect on my system.
 
Old 11-30-2003, 09:30 PM   #8
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
If ALSA is set to use a pcm device then you need to:
chmod 666 /dev/snd/pcm*

This fix worked for me... I had the same issue.

slight
 
Old 12-01-2003, 04:55 PM   #9
ZiGiE
Member
 
Registered: Oct 2003
Location: ex USSR, Canada
Posts: 58

Rep: Reputation: 15
Wow!!!
I have identical problem. When I get home I'm gonna try changing permissions and see if it helps.
 
Old 12-01-2003, 07:01 PM   #10
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Don't know if your issue is solved yet, but one more thing you may try ->

# adduser <username> audio
 
Old 12-02-2003, 03:49 AM   #11
jazzyjazz
Member
 
Registered: Oct 2003
Location: Brussels
Distribution: Slackware-current
Posts: 42

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by slightcrazed
If ALSA is set to use a pcm device then you need to:
chmod 666 /dev/snd/pcm*

This fix worked for me... I had the same issue.

slight
I tried this aswell but still nothing :/
 
Old 12-02-2003, 12:28 PM   #12
stingx
Member
 
Registered: Oct 2002
Location: NYC
Distribution: Linux Mint 12 Mate
Posts: 54

Rep: Reputation: 15
try dma 1


modprobe sb dma=1 irq=5
 
Old 12-02-2003, 12:55 PM   #13
ZiGiE
Member
 
Registered: Oct 2003
Location: ex USSR, Canada
Posts: 58

Rep: Reputation: 15
I did:
Code:
chmod 666 /dev/mixer*
chmod 666 /dev/dsp*
chmod 666 /dev/snd/pcm*
and i was able to use ALSA plug-in in XMMS. The sound now is MUCH better. No more speed-ups and that annoying noise that you usually hear when you have much more bass than speakers can handle. I still hear very quiet 'pops' when I play MP3s on XMMS. I didn't however hear those 'pops' with mpg321. I installed ALSA 1.0.0rc1, but popping is still there.
Also I'm still unable to use multiple channels at once, i.e. only one application can play sounds at one point in time (no mixing). I'm gonna try to figure out how to enable ALSA mixer plug-in dmix, something to do with .asoundrc, I think. Back to RTFM for now.

Cheers.
 
Old 12-02-2003, 01:11 PM   #14
Angelo
Member
 
Registered: Mar 2003
Location: Connecticut
Distribution: Slackware, OpenBSD
Posts: 61

Rep: Reputation: 15
I know most people don't care, but the proper way todo this is to add your user to the sys group and not to chmod 666 everything in sight.
 
Old 12-02-2003, 01:14 PM   #15
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: Slackware 14.2-stable, Ubuntu 16.04 LTS
Posts: 401

Rep: Reputation: 30
ZiGiE: Having the same problem as you are. XMMS works fine (meaning, no popping, can run as root/non-root), but whenever XMMS is running, other system sounds seem to "queue" up. When I quit XMMS, I get a barrage of pings, whooshes, and other system sounds for several minutes. If you figure out how to fix your problem with ALSA, please post your solution.

Thanks,
tino27
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA Question dave_starsky Linux - General 1 05-26-2004 01:18 PM
Alsa question BinaryLinux Slackware 6 05-10-2004 07:07 AM
Alsa question Harp00 Slackware 16 04-05-2004 06:18 AM
Alsa question... CryptDragoon Slackware 1 02-20-2004 10:51 AM
ALSA question dhrivnak Slackware 5 10-28-2003 08:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration