LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Little Alsa question (https://www.linuxquestions.org/questions/slackware-14/little-alsa-question-119408/)

jazzyjazz 11-24-2003 05:27 AM

Little Alsa question
 
Hello ppl :)

I recompiled my kernel to 2.6 with ALSA support and all,

Now when i play music in xmms the sound is good for some moments then it starts craking and musics speeds up then it goes back to normal. Now this is quite annoying.

So i tried to change the output plugin in xmms from OSS to ALSA and here is the funnt thing.

When i start xmms as a normal user and change the output plugin from OSS to ALSA i can't play music anymore while when i start xmms as root i can change the output plugin to ALSA and then music plays with no error and no more cracking.

so, what do i have to change in order to use the ALSA output plugin as a normal user aswell ?

Thx in advance and have a nice day :)

linen0ise 11-24-2003 07:25 AM

hi,
did you set the permissions for the /dev/mixer* and /dev/dsp* device files correctly ?

chmod 666 /dev/mixer*
chmod 666 /dev/dsp*

jazzyjazz 11-24-2003 08:26 AM

i did what u did but still the same :/

tho when i start xmms from console i get this error

** WARNING **: alsa_setup_mixer(): Attaching to mixer hw:0 failed: Permission denied

jazzyjazz 11-25-2003 02:18 AM

cmon guy could u help me out here ?

i tried everything i looked even on post on anotehr forul and still the same ...

i tried chmod +rw , trying adding a new group only for audio still nothing :/

and that hw is says int in /dev/

hope to hear something ...

kadaver 11-25-2003 03:13 AM

try
chmod u+s /dev/dsp
chmod u+s /dev/mixer

jazzyjazz 11-25-2003 05:15 AM

Still nothing :(


when root and i play a song i see in console :
Message: output format: 7
Message: fmt 5, channels: 2

Now after i've done chmod u+s as normal user i see along with the same error msg ofcourse:
Message: output format: 7

Before i didnt get any message as normal user, so i think we'r getting closer :)


LinFreak! 11-25-2003 06:44 AM

Did you re-install alsa after you re-compiled your kernel? That had a big effect on my system.

slightcrazed 11-30-2003 09:30 PM

If ALSA is set to use a pcm device then you need to:
chmod 666 /dev/snd/pcm*

This fix worked for me... I had the same issue.

slight

ZiGiE 12-01-2003 04:55 PM

Wow!!!
I have identical problem. When I get home I'm gonna try changing permissions and see if it helps.

Bruce Hill 12-01-2003 07:01 PM

Don't know if your issue is solved yet, but one more thing you may try ->

# adduser <username> audio

jazzyjazz 12-02-2003 03:49 AM

Quote:

Originally posted by slightcrazed
If ALSA is set to use a pcm device then you need to:
chmod 666 /dev/snd/pcm*

This fix worked for me... I had the same issue.

slight

I tried this aswell but still nothing :/

stingx 12-02-2003 12:28 PM

try dma 1


modprobe sb dma=1 irq=5

ZiGiE 12-02-2003 12:55 PM

I did:
Code:

chmod 666 /dev/mixer*
chmod 666 /dev/dsp*
chmod 666 /dev/snd/pcm*

and i was able to use ALSA plug-in in XMMS. The sound now is MUCH better. No more speed-ups and that annoying noise that you usually hear when you have much more bass than speakers can handle. I still hear very quiet 'pops' when I play MP3s on XMMS. I didn't however hear those 'pops' with mpg321. I installed ALSA 1.0.0rc1, but popping is still there.
Also I'm still unable to use multiple channels at once, i.e. only one application can play sounds at one point in time (no mixing). I'm gonna try to figure out how to enable ALSA mixer plug-in dmix, something to do with .asoundrc, I think. Back to RTFM for now.

Cheers.

Angelo 12-02-2003 01:11 PM

I know most people don't care, but the proper way todo this is to add your user to the sys group and not to chmod 666 everything in sight.

Tino27 12-02-2003 01:14 PM

ZiGiE: Having the same problem as you are. XMMS works fine (meaning, no popping, can run as root/non-root), but whenever XMMS is running, other system sounds seem to "queue" up. When I quit XMMS, I get a barrage of pings, whooshes, and other system sounds for several minutes. If you figure out how to fix your problem with ALSA, please post your solution.

Thanks,
tino27


All times are GMT -5. The time now is 11:01 PM.