-   Slackware (
-   -   Linux novice here. No distros seem to work with my computer. (

slack_newbie 09-04-2012 06:32 PM

Linux novice here. No distros seem to work with my computer.
I'm new to linux but very interested in giving it a try.

I've tried 6 different distros including the latest versions of:
Ubuntu, OpenSUSE, Fedora, Slackware, Debian, and Linux Mint.

All of them but Slackware froze during installation and gave cryptic error messages that weren't google-able as far as I could tell.

I was able to install Slackware successfully (after multiple attempts--it would often stop at random times during the installation with different error messages every time). However, it can't boot. I tried it with LILO installed to the MBR, to the main partition, and even just booting from the disk. Same error every time.

HD was reformatted and repartitioned with fdisk prior to installation. memtest86 came up with no issues.

Laptop is a ~5 year old Sony Vaio PCG-GRT250.

Intel Pentium 4 CPU 2.80GHz FC-PGA2
40 GB HD
nVIDIA GeForce4 420 GO
SiS 648 Chipset

If any more detail would be helpful here, let me know.

I think it might be a graphics card issue since the error message I get seems to concern graphics:

Parsing VBIOS init table 6 at offset 0xE7A0
...a few lines describing graphics memory followed by...
[TTM] Initializing pool allocator
...a few lines about AGP 3.0 bridge/SiS delay workaround then...
[drm] nouveau 0000:01:00.0: 64 MiB GART (aperture)
[drm] nouveau 0000:01:00.0: Saving VGA fonts
BUG: unable to handle kernel NULL pointer dereference at 000002d4

If it would help to type out the full message, let me know.

I assure you that I'm not lazy, only ignorant. If there's reading you recommend I should do to get a handle on this stuff, I'll do it. I just really want to get this computer working and I'm not successfully googling any solutions.

Miranden 09-04-2012 08:17 PM

I am not qualified to help you with this but since no one else has come along I have asked if your thread should be moved to the Slackware forum. they are seriously helpful over there for all things Slackware.

Also, digital cameras are handy for taking pictures of terminal messages so you dont have to type everything out. You can attach the piture to your post.

Finally, if you suspect a graphics card problem, reseating the card would not be a bad idea. It works for me more often than it doesn't.

Wish I could be more help.

jefro 09-04-2012 08:41 PM

Did the live cd's for those work?

On the surface that computer should work. Let's start all over. We need to verify a few things. One is that you correctly downloaded the files. Use md5 or shal to test each file.

Second is that you may need to get high quality cd/dvd's and burn them at the very slowest speeds you can.

Last idea may be to try a live usb to boot to. I can't tell yet if your system is not reading the disks or there is another issue.

Ztcoracat 09-04-2012 11:53 PM

Don't touch the underneath portion of the brand new cd or dvd like I did.

I had to go and get the ISO and burn Debian all over again.

I used a DVD+R and successfully installed the distro.

slack_newbie 09-04-2012 11:54 PM

Live CDs didn't work even while XP was still working. I would get to the main screen of the install (e.g., attempt to install, and it would just freeze.

No red flags as far as md5 testing goes.

I have been using high quality DVDs, and have been using infrarecorder at the lowest possible setting to burn them.

Live USB is a no go, because as far as I can tell my laptop doesn't allow you to boot to removable devices. In the BIOS list of bootable devices, it's not listed as an option.

More problems now. Tried to reinstall XP with the original disc but now that won't even work. I get a blue-screen setupdd.sys PAGE_FAULT_IN_NONPAGED_AREA error during installation.

Preliminary googling suggests again that it's a hardware issue, but I'm truly befuddled since everything was working fine just a day ago. Pretty sure I ruled out RAM, tried removing each stick and doing the installation with only one, no dice. Can't think of what else it could be.

wigry 09-05-2012 02:02 AM

Definately hardware issue. Your old coputer seems to be crumbling so not much hope on it anymore. The capacitors are the chemical elements that will usually cause such a problems also memory modules.

Other issue might be cooling. Check the CPU temperatures, P4 is very inefeecient CPU producing insane amounts of heat and that might easily cause problems if the heat is not removed. Your BIOS should show the CPU temp.

jefro 09-05-2012 11:33 AM

Does a real disk like xp work to boot to? I still can't determine if your disk or disk reader or channel is bad yet.

TobiSGD 09-05-2012 12:37 PM

Seeing your symptoms and the Windows error message I would assume that there is in fact a problem with your RAM.
Download Memtest86+ and let the test run for some hours:

slack_newbie 09-05-2012 02:51 PM

I ran the memtest included with slackware for about 5 hours and it didn't find anything. I have a freshly downloaded ultimate boot cd, should I run the version on that? Or d/l by itself, fresh?

I've also tried swapping out each stick of RAM and attempting to install various OS without it. It didn't seem to make a difference.

I got knoppix to run by using noapic, but I have no GUI.

Habitual 09-05-2012 03:17 PM


Originally Posted by slack_newbie (Post 4772917)
Live USB is a no go, because as far as I can tell my laptop doesn't allow you to boot to removable devices. In the BIOS list of bootable devices, it's not listed as an option. ...

While I don't have a Vaio, my lappy has no such BIOS option either, yet, if I have a bootable USB in place, it comes up when I "F12", so I'd like to recommend trying that.

nomodeset passed to install may help as described here... ?

Tinkster 09-05-2012 03:38 PM

Moved: This thread is more suitable in <SLACKWARE> and has been moved accordingly to help your thread/question get the exposure it deserves.

Franklin 09-05-2012 05:18 PM

I looks like nouveau caused a kernel oops. This just happened on one of my boxes that I cobbled together and added the new (cheap) nVidia 610 card to.

I was able to load slackware current 32bit (RC3) just fine, but the box would not boot. I got a kernel oops after the nouveau kernel driver attepted to load. I solved the problem by passing the nomodeset flag at the lilo prompt. At the lilo boot screen hit TAB and enter


Linux 3 nomodeset
After the box boots to the command prompt, login as root and install the xf86-video-nouveau-blacklist package from /extra. Then you should be able to install the proprietary nVidia driver.

It's very possible this may have been impacted by the addition of the FB driver in the RC4 additions to current. I noticed I needed to reinstall the blacklist package in order to boot to X again.

Hope this help. It sounded similar based on what you wrote.

dfwrider 09-05-2012 05:30 PM

from the very first post, I gave a high probability of hardware problem.

memtest can check for bad memory, and in conjunction with other stress tests perhaps provide some insight, but i've had computers pass memtest, but fail with other i/o issues due to heat, bad-caps, faulty mobo, faulty cpu, etc etc etc.

normally, if the kernel is going to have a compatibility problem, it does so right at boot, including the installation media boot. if you are seeing random failures at different points of the install, that means instability and io, so very likely hardware related.

something as simple as the heatpipes/heatsinks/vents on your laptop being stuffed up with dust and crap could be causing it. also dried out thermal paste (graphics chip or cpu)could also cause problems. or maybe a semi-failed motherboard component.

a beginnning to fail harddrive also comes to mind.


damgar 09-05-2012 09:10 PM

I would try the kernel modesetting wok around mentioned above. The nouveaou driver has been a pain in my butt since it was included in Slackware. The NVIDIA proprietary driver is a very nice driver even if it is proprietary and people don't like that. It works very well.

ReaperX7 09-05-2012 09:48 PM

If you can, get the Install Media to boot the system as such:

huge.s /dev/sda# noinitrd= ro
Replace # with whatever partition your main install is located at.

Once the system is loaded rerun liloconfig and where it asks for Kernel Parameters type in

to the linespace without the " marks and finish it out.

I would recommend the Nvidia proprietary driver for your needs however to remedy this issue.

All times are GMT -5. The time now is 11:43 PM.