LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-23-2011, 08:22 PM   #1
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Rep: Reputation: 11
Linux 3.0 Internet Disconnection


Hi,

So right now I'm running Linux 2.6.39.3, and when I upgraded to 3.0 by Mr. Hamaleers page here:

http://alien.slackbook.org/dokuwiki/...rnelbuilding&s[]=kernel&s[]=compile

Everything worked fine. My computer was working too, but my internet wasn't. Since it works on the original kernel, I know that maybe it's something I was supposed to install as part of "make [variable]config" and I'm wondering if you guys can help me which one I missed out on.

The network icon is there, but it doesn't connect automatically as 2.6.39.3 does if that helps as a part of the description.
 
Old 07-23-2011, 08:25 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,833
Blog Entries: 1

Rep: Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229
Did you use 'make oldconfig'?
 
Old 07-23-2011, 08:28 PM   #3
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
No I used xconfig actually.
 
Old 07-23-2011, 08:47 PM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,833
Blog Entries: 1

Rep: Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229
If everything was working ok under the old kernel, it'd make sense to utilise the old config file.

If you don't want to recompile it again, I guess you could boot into the old kernel and save the output of lsmod in order to see if/what modules aren't loaded in the new kernel (and load them manually). It might help.
 
Old 07-23-2011, 08:50 PM   #5
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
It's okay, I'm fine with re-compiling. I guess I just missed a few things this time.
 
Old 07-24-2011, 10:41 AM   #6
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
Okay, one final question:

When it says to "# copy the new kernel file" under Building your kernel, as a 64-bit user I would type:

cp arch/x86_64/

instead of

cp arch/x86/

Right?
 
Old 07-24-2011, 11:44 AM   #7
GazL
Senior Member
 
Registered: May 2008
Posts: 4,952
Blog Entries: 15

Rep: Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559
On x86_64, it's a symlink from one to the other, so it doesn't matter.

arch/x86_64/boot/bzImage -> ../../x86/boot/bzImage

Last edited by GazL; 07-24-2011 at 12:01 PM. Reason: simplified
 
Old 07-24-2011, 01:22 PM   #8
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,368

Rep: Reputation: Disabled
For a leap in kernel versions you ought to run 'make oldconfig' before 'make {x,menu}config' unless you want to start from scratch.

If you configured from scratch then perhaps you missed out the driver for your network device or some other network option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem on Internet disconnection satimis Linux - Networking 25 10-08-2007 10:31 PM
dialup disconnection zovres Linux - Networking 5 09-11-2007 05:29 PM
[SOLVED] Internet disconnection using Suse 9.3 enrico_dvchp Linux - Newbie 3 08-17-2006 08:16 AM
VPN disconnection karlyue Linux - Networking 0 05-04-2005 09:16 AM
disconnection message cynthia Linux - Networking 1 09-30-2004 05:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration