-   Slackware (
-   -   Linksys Wireless-G USB Adapter (

Anonymo 05-05-2006 07:04 PM

Linksys Wireless-G USB Adapter
I have the Linksys Wireless-G USB Adapter (WUSB54GC).

I am running Slackware -current (May 1st) with a 2.6 kernel.

Wondering how I could get this working if anyone already has or point me in a good direction. Never done this before.

Oh I am going to install Gnome Dropline, the newest one in a few minutes. It has automounting.

-=Graz=- 05-06-2006 05:20 AM

i just had a quick snoop around google and your card seems to use the RALINK RT2501 chipset..
I have not seen this particular chip before - i have a card that uses the rt2570 chip and i have seen rt2500 as well... (but not 2501)
Im not sure if this helps but you can try:
these guys make the linux driver for the 25xx series chips (the one that i use works perfect) - if your card is Ralink then you will find ppl talking about it on the forum here..
btw - my stick is DLink DWL-122 USB 54Mbit adaptor

-=Graz=- 05-06-2006 05:29 AM

Also - on Ralink's page there is a device called WUSB54G (not quite WUSB54Gc)
getting close =)
if the serial monkey drivers do not work you could try Madwifi- i know nothing about this though as have not tried

Anonymo 05-06-2006 10:17 AM


Will try.

aqau 07-14-2006 08:37 PM

I found a website that seems to know whta they are talking about. It's a step by step guide for that particular adapter...check it out.

Anonymo 07-14-2006 09:13 PM


Can anyone translate this to Slackware?

I have tried it but don't know exactly the steps for Slackware.

aqau 07-16-2006 03:14 PM

okay i had something here but then i figured out that i had no idea what i'm talking about....anyways...hope you get real help f

aqau 07-17-2006 11:44 PM

whoops...didn't mean to post this here and can't figure out how to delete a post

Nylex 07-18-2006 01:00 AM

Firstly, you should have the kernel source installed already so you won't need to install a package for it (or the kernel headers). Slack usually comes with those installed.

Also check that you have gcc, make and wireless-tools installed. You can do a "ls -l /var/log/packages | grep gcc" to check that gcc is installed for example.

All the unpacking the archive, building the source, loading the module and creating an alias for it are the same (that's done where /etc/modprobe.conf is edited to add the "alias rausb0 rt73" line).

After that though, you might want to look at editing /etc/rc.d/rc.inet1.conf. Scroll down and there's a section for wireless cards. If there's a line that specifies the interface name as wlan0, then you'll need to change that to rausb0.

HTH a bit.

All times are GMT -5. The time now is 08:24 AM.