-   Slackware (
-   -   Linking a directory for ftp user (

riemann_noodles 11-13-2006 10:34 PM

Linking a directory for ftp user
Hi All,

So, I have done this before, but after a fresh install of Slack 11, I can't for the life of me figure out what I am doing wrong this time.

I want a symbolic link in the /home/ftp directory to a /data/files directory mounted on a seperate drive, so that an anonymous ftp user can navigate to the 'files' subdirectory and download it's contents.

The link is as follows:

lrwxrwxrwx files -> /data/files

The permissions of the entire /data folder are:

drwxr-xr-x me:users

On the server as the ftp user I can navigate the link. But ftp-ing in from another box, I am denied access to the folder. I tried all sorts of random permissions when all logic failed, to no avail.

Anyone see my error? Or have a better solution.


bathory 11-14-2006 02:57 AM

Could you please be more specific and answer the following questions.
What ftp server are you using? Is it running chrooted? Do you allow you server to follow symlinks?

riemann_noodles 11-14-2006 05:04 AM

Thanks for the reply.

Im using vsftpd (sorry I intended to include that in the original post)

It is not running chrooted.

Apparently as I read while digging around on the net, vsftp does not allow symlinks in any case- which would be my problem if true.

I have since solved my problem, however, with the option I overlooked anon_root=/data/files. Which works for now : )

acummings 11-15-2006 12:15 AM

A disk partition from elsewhere can be mounted underneath /home/ftp

for example mkdir the hd2 dir in the next


since your disk partition (dp) containing /data/files is already mounted elsewhere

then, now you can use the -bind option with mount to mount this same dp a second time.

thus the entire /dev/hdX containing /data/files gets mounted again, a 2nd time, using -bind it gets mounted onto /home/ftp/hd2

It works. I've done it. It's a way to add disk space onto the ftp.


All times are GMT -5. The time now is 11:06 PM.