-   Slackware (
-   -   lilo x elilo x grup2 x UEFI (

afreitascs 09-08-2012 05:16 PM

lilo x elilo x grup2 x UEFI
I wanted to know the status of slackware and booting a UEFI-based system,
and the incompatibility of lilo.

Will we have to buy computers compatible with slackware ?

What are the alternatives ?


BlackRider 09-08-2012 05:35 PM

I suggest you read the relevant documentation, as it will explain far better than I can.

You could use a UEFI board in BIOS compatibility mode in some cases (and it might be a must if you use kernel modules that require traditional BIOS calls, like some proprietary stuff).

If you want to use pure UEFI mode, then have a look at the following bootloaders and methods:

afreitascs 09-08-2012 09:22 PM

thanks for the replies BlackRider

I actually am now telling me about it, and how LILO is not compatible I was wondering how would the slackware ...

Thanks also for the link

ruario 09-09-2012 02:28 AM

This has been discussed several times before. A number of us have installed on such systems. You really should have searched the forums first as the last thread was still active as recently as three days ago. Here is a snippet.


Originally Posted by ruario (Post 4773803)
make your own EFI-capable Slackware install media (copy the contents of the Slackware install DVD [or USB], create a new "efi/boot" directory and add to this the elilo.efi program and an appropriately configured elilo.conf, pointing at the huge kernel+initrd from the install media).


A more complete explanation of this is:


Originally Posted by ruario (Post 4777499)
The easiest way to make your own Slackware EFI-capable install media would be to create a USB boot disk. Partitioning it with a GPT partitioning scheme and include a UEFI System Partition (FAT32 filesystem, created with gdisk, using type code EF00, at least 50Mb and formatted with mkdosfs). Add a ./EFI/BOOT/ directory structure to this partition, into which place BOOTX64.EFI (extract elilo-3.14-x86_64.efi from elilo-3.14-all.tar.gz and rename it), bzImage, initrd.img and an elilo.conf that looks like this:



  append="load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=huge.s"

With this disk you should be able to boot into the Slackware install environment.


This allows you to do the install and you can also use your newly created boot media to boot the system after first install.

After install you need to install elilo, grub2, gummiboot or some other EFI capable boot loader. You may also wish to recompile your kernel with efistub support. Then you don't necessarily need a boot loader as the kernel itself is the boot loader.

In summary the two things lacking are official EFI capable install media and an EFI boot loader. Both issues can be worked around until Pat chooses to fix them one day.

ruario 09-09-2012 02:31 AM

Also most EFI systems can do BIOS compatibility mode in any case. If yours can do this, just enable it and problem solved!

afreitascs 09-09-2012 10:55 AM

Thanks for the replies ruario

Sorry, I really should have done a search on the forum.

But from what little I've read about these things, and as there are already using UEFI hardware, and as I read a bit that Ubuntu, Arch Linux, Fedora are already preparing to use UEFI, I wondered if Slackware is also ...

I would put this issue as resolved, but I think I can not do this because it is not ! I think the best thing to do is let it go away ...

I'll read here and there and stay alert, as the path that will take Slackware ....

For now I have no problems with UEFI x Slackware, but if I change the motherboard, I have to stay alert!

many thanks

All times are GMT -5. The time now is 06:42 AM.