LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-10-2017, 08:13 PM   #1
krakanut
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 22

Rep: Reputation: Disabled
Lilo VESA Framebuffer Optimized For VirtualBox on Mac


Hi, I just installed Slackware 14.2 in VirtBox 5.2 on MacbookPro 15" with retina. I am having trouble getting the resolution for the console correct. I believe the mac native resolution is 2880x1800. I do not need my Slack console to be near this resolution but I would like to be relatively high resolution at full screen. It looks like 1920x1200 is largest native VESA according to wiki. Are there other options to match the retina? Do I need to play with scaling in VirtBox settings? Looking for best options.
 
Old 11-10-2017, 11:09 PM   #2
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,456

Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
after you install the guest addons edit the /etc/lilo.conf file and add this line toward the top where you see append.

append="video=1920x1200" or whatever resolution you want. rerun lilo, then reboot.
 
Old 11-11-2017, 07:40 AM   #3
krakanut
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: Disabled
Thank you Daedra - installing guest addons helped my x resolution and now xfce runs very well full screen. but I am still confused as to how when I start slackware in full screen mode to get my console to run full screen. according to display app in xfce it is running at 1440x900. it seems to me that this would be a good resolution to use for the console. i did try setting video=1440x900, running lilo but no matter what resolution i choose it seems to default to 1024x768 and is a block in the middle of the black screen. i can set vga=ask and choose some other resolutions from the list and these do expand out but none of the default ones scale properly to screen - i.e. not wide enough or too tall/short. is it possible that setting video= is more for x and i still need to set vga for boot console? perhaps it is a resolution issue with virtualbox that is stomping on something?
 
Old 11-11-2017, 09:37 AM   #4
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,318

Rep: Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784
Quote:
Originally Posted by krakanut View Post
Thank you Daedra - installing guest addons helped my x resolution and now xfce runs very well full screen. but I am still confused as to how when I start slackware in full screen mode to get my console to run full screen. according to display app in xfce it is running at 1440x900. it seems to me that this would be a good resolution to use for the console. i did try setting video=1440x900, running lilo but no matter what resolution i choose it seems to default to 1024x768 and is a block in the middle of the black screen. i can set vga=ask and choose some other resolutions from the list and these do expand out but none of the default ones scale properly to screen - i.e. not wide enough or too tall/short. is it possible that setting video= is more for x and i still need to set vga for boot console? perhaps it is a resolution issue with virtualbox that is stomping on something?
Does this help? It's been some time since I referred to it so I can't remember if it fixed the console as well as X. You might need to set VGA = ask again after doing this.
 
Old 11-11-2017, 06:39 PM   #5
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,456

Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
Quote:
Originally Posted by krakanut View Post
Thank you Daedra - installing guest addons helped my x resolution and now xfce runs very well full screen. but I am still confused as to how when I start slackware in full screen mode to get my console to run full screen. according to display app in xfce it is running at 1440x900. it seems to me that this would be a good resolution to use for the console. i did try setting video=1440x900, running lilo but no matter what resolution i choose it seems to default to 1024x768 and is a block in the middle of the black screen. i can set vga=ask and choose some other resolutions from the list and these do expand out but none of the default ones scale properly to screen - i.e. not wide enough or too tall/short. is it possible that setting video= is more for x and i still need to set vga for boot console? perhaps it is a resolution issue with virtualbox that is stomping on something?
No the video option only affects the framebuffer resolution. I used to use the VGA options, but a few releases ago they stopped working after I installed the guest addons. The framebuffer resolution would always revert back to 1024x768 while booting. The video option fixed the problem for me. Don't know if it will help but here is my VM lilo.conf

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append="video=1280x1024"

boot = /dev/sda
compact        # faster, but won't work on all systems.

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and 
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
#prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# Ask for video mode at boot (time out to normal in 30s)
#vga = ask
# Normal VGA console
#vga = normal
# VESA framebuffer console @ 1024x768x64k
#vga=791
# VESA framebuffer console @ 1024x768x32k
#vga=790
# VESA framebuffer console @ 1024x768x256
#vga=773
# VESA framebuffer console @ 800x600x64k
#vga=788
# VESA framebuffer console @ 800x600x32k
#vga=787
# VESA framebuffer console @ 800x600x256
#vga=771
# VESA framebuffer console @ 640x480x64k
#vga=785
# VESA framebuffer console @ 640x480x32k
#vga=784
# VESA framebuffer console @ 640x480x256
#vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  initrd = /boot/initrd.gz
  root = /dev/sda1
  label = Linux
  read-only
# Linux bootable partition config ends

Last edited by Daedra; 11-11-2017 at 06:49 PM.
 
Old 11-11-2017, 07:05 PM   #6
krakanut
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: Disabled
Hi - I tried your lilo and this is what I see booting full screen.
 
Old 11-11-2017, 07:07 PM   #7
krakanut
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: Disabled
Click image for larger version

Name:	slack_boot_console.png
Views:	14
Size:	122.3 KB
ID:	26283
 
Old 11-11-2017, 07:32 PM   #8
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,456

Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
Yeah that is not working for you. You said you are using Virtualbox 5.2.0? What are the display settings of your VM? Also did you install the extensions package?

Last edited by Daedra; 11-11-2017 at 07:33 PM.
 
Old 11-11-2017, 07:50 PM   #9
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,456

Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
I found this from the virtualbox manual. Might be worth a try http://www.virtualbox.org/manual/ch09.html#idp13634352

Scroll down to 9.8.1. Custom VESA resolution
 
Old 11-11-2017, 10:24 PM   #10
krakanut
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Daedra View Post
Yeah that is not working for you. You said you are using Virtualbox 5.2.0? What are the display settings of your VM? Also did you install the extensions package?
Here is screenshot of my VB video settings.

Click image for larger version

Name:	vb_display_settings.png
Views:	13
Size:	159.3 KB
ID:	26284
 
Old 11-11-2017, 10:49 PM   #11
krakanut
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: Disabled
Extension pack is installed too without effect.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to setup vesa framebuffer? kdrlx *BSD 1 07-24-2006 11:35 AM
VESA framebuffer vs Intel framebuffer in Slackware 10.0 with default kernel brancalessio Slackware 3 01-20-2005 04:21 PM
problem with VESA framebuffer driver alinsoar Linux - Hardware 1 11-30-2004 09:05 PM
VESA Framebuffer Driver hubabuba Linux - General 1 10-02-2004 08:37 AM
VESA framebuffer nautilus_1987 Slackware 3 09-26-2002 01:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration