LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   LILO on Slackware 14.2 install DVD (https://www.linuxquestions.org/questions/slackware-14/lilo-on-slackware-14-2-install-dvd-4175656212/)

deretsigernu 06-22-2019 11:10 PM

LILO on Slackware 14.2 install DVD
 
I'm in the process of setting up a new laptop that has UEFI for booting Windows 10 and Slackware. Windows 10 is preinstalled. Before running the Slackware installation, I have gone into the BIOS boot set up and changed from Secure boot to "Legacy". I also disabled the UEFI boot option. The Slackware install DVD runs through most of the setup okay, but when it gets to the part about setting up a boot manager, it only gives me the option of "LILO" and not "ELILO". I've read that LILO is not suggested for UEFI disks, this link for example. I see here that the Slackware installation disk supposedly includes ELILO in the setup, but when I am running the setup, I don't get an option for ELILO, only LILO.

I have run the setup several times now and cannot get any kind of boot menu. I get either an error that says there is no OS or I have to manually select the hard disk to boot Win10 or I have to use the USB to boot Slackware. If I turn UEFI back on as a boot option, the machine only boots to Windows 10. None of these are what I really want; I would like to get a menu that lets me select which OS to boot. During my most recent installation setup, I tried to let the setup just install LILO to the MBR and that didn't work. What do I need to do to get a boot manager that installs ELILO or GRUB when the set up is in process? Do I need to set up, boot to Slackware with the USB, and manually install ELILO or GRUB from there? Is there some way to just get the boot manager installed with the setup that happens with the DVD?

khronosschoty 06-22-2019 11:18 PM

The automated tools for elilo, that Slackware provides, doesn't let you make an entry that ends in being able pick what OS you want at boot. I think that if you manually setup elilo to do so, you can have elilo present a menu for you to pick the OS you want to boot, at boot; but I haven't ever bothered to make such an attempt.

deretsigernu 06-22-2019 11:29 PM

Thanks for responding.

The setup process on the installation DVD doesn't offer an ELILO option for me. Should it? Do I need to start Slackware on the new machine from the USB and set up GRUB2 or ELILO from there to give me boot manager options? I currently have an older machine that uses LILO and Windows 7 and that let me have a menu at startup. I don't remember having to edit much, if anything, when I set up this machine, but it's been a few years at least since I messed with it and I don't do this sort of thing that often.

khronosschoty 06-22-2019 11:39 PM

Quote:

Originally Posted by deretsigernu (Post 6008150)
Thanks for responding.

The setup process on the installation DVD doesn't offer an ELILO option for me. Should it? Do I need to start Slackware on the new machine from the USB and set up GRUB2 or ELILO from there to give me boot manager options? I currently have an older machine that uses LILO and Windows 7 and that let me have a menu at startup. I don't remember having to edit much, if anything, when I set up this machine, but it's been a few years at least since I messed with it and I don't do this sort of thing that often.

You should be offered the option to choose elilo or lilo after installation; however, the Slackware installer will need to detect an efi partition, or this wont be true. Its been a while since I installed 14.2 but I had also noticed instances when installing in bios emulation mode on a Macbook Pro that the elilo option wasn't present. Lilo was much nicer when it comes to giving you want you want. You might try out grub2 in this case.

Didier Spaier 06-23-2019 04:45 AM

As you disabled the UEFI boot option, the installer doesn't find the file /sys/firmware/efi, and in this case doesn't allow you to run ELILO.

Either enable UEFI or use LILO.

This being said, I never used Windows 10, thus can't say which will work.

colorpurple21859 06-23-2019 07:54 AM

Disasble legacy mode, enable efi mode, disable secure boot, disable fast boot under power advance setttings in windows

deretsigernu 06-23-2019 02:06 PM

Thanks for all of the replies, everyone.

I have done everything that colorpurple21859 indicated just previously, so that I can get the install disc to give me a chance to use ELILO. But even with doing that, the disc does not provide me with a chance to use ELILO, just LILO.

These are the settings in the set up menu that is available at start up for the computer (HP Probook) I currently have:
Security tab > TPM is off; BIOS Sure Start is off

Advanced tab > Boot options: Fast Boot is disabled (also turned off in Windows power modules); UEFI Boot Order is enabled and Legacy Boot Order is enabled (but greyed out as UEFI Boot seems to take precedence).

Advanced tab > Secure boot configuration: Legacy Support Disabled and Secure Boot Disabled (both are part of same drop down menu); all of the Secure Boot Key Management options are disabled.

I don't know what else to do. I tried turning Legacy back on and running LILO on the install and that messes something up because then I get an error at start up "BootDevice Not Found" and there is no operating system on HDD. When Legacy is enabled, I can use the USB stick I created with one of the installs to start Slackware or I can get the install DVD to read, but it gives the no OS error when it tries to read SATA0. When UEFI is enabled in the Boot Options, it only reads the SATA and starts Windows without any reference to a menu or Slackware option, won't read USB or DVD, even though those are listed before SATA in the boot order.

Alien Bob 06-23-2019 02:13 PM

Quote:

Originally Posted by deretsigernu (Post 6008274)
These are the settings in the set up menu that is available at start up for the computer (HP Probook) I currently have:
Security tab > TPM is off; BIOS Sure Start is off

Advanced tab > Boot options: Fast Boot is disabled (also turned off in Windows power modules); UEFI Boot Order is enabled and Legacy Boot Order is enabled (but greyed out as UEFI Boot seems to take precedence).

Advanced tab > Secure boot configuration: Legacy Support Disabled and Secure Boot Disabled (both are part of same drop down menu); all of the Secure Boot Key Management options are disabled.

I don't know what else to do.

If you leave it like that, and then re-install Slackware, the installer should prompt to install elilo instead of lilo. But before starting the installation, make sure that there is (or you create one) a FAT32 partition available which does not need to be larger than a couple hundred MB. That partition will be mounted by the Slackware installer on /boot/efi if it detects an uEFI computer.

Quote:

I tried turning Legacy back on and running LILO on the install and that messes something up because then I get an error at start up "BootDevice Not Found" and there is no operating system on HDD. When Legacy is enabled, I can use the USB stick I created with one of the installs to start Slackware or I can get the install DVD to read, but it gives the no OS error when it tries to read SATA0. When UEFI is enabled in the Boot Options, it only reads the SATA and starts Windows without any reference to a menu or Slackware option, won't read USB or DVD, even though those are listed before SATA in the boot order.
Changing the boot back from Legacy BIOS to UEFI mode will not make Slackware suddenly work. It needs to be installed on an UEFI computer (i.e. the computer needs to boot from UEFI instead of BIOS).
One way or the other. This is easily fixable manually but I do not think your level of knowledge is sufficient to accomplish that currently. But... you will get there, I am sure.

enorbet 06-23-2019 02:46 PM

Now I'm curious. If one installs LILO to Slackware Root partition will it not still boot from the command line presented from the 1st step of the Install Disk by setting sort of like this? the typical response.....

Code:

huge.s root=/dev/foo rdinit= ro
If that works I also wonder if even the Windows Bootloader wouldn't "handoff" or chainload... or does UEFI (sans Secure and Fast Boot) forbid this?

hazel 06-23-2019 02:49 PM

Once you get elilo installed, getting it to display a menu is not difficult. Basically you need to do 2 things:

1. Edit elilo.conf to work in menu mode (the default mode is a simple boot prompt)

2. Edit and copy over the menu message file that you will find in /usr/share/doc/elilo-3.16/examples/textmenu_chooser.

But I warn you, it's a pig to edit because it's full of weird control characters. It took me a lot of supplementary edits before I got it looking reasonable.

colorpurple21859 06-23-2019 03:02 PM

You didn't say which iso you used, have to use slackware64-14.2 iso to boot in uefi mode not slackware-14.2 iso.

deretsigernu 06-23-2019 07:01 PM

@colorpurple21859: I hadn't realized there was a difference! That may be it. It looks like I have the slackware-14.2 ISO, not slackware64. I am getting the 64 ISO right now...

@AlienBob: The information you provide helps. But for some reason, even when I disable all the settings it seems I need to, I still can't get the computer to boot from anything but the HDD when UEFI is enabled. Only Legacy seems to let me use other sources for booting. So I'm kind of stuck in a catch-22. Like you said, I should get there. Hopefully before it takes 2 weeks. ;)

@hazel: Thank you for the advice. I am going to change up the ISO I am using and hope that I get ELILO to cooperate. If it doesn't this time, I'll see about making the install and then installing GRUB2 after a reboot or something.

@enorbet: I didn't think the LILO or the other boot loaders could be installed to a non-EFI partition. This process is difficult for me already. I don't know if I'm ready to try something experimental.

enorbet 06-24-2019 12:10 AM

Quote:

Originally Posted by deretsigernu (Post 6008348)
@colorpurple21859:
@enorbet: I didn't think the LILO or the other boot loaders could be installed to a non-EFI partition. This process is difficult for me already. I don't know if I'm ready to try something experimental.

I'm not sure if the above is a typo or what but LILO is exactly for NON-efi partitions. Also I know one can mix MBR drives with GPT drives because mine does. I don't use UEFI for booting, in fact I'm set to "Legacy Mode" but one of my 3 drives is 4TB and it is my understanding that must be partitioned as GPT or lose a very large amount of "real estate", so it is GPT.. This is why I'm wondering about the strictness of the rules of UEFI. I don't know if UEFI disallows any and everything with the sole exception of UEFI bootable devices or, since it can certainly access a non-GPT drive/partition, I wonder if an MBR boot device could work under such circumstances. Probably not is my guess but thought maybe someone might know for certain.

Didier Spaier 06-24-2019 03:28 AM

Quote:

Originally Posted by enorbet (Post 6008382)
This is why I'm wondering about the strictness of the rules of UEFI. I don't know if UEFI disallows any and everything with the sole exception of UEFI bootable devices or, since it can certainly access a non-GPT drive/partition, I wonder if an MBR boot device could work under such circumstances. Probably not is my guess but thought maybe someone might know for certain.

UEFI booting is allowed with a GPT disk layout as with a MBR disk layout, provided that the layout includes a partition of type "ESP" (EFI System Partition) with a FAT filesystem in which an EFI boot executable is installed. The UEFI specification states that an EFI System partition has a GUID of C12A7328-F81F-11D2-BA4B-00A0C93EC93B for a GPT layout. In case of a DOS (ka MBR) layout instead, an ESP should have an OS type of 0xEF. These values are indicated in the "parttype" field of "lsblk" output and can be set by usual partitioning tools: fdisk, cfdisk, gdisk, cgdisk and parted.

Quoting the UEFI specification version 2.8, pages 111 sqq:
Quote:

  • A legacy MBR may be located at LBA 0 (i.e., the first logical block) of the disk if it is not using the GPT disk layout (i.e., if it is using the MBR disk layout). The boot code on the MBR is not executed by UEFI firmware.
  • For a bootable disk, a Protective MBR must be located at LBA 0 (i.e., the first logical block) of the disk if it is using the GPT disk layout. The Protective MBR precedes the GUID Partition Table Header to maintain compatibility with existing tools that do not understand GPT partition structures.

So the UEFI firmware does not use a MBR, but the UEFI specification allows to have one in a GPT layout. This way the same disk can be used to boot in EFI mode as in Legacy mode, if the firmware provides both.

deretsigernu 06-28-2019 05:45 PM

I am still working on this issue.

With UEFI enabled, the install ISO DVD takes more than 15 minutes to start to do anything. I found this out by accident. I originally thought that there was something wrong with the ISO DVD, because of how long it takes. I started the computer with the DVD in place and the HP start up splash screen comes up and after a few seconds there is a "Welcome to GRUB" message in the upper corner and then the process seems to hang. Almost 20 minutes later I get a prompt:
Quote:

GNU GRUB

Minimal BASH-like scripting...

grub>
This is new for me. Normally, the ISO DVD will start and run on its own. In the normal run of the DVD, there is a prompt that you skip the first time, then you log in as root, then you start the set up process and go through all the automated steps. Now, it's waiting for me to do something and I don't know what to do. TAB will give me options, but I don't know which to use.

If I type "root", it says that it doesn't recognize the command.

If I type "boot", it says "error: you need to load a kernel first".

If I type "linux", it says "error: filename expected".

If Legacy is enabled, I can use the USB drive to start slackware or I can run the ISO DVD normally to set up and install, but I can't use the HDD. I think I messed up the boot sector from my first attempt at installing slackware. On my first try at installing, I tried to use the default setting for LILO. Since then, I can't get into the HDD when Legacy is enabled.

During the multiple slackware installs that I've made, one of the steps includes a screen with the following message. I'm including it for informational purposes:
Quote:

EFI SYSTEM PARTITION RECOGNIZED
Adding this information to your /etc/fstab:
/dev/sda1 /boot/efi vfat default 1 0
My partitions according to the ISO setup are:
Quote:

/dev/sda1 260M EFI System
/dev/sda2 16M Microsoft reserved
/dev/sda3 170.9G Microsoft basic data
/dev/sda4 8G Linux swap
/dev/sda5 890M Windows recovery environment
/dev/sda6 240G Microsoft basic data
/dev/sda7 45.7G Linux filesystem
sda6 is a partition I created to share data between Windows and slackware.

I don't care if the computer uses UEFI or Legacy, but it's hard for me to pick which one to use.

In Legacy mode, slackware is installed, but I seem to have no Windows, unless I get the HDD boot (error: no OS installed) fixed somehow.

In UEFI, I can't get the ISO to finish installing/configure slackware or otherwise somehow get a boot manager to recognize that there is a linux partition in place, so I only get Windows to boot.

I'm open to suggestions. Explicit suggestions. For now, I'm going to try to run the System Rescue CD again to see if it fixes the HDD boot.


All times are GMT -5. The time now is 08:29 AM.