-   Slackware (
-   -   lilo not booting my SATA winxp drive (

thrice 10-15-2004 12:23 AM

lilo not booting my SATA winxp drive
i recently got a sata 120 gig harddrive to add to the 80 gig and 6.4 gig(for backups) ide harddrives that i have. first off, my winxp cd couldn't recognize my sata drive when it was set to IDE3, so i had to unplug my other harddrives so that my sata drive could get IDE 1 Master. after getting windows installed, i deleted everything on my older 80 gig and reinstalled slackware over it (during install, i had to unplug my sata drive for hte cd to kept trying to recognize the drive, but it wasn't able to). after installing slack, i recompiled the kernel with 2.8.1 and was then able to mount and recognize my sata drive. now that i was able to see the drive (sda1), i ran liloconfig, set up my Slackware boot option and then my Windows boot option (choosing sda1 to boot with) and installed it on the superblock of my linux (80 gig) harddrive. now when i boot up my computer, i get both options, but only booting into winxp works. when i choose windows, it just says "Loading WinXP...." (WinXP is my windows install identifier in Lilo) and nothing happens. What could be the problem? its been several months since i've been able to use linux, so i apologize if this is a newbie question. i don't have any experience with sata drives (especially in linux) so this is all very new to me. any help would be greatly appreciated.

predator.hawk 10-15-2004 12:51 AM

SDA1 refers to the partition.......... Recheck the partition numbers and setup lilo by hand.

thrice 10-15-2004 01:08 AM

well this is what cfdisk says about my sata disk


]    sda1          Boot          Primary      NTFS                [                  120031.52

and this is what is in my lilo.conf....

Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda2
label = Slack
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda1
label = WinXP
# map-drive = 0x80
# to = 0x81
# map-drive = 0x81
# to = 0x80
table = /dev/sda
# Windows bootable partition config ends

that should work, right?

gbonvehi 10-15-2004 01:56 AM

Try adding boot-as=0x80
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda1
label = WinXP

thrice 10-15-2004 02:50 AM

wtf. that worked...why??
wtf is "boot-as=" and where'd you get the "0x80"? does that mean boot as IDE or something?
thanks a lot for the info though. never ever would have figured that out.
thanks again

gbonvehi 10-15-2004 03:02 AM

Take a look at: man lilo.conf
That's where I first saw it and worked like a charm when the default (without it) didn't work. :)

All times are GMT -5. The time now is 02:14 PM.