LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-20-2009, 11:35 PM   #1
Vilius
Member
 
Registered: Jan 2006
Location: Lithuania
Distribution: Arch, Debian
Posts: 193

Rep: Reputation: 16
Lilo install failing in expert mode ?


Hi,

Yesterday I tried to install Slackware 12.2. Everyting went OK except LILO. When I tried to install it I got:
Syntax error at or above line 9 in file '/etc/lilo/conf'

I'm trying to install it on second primary partition on IDE disk. Disk is configured as slave. Partition device is /dev/hdb2. hdb2 is marked as active. I have some other partitions and don't want lilo to include them so using expert mode. I need it to be installed on root superblock not in MBR.
So after choosing options listed above I got:
Syntax error at or above line 9 in file '/etc/lilo/conf'

What I'm doing wrong ?

This is lilo.conf as it is showed from setup menu "show current lilo.conf" (I've skipped comment lines):
#
#
#
#
boot =
#
#
message = /boot/boot_message.txt

#
append=" vt.default_utf8=0"
#
#
#
vga = normal
#
#
#
#
image = /boot/vmlinuz
root = /dev/hdb2
label = slack
read-only
#

thanks in advance
Vilius

Last edited by Vilius; 01-20-2009 at 11:53 PM.
 
Old 01-20-2009, 11:51 PM   #2
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Quote:
Originally Posted by Vilius View Post
#
#
boot =
#
#
message = /boot/boot_message.txt

#
append=" vt.default_utf8=0"
#
#
#
vga = normal
#
#
#
#
image = /boot/vmlinuz
root = /dev/hdb2
label = slack
read-only
I think you need ...

Code:
boot = /dev/hdb2
... to put it on the root partition superblock
 
Old 01-21-2009, 12:08 AM   #3
Vilius
Member
 
Registered: Jan 2006
Location: Lithuania
Distribution: Arch, Debian
Posts: 193

Original Poster
Rep: Reputation: 16
But this file is generated automatically by setup. So it generates wrong lilo.conf ?

If so, how do I change lilo.conf -
I've never booted new installed system because of my problem and (correct me if I'm wrong) - when I boot from Slackware DVD - lilo.conf resides not in /etc, but in /mnt/etc, and if I change /mnt/etc/lilo.conf - it's changes are not shown in setup "View your current /etc/lilo.conf" - even if I don't choose new lilo header.
What should I do ?

thanks
Vilius

Last edited by Vilius; 01-21-2009 at 12:16 AM.
 
Old 01-21-2009, 12:31 AM   #4
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Quote:
Originally Posted by Vilius View Post
But this file is generated automatically by setup. So it generates wrong lilo.conf ?
Well, it is expert mode and I think that takes it out of the automatically generated category, at least somewhat.

I do not have a bootable install media handy at the moment and do not know the installer options very well from memory, so unfortunately I cannot walk through it.

But, maybe you could use the default (ie, non-expert) mode and just remove the other unwanted partition references after you get it installed? But if you put the lilo record on the root device partition you will of course have to have a reference to that device in the boot device MBR, making it active will not do that for you. It does not matter that the partition is set active as far as lilo is concerned.

I may not clearly understand just how you want to boot it, so could you provide a more complete list of your partitions, what your boot device is
and what is on the MBR (or what manages the MBR record). And just to confirm it, I assume that you can boot to the install CD/DVD and mount the hdb2 device, is that correct?
 
Old 01-21-2009, 02:34 AM   #5
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
Originally Posted by astrogeek View Post
But if you put the lilo record on the root device partition you will of course have to have a reference to that device in the boot device MBR, making it active will not do that for you. It does not matter that the partition is set active as far as lilo is concerned.
Lilo may not care about bootable partitions but I do have an Intel board here that will refuse to see a drive as bootable unless it has an "Active" partition on it :/
 
Old 01-21-2009, 03:34 AM   #6
Vilius
Member
 
Registered: Jan 2006
Location: Lithuania
Distribution: Arch, Debian
Posts: 193

Original Poster
Rep: Reputation: 16
My concern now is to finish lilo setup successfully - I won't have any problems by referencing it from boot MBR (it's on another disk, not linux os loader in MBR).
When I boot from dvd device hdb2 is mounted automatically on /mnt. I'll try to modify lilo.conf there by your suggestion. When I'll try to install by using setup's "Reinstall LILO using the existing lilo.conf", because "Install LILO" requires new lilo.conf.
Just I expect that by selecting "View your current /etc/lilo.conf"(and not creating new LILO Header) I'll see lilo.conf modifications I've done - but I see no modifications there - and question arises - maybe setup doesn't use /mnt/etc/lilo.conf at all ?

Expert Options:
Begin....Start LILO configuration with a new LILO header
Linux....Add a Linux partition to the LILO config
DOS......Add a DOS/Windows FAT partition to the LILO config
Install..Install LILO
Recycle..Reinstall LILO using the existing lilo.conf
Skip.....Skip LILO installation and exit this menu
View.....View your current /etc/lilo.conf
Help.....Read the Linux Loader HELP file



thanks
Vilius

Last edited by Vilius; 01-21-2009 at 03:39 AM.
 
Old 01-21-2009, 03:42 AM   #7
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Hi mRgOBLIN, and thanks,
Quote:
Originally Posted by mRgOBLIN View Post
Lilo may not care about bootable partitions but I do have an Intel board here that will refuse to see a drive as bootable unless it has an "Active" partition on it :/
Yea, good point. I was thinking only narrowly in terms of it being the second device as it is 'hdb', and assumed incorrectly that it would chain from the primary device's MBR, 'hda', in which case it seemed that being active did not matter. I see the error of my ways...

So now with my point of view rattled, it looks as if Vilius wants to boot directly into hdb2 - no hda chain and no bootloader in hdb MBR - just BIOS detection of active partition, does that sound right? In that case the system BIOS would have to allow booting to the second IDE device and making 'hdb2' active would come into play, probably not a problem with recent BIOS...

So we are back to the first point that lilo.conf still must have boot = /dev/hdb2 set to install to the root partition. So it should really just be a matter of getting that line into lilo.conf and running lilo.

I do not have bootable media available right now so hopefully someone can verify the actual file location, best way to edit it at install time.
 
Old 01-21-2009, 04:21 AM   #8
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: Disabled
Hi together,

in my opinion it is not necessary to install lilo in expert-mode in this case.
While running the slackware-setup you can choose installing lilo automatically and later you will be asked if you want lilo to be installed in MBR of the disk or in MBR of the rootpartition (which would be the correct choise for Vilius).

Markus
 
Old 01-21-2009, 06:41 AM   #9
gegechris99
Senior Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 15.0 64bit
Posts: 1,159
Blog Entries: 5

Rep: Reputation: 392Reputation: 392Reputation: 392Reputation: 392
Quote:
Originally Posted by Vilius View Post
My concern now is to finish lilo setup successfully - I won't have any problems by referencing it from boot MBR (it's on another disk, not linux os loader in MBR).
When I boot from dvd device hdb2 is mounted automatically on /mnt.
When you boot with DVD, you need to chroot to your mounted environment before being able to modify your lilo.conf and apply those changes: run the following commands:

Code:
mount -o bind /dev  /mnt/dev   # populates /mnt/dev with detected devices before chroot
mount -o bind /proc /mnt/proc
chroot /mnt
vi /etc/lilo.conf              # <make the change,save and exit>
/sbin/lilo                     # apply the changes
 
Old 01-21-2009, 09:00 AM   #10
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 232Reputation: 232Reputation: 232
Quote:
When I boot from dvd device hdb2 is mounted automatically on /mnt.
Hava a close look at the prompt when booting up the Slackware DVD. It tells you that you may boot into your system with the command :

Code:
boot: hugesmp.s root=/dev/hda1 rdinit= ro
In you case as the newly installed Slackware is on /dev/hdb2 you command is :
Code:
boot: hugesmp.s root=/dev/hdb2 rdinit= ro
You could then run liloconfig as root choosing "simple" and "install to superblock". Alternatively you could edit/create /etc/lilo.conf and run lilo as root to install. Should you need to create a new lilo.conf this should do:

Code:
boot = /dev/hdb2
append=" vt.default_utf8=0"
vga = normal
image = /boot/vmlinuz
root = /dev/hdb2
label = slack
read-only
 
Old 01-21-2009, 10:58 AM   #11
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
This won't work if there are any *bootable* partitions before in hda or hdb1 is also bootable. The BIOS should look at MBR and if it is empty it will cycle through primary and extended partitions searching for boot record.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Minesweeper expert mode: impossible game? vharishankar General 7 09-08-2008 09:23 AM
Where is expert mode in fedora core 2 mahendra Fedora 1 10-15-2004 01:42 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 05:00 PM
lilo install failing on install bindsocket Slackware - Installation 5 12-22-2003 07:58 AM
LILO install failing, Boot failing, but Installation fine. sramelyk Slackware 9 08-23-2003 02:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration