LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-01-2013, 01:55 AM   #1
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 73

Rep: Reputation: Disabled
LILO don't show the generic kernel.


Hi,
After installing successfully Slackware, I tried to switch to the generic kernel. So, I folloed the instructions here: http://docs.slackware.com/slackware:...generic_kernel

Here is my lilo.conf.
Code:
image = /boot/vmlinuz-generic-3.2.29
  initrd = /boot/initrd.gz 
  root = /dev/sda3
  label = Slackware Linux generic
  read-only

image = /boot/vmlinuz
  root = /dev/sda3
  label = Slackware Linux failsafe # labeled "Linux" before editing.
  read-only
However, when I run
Code:
# lilo -v
, messages appearing normally until
Code:
Unrecognized token "Linux" at or above Line 65 in file /etc/lilo.conf
Then, after reboot, LILO only displayed "Linux" as an option, as before trying to switch to the generic kernel.

Last edited by lensilvan; 07-01-2013 at 02:03 AM.
 
Old 07-01-2013, 02:07 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,184

Rep: Reputation: Disabled
Try not to use spaces in the name of the label.
Untested by me: enclose the label in double quotes if you keep insisting on using spaces.

Eric
 
Old 07-01-2013, 02:10 AM   #3
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,646

Rep: Reputation: 568Reputation: 568Reputation: 568Reputation: 568Reputation: 568Reputation: 568
Quote:
Originally Posted by lensilvan View Post
Code:
image = /boot/vmlinuz-generic-3.2.29
  initrd = /boot/initrd.gz 
  root = /dev/sda3
  label = Slackware Linux generic
  read-only

image = /boot/vmlinuz
  root = /dev/sda3
  label = Slackware Linux failsafe # labeled "Linux" before editing.
  read-only
The label can be max 16 characters long and must not include spaces.

So it is not installing the new stanzas and you are still seeing the original installed Linux stanza.

Try some new labels and see what it says.

[EDIT]
Also - are you really intending to use the generic, or should that be the generic-smp kernel?
[/EDIT]

Last edited by astrogeek; 07-01-2013 at 02:37 AM. Reason: changed only to max, added better description
 
Old 07-01-2013, 03:57 AM   #4
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 73

Original Poster
Rep: Reputation: Disabled
Fine, now everything works. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiled custom kernel; Network devices don't show up? steviebob Slackware 5 04-12-2012 02:57 PM
[SOLVED] Software RAID 1 vs. LILO vs. kernel-generic kikinovak Slackware 4 07-03-2011 03:06 AM
[SOLVED] setting up initrd / generic kernel in Grub2...can't load generic Ubunoob001 Slackware 8 01-05-2011 11:37 PM
kernel-generic-2.6.12.5 lilo Slinky Slackware 2 09-04-2005 01:04 PM
run /sbin/lilo after update IF you use LILO (don't know) jdblick Suse/Novell 3 12-28-2004 03:06 PM


All times are GMT -5. The time now is 02:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration