LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-26-2007, 04:30 PM   #1
agentc0re
Member
 
Registered: Apr 2007
Location: SLC, UTAH
Distribution: Slackware
Posts: 200

Rep: Reputation: 34
libtool.m4 and ltmain.sh version mismatch


I am trying to compile spine for cacti. When i run the ./configure, this is what i get.
Code:
configure: error:

*** [Gentoo] sanity check failed! ***
*** libtool.m4 and ltmain.sh have a version mismatch! ***
*** (libtool.m4 = 1.5.22, ltmain.sh = 1.5.24) ***

Please run:

  libtoolize --copy --force

if appropriate, please contact the maintainer of this
package (or your distribution) for help.
i did run libtoolize --copy --force
Code:
root@yoda:/tmp/cacti-spine-0.8.7-src-1# libtoolize --copy --force
Putting files in AC_CONFIG_AUX_DIR, `config'.
I have no idea what that is trying to tell me to do.

I am running Slack 12. Did a full install. Also checked to make sure i had the right version of libtool's pkg and i have 1.5.24.
uname -a
Code:
Linux yoda 2.6.23.1-smp #1 SMP Tue Nov 13 17:07:10 MST 2007 i686 Intel(R) Xeon(R) CPU           E5335  @ 2.00GHz GenuineIntel GNU/Linux
 
Old 11-26-2007, 05:22 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,756

Rep: Reputation: 6339Reputation: 6339Reputation: 6339Reputation: 6339Reputation: 6339Reputation: 6339Reputation: 6339Reputation: 6339Reputation: 6339Reputation: 6339Reputation: 6339
Before your "./configure ..." command, run this single line and all will be well:
Code:
autoreconf --force --install --symlink
Eric
 
1 members found this post helpful.
Old 11-26-2007, 07:30 PM   #3
agentc0re
Member
 
Registered: Apr 2007
Location: SLC, UTAH
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 34
Alright, that worked. Thank you Eric.

I do have a couple of questions as to why you might think this happened? Is it a bug in slack? Possible that i may have done something wrong?


also here was that out put, not sure if it's useful or worthless
Code:
/usr/share/aclocal/nspr.m4:8: warning: underquoted definition of AM_PATH_NSPR
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/share/aclocal/imlib.m4:9: warning: underquoted definition of AM_PATH_IMLIB
/usr/share/aclocal/imlib.m4:167: warning: underquoted definition of AM_PATH_GDK_IMLIB
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of AM_PATH_AUDIOFILE
/usr/share/aclocal/aalib.m4:12: warning: underquoted definition of AM_PATH_AALIB
Putting files in AC_CONFIG_AUX_DIR, `config'.
/usr/share/aclocal/nspr.m4:8: warning: underquoted definition of AM_PATH_NSPR
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/share/aclocal/imlib.m4:9: warning: underquoted definition of AM_PATH_IMLIB
/usr/share/aclocal/imlib.m4:167: warning: underquoted definition of AM_PATH_GDK_IMLIB
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of AM_PATH_AUDIOFILE
/usr/share/aclocal/aalib.m4:12: warning: underquoted definition of AM_PATH_AALIB
 
Old 11-27-2007, 12:03 AM   #4
agentc0re
Member
 
Registered: Apr 2007
Location: SLC, UTAH
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 34
The one thing i've notice is that it's a one time fix. If i delete that build dir, recreate it and try to run the ./configure again, i get the same mismatch error and have to run that fix you gave me Eric.
Is it not supposed to be a permanent fix?
 
Old 11-27-2007, 01:36 AM   #5
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,897

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
The problem is in the sources, not with your installation. The command is quite useful for fixing many problems in autoconf sources. If you want to keep a saintized tarball of the sources, simply run the command, but without --symlink, then run 'make distclean' and then create a new archive of the sources.
The short version is 'autoreconf -if'. src2pkg uses this command in a couple of places when it 'knows' that the sources are not 'sane'.
 
Old 12-29-2007, 02:48 AM   #6
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
I have a similar issue, but when running the autoconf, I get this:
Code:
 autoreconf --force --install --symlink
aclocal: unrecognized option -- `-I.'
Try `aclocal --help' for more information.
autoreconf: aclocal failed with exit status: 1
Ideas?
 
Old 12-29-2007, 06:24 AM   #7
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,897

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
Sometimes autoreconf exits with an error code which is usually non-fatal. After running autorecond, run autoconf and see if that exits without error. If so, you should be set to go.
One tip -if the sources contains a script called autogen.sh it's better to run that instead of autoreconf.

If all that fails, try something like this, which is one of the ways that src2pkg trioes to resolve these errors:

Code:
# leave off '-I .' if it complains
aclocal -I .
autoheader
# try either one of these
# automake --add-missing --copy --foreign
automake -a --force --copy --foreign
# run this if needed
#libtoolize --copy --force
autoconf
Sometimes you need to run automake twice, the first time with no options just after running aclocal

Another thing that sometimes is a problem is that old temporary config files are still in the sources. So doing this is a good idea as well:

Code:
rm -rf ./autom4te.cache
rm -rf ./.deps
rm -f ./config.status
rm -f ./config.cache
If that doesn't work, I'd really complain to the developer.
 
Old 11-29-2019, 04:31 PM   #8
Nick-us
Member
 
Registered: Feb 2019
Distribution: Slackware64-Current
Posts: 51

Rep: Reputation: 8
Thumbs up

Quote:
Originally Posted by Alien Bob View Post
Before your "./configure ..." command, run this single line and all will be well:
Code:
autoreconf --force --install --symlink
Eric
I know this post is 12 years old!
But right now it helped me a lot!

I am trying to compile the gcolor2 program and the error message is the same as the question writer published, only different versions of the same problem.

Then I saw this message from AlienBOB and got excited!
But in Source there was no file autoreconf... But I didn't give up!
The closest similar name was autogen.sh

So I thought? Why not try right? Will it work?
./autogen.sh --force --install --symlink

YEAHHHH It worked!

I run after that the ./configure and make
So 12 years later TODAY thank AlienBOB for giving the solution one more time!
 
Old 11-29-2019, 09:53 PM   #9
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,814

Rep: Reputation: Disabled
Quote:
Originally Posted by Nick-us View Post
I know this post is 12 years old!
But right now it helped me a lot!

I am trying to compile the gcolor2 program and the error message is the same as the question writer published, only different versions of the same problem.

Then I saw this message from AlienBOB and got excited!
But in Source there was no file autoreconf... But I didn't give up!
The closest similar name was autogen.sh

So I thought? Why not try right? Will it work?
./autogen.sh --force --install --symlink

YEAHHHH It worked!

I run after that the ./configure and make
So 12 years later TODAY thank AlienBOB for giving the solution one more time!
autoreconf is not providing in the src tarball, but its part of the autoconf package and those arguments are generally not used by individual autogen.sh scripts which can differ from project to project if they even exist.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ABI version mismatch with server version rjpilla Ubuntu 1 10-03-2006 11:03 PM
help, gcc version and kernel version mismatch akanitkar Linux - Newbie 1 05-06-2006 08:02 AM
API version mismatch Harold Programming 1 03-30-2006 01:26 PM
Kernel version Source Version mismatch after recompile chuckleberry Linux - Software 1 06-20-2005 07:37 PM
kernel version mismatch jimo Linux - Software 3 10-29-2001 02:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration